summaryrefslogtreecommitdiff
path: root/x11-terms
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-03-23 00:31:41 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-03-23 00:31:41 +0000
commitadd1c3acddd7a3f49fdb230135725463d2662921 (patch)
tree9cbe35db675b23a6afadbe3a78f9944ea8990f18 /x11-terms
parent6fe1dafaa446d9bc41dea28a43551fffa73f6b87 (diff)
gentoo auto-resync : 23:03:2025 - 00:31:41
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/Manifest.gzbin5055 -> 5055 bytes
-rw-r--r--x11-terms/tilda/Manifest2
-rw-r--r--x11-terms/tilda/tilda-2.0.0.ebuild32
3 files changed, 34 insertions, 0 deletions
diff --git a/x11-terms/Manifest.gz b/x11-terms/Manifest.gz
index 39042c5f4344..7ce8fafbcf84 100644
--- a/x11-terms/Manifest.gz
+++ b/x11-terms/Manifest.gz
Binary files differ
diff --git a/x11-terms/tilda/Manifest b/x11-terms/tilda/Manifest
index 61bfa5526166..632edba36a3c 100644
--- a/x11-terms/tilda/Manifest
+++ b/x11-terms/tilda/Manifest
@@ -1,3 +1,5 @@
DIST tilda-1.5.4.tar.gz 485611 BLAKE2B beced68e0712fdc3f4f46a1d839a87e91ecf7e84dec500908efa510d7b43d0c0bf6b5e296c3df255ea462cf08f5107aa324d5a0a6abb134917a054366912a068 SHA512 6982a14a89d148c04e08df0c7566ea7b3e340252fa1a3e434450443f7464e6805caee46afda9b385633a4b9c22d2f2d283641082a1e009f301c3a1bf508c3b29
+DIST tilda-2.0.0.tar.gz 532550 BLAKE2B a445b180ba921dbea3441b82c60350e9cfefcc40464258db91d361b9815533af864eb27cc7de35512415faf495d7303daddfe84378ed8002aef8fc3605a6508f SHA512 e68c04e1c8dd862ab850a06036d67544a910ccd3143eb9d33171d551f34ef47445d6b387bf087ada6f3deddcf115ba928f3bb0497b8a3d2305b202b3b84fd476
EBUILD tilda-1.5.4.ebuild 725 BLAKE2B 5a16757fa6b618e2871a83c0b32568981b7bab0a98c73e821946150b2b4cae0ca39405cbb28b8193b3e4508d9edacc8b975461ebea07c9d8776046921f9f986f SHA512 b66e117f6b2748abd142f37d0ad7654c304f61533d084947e5306b5719ff62ccf965ae8658f6e7d84b4a7682b97122531b604d707e39bee91f7198586da9ad40
+EBUILD tilda-2.0.0.ebuild 728 BLAKE2B 7733c6e663f9aec6ef805cfafaff0edf71c641edea5530df37eb61cc454923fcd73d36537862cc060610587ffa6198ca8b952e289c9e08ce59cb8a1f3df8938c SHA512 a854e920a0eca7e122c2d58d1085dbede461e886e0f5bb5a0526f36ccfdd59a9d29c673b7ed359d67b7297ec4752adb20c4063ededb904e81bbfa24e1291a92e
MISC metadata.xml 295 BLAKE2B a0b1d1c7cc0bcb98be694fcc9a07e90e1c67e33e049742d9cd7c9d33e1aa8c7bf0702cee72b26838e924a5e3770ca9ebdb1bf1ab8da619654a99293e24d4839a SHA512 e4e5f614f6c0c6e433d05b8d5882b2f66f7de5aeefd64caf27a907498070776c7c26972c0c1e285241bb9aa9d1f6a22de4622adaff442c9d7ab35ff7cf13fdfc
diff --git a/x11-terms/tilda/tilda-2.0.0.ebuild b/x11-terms/tilda/tilda-2.0.0.ebuild
new file mode 100644
index 000000000000..3bd733e380dd
--- /dev/null
+++ b/x11-terms/tilda/tilda-2.0.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="A drop down terminal, similar to the consoles found in first person shooters"
+HOMEPAGE="https://github.com/lanoxx/tilda"
+SRC_URI="https://github.com/lanoxx/tilda/archive/${P}.tar.gz"
+
+S="${WORKDIR}/${PN}-${P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="x11-libs/vte:2.91
+ >=dev-libs/glib-2.8.4:2
+ dev-libs/confuse:=
+ gnome-base/libglade
+ x11-libs/gtk+:3
+ x11-libs/libX11"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig
+ sys-devel/gettext"
+
+src_prepare() {
+ default
+ append-cflags -std=c99
+ eautoreconf
+}