summaryrefslogtreecommitdiff
path: root/x11-terms/zutty/zutty-0.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-27 06:06:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-27 06:06:27 +0000
commit8d5dbd847cbc704a6a06405856e94b461011afe3 (patch)
tree4d26462d027b14926335894749d2e01d982234d0 /x11-terms/zutty/zutty-0.8.ebuild
parent5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (diff)
gentoo resync : 27.03.2021
Diffstat (limited to 'x11-terms/zutty/zutty-0.8.ebuild')
-rw-r--r--x11-terms/zutty/zutty-0.8.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/x11-terms/zutty/zutty-0.8.ebuild b/x11-terms/zutty/zutty-0.8.ebuild
new file mode 100644
index 000000000000..d4ab66148fff
--- /dev/null
+++ b/x11-terms/zutty/zutty-0.8.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit python-any-r1 waf-utils
+
+DESCRIPTION="X terminal emulator rendering through OpenGL ES Compute Shaders"
+HOMEPAGE="https://tomscii.sig7.se/zutty/ https://github.com/tomszilagyi/zutty"
+SRC_URI="https://github.com/tomszilagyi/zutty/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+COMMON_DEPEND="
+ media-libs/freetype:2
+ media-libs/libglvnd[X]
+ x11-libs/libXmu"
+DEPEND="
+ ${COMMON_DEPEND}
+ ${PYTHON_DEPS}"
+RDEPEND="${COMMON_DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( doc/KEYS.org doc/USAGE.org )