summaryrefslogtreecommitdiff
path: root/x11-terms/yeahconsole/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-terms/yeahconsole/files
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-terms/yeahconsole/files')
-rw-r--r--x11-terms/yeahconsole/files/yeahconsole-0.3.4-make.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/x11-terms/yeahconsole/files/yeahconsole-0.3.4-make.patch b/x11-terms/yeahconsole/files/yeahconsole-0.3.4-make.patch
new file mode 100644
index 000000000000..0075c433292b
--- /dev/null
+++ b/x11-terms/yeahconsole/files/yeahconsole-0.3.4-make.patch
@@ -0,0 +1,30 @@
+--- a/Makefile 2006-01-14 16:54:05.000000000 +0100
++++ b/Makefile 2009-02-26 16:18:25.000000000 +0100
+@@ -1,6 +1,4 @@
+ TARGET = yeahconsole
+-CC = gcc
+-#CC = cc
+ INSTALL = install
+
+ PREFIX = /usr/local
+@@ -8,17 +6,16 @@
+ LIBS = -lX11
+ INCLUDES = -I/usr/X11R6/include
+ LIB_DIRS = -L/usr/X11R6/lib
+-FLAGS = -Os -Wall
++FLAGS = -Wall $(CFLAGS)
+
+ OBJECTS := yeahconsole.o
+ SOURCES := yeahconsole.c
+
+ $(TARGET): $(OBJECTS)
+- $(CC) $(DEFINES) $(INCLUDES) $(LIB_DIRS) $(LIBS) -o $@ $<
+- strip $@
++ $(CC) $(FLAGS) $(LDFLAGS) $(DEFINES) $(INCLUDES) $(LIB_DIRS) -o $@ $< $(LIBS)
+
+ $(OBJECTS): $(SOURCES)
+- $(CC) $(FLAGS) $(DEFINES) $(INCLUDES) $(LIB_DIRS) -c -o $@ $<
++ $(CC) $(FLAGS) $(DEFINES) $(INCLUDES) $(LIB_DIRS) -c -o $@ $<
+
+ clean:
+ rm -rf $(TARGET) $(OBJECTS)