summaryrefslogtreecommitdiff
path: root/x11-terms/tilda
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /x11-terms/tilda
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'x11-terms/tilda')
-rw-r--r--x11-terms/tilda/Manifest2
-rw-r--r--x11-terms/tilda/tilda-1.5.2.ebuild32
2 files changed, 34 insertions, 0 deletions
diff --git a/x11-terms/tilda/Manifest b/x11-terms/tilda/Manifest
index 970ee58a1a15..bfffc95f0d45 100644
--- a/x11-terms/tilda/Manifest
+++ b/x11-terms/tilda/Manifest
@@ -1,5 +1,7 @@
DIST tilda-1.4.1.tar.gz 471340 BLAKE2B a84d125bf81e384706347401ebbf7b11813bf5ed422e6b374e918ed564b9bfe168ebf3fef163b91a15350b49166b0040e90afdef716cc1762ecc410710f72c29 SHA512 d16878e762d94f94c219e8e711223a771a2ab816f02573f693cfbcfa0eee5aafff8a274898a65df168c0bf78258aa16e5a3be6b0c3dee418af61c68f43ed74c6
DIST tilda-1.5.0.tar.gz 484754 BLAKE2B 8f04a5046b642e0cd67d375817d046920bbefd9b499458c2dab90f9801b0a4009b7b06cfe29af01095f1627581e4577ba5a7405948b29d21e233db288da48efd SHA512 2876b3ffbc5dd663b10c2f5fc7e6b838d6e3e18f30eb62afe07d9615b4567b04fba0b1efb2449204f4a5b78a90198092e397a24a41b978862d4fc6fab0b8de81
+DIST tilda-1.5.2.tar.gz 485261 BLAKE2B 2ce0059ad695ac3e920cf8e40841b850967ff1e05b88a1c527b7154112c88a3435b66d0f31b882b6fdaf0dee038b7a7e6ab0401184ab701bed8d23d44a2856d8 SHA512 5f950696626005d6f8711fe1403313b36f065796ac07946e9782997aaf67a4bfdb3bfa5e37889bff95d77655d3546100a48327bfa175aa24c39a28685ee0306a
EBUILD tilda-1.4.1.ebuild 695 BLAKE2B 33d4ffd0915fcbc42591161eba09ec2a36ad63c45ca31f85b9d471afb9ad5cad1fbe7277b1714153d12c43b1dfcee0cea2764dc08c401727b2ccbf97dfa241a5 SHA512 440c50ad4f9c5e738d948951848f25bfbd9a167374bbbb1cc264594d09911759fa5c5df9d35013db1a4f6411c2ed218252fce532563df42a9a10f51cba2edda6
EBUILD tilda-1.5.0.ebuild 698 BLAKE2B 339df837f44a5c428b6b13639f5a55c5d34734daf59accff528f769e73187955a2a098ba1069eacdc3d8b3330130be71538e5c810aa11a09b395edb5b01a8308 SHA512 e577adb64da6f0be2635d0c1761d3d63099aaae0721cd62f05e1117224f9165af851e88987682ca1345c1d21f13d8e3e14b15059c2c98dac25b747164659a181
+EBUILD tilda-1.5.2.ebuild 698 BLAKE2B 339df837f44a5c428b6b13639f5a55c5d34734daf59accff528f769e73187955a2a098ba1069eacdc3d8b3330130be71538e5c810aa11a09b395edb5b01a8308 SHA512 e577adb64da6f0be2635d0c1761d3d63099aaae0721cd62f05e1117224f9165af851e88987682ca1345c1d21f13d8e3e14b15059c2c98dac25b747164659a181
MISC metadata.xml 319 BLAKE2B 69510b8b8d8658d9cc6884a960bd6b2511da1ae40e771c1edcfa836b0f1033bd4b66d5cbdb3d664108d90d0afa77de6caacb42f8f0bed5d9f8c88abeb34463d4 SHA512 013ac97bba6505168215a97c531a4fcac607b678aaf804ffdfb44611b61e930709621bedd71f7fbea06b25f8bd7000530f878cf57c419c9938afd61155ff060a
diff --git a/x11-terms/tilda/tilda-1.5.2.ebuild b/x11-terms/tilda/tilda-1.5.2.ebuild
new file mode 100644
index 000000000000..b7827af4144d
--- /dev/null
+++ b/x11-terms/tilda/tilda-1.5.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="A drop down terminal, similar to the consoles found in first person shooters"
+HOMEPAGE="https://github.com/lanoxx/tilda"
+SRC_URI="https://github.com/lanoxx/tilda/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="x11-libs/vte:2.91
+ >=dev-libs/glib-2.8.4:2
+ dev-libs/confuse:=
+ gnome-base/libglade
+ x11-libs/gtk+:3
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ sys-devel/gettext"
+
+S="${WORKDIR}/${PN}-${P}"
+
+src_prepare() {
+ default
+ append-cflags -std=c99
+ eautoreconf
+}