summaryrefslogtreecommitdiff
path: root/x11-terms/terminology
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
commite23a08d0c97a0cc415aaa165da840b056f93c997 (patch)
tree4c5f7db60483518201fef36f8cc0712789a08db2 /x11-terms/terminology
parent391b5b359a346aff490103da7dddc85047f83830 (diff)
gentoo resync : 08.10.2021
Diffstat (limited to 'x11-terms/terminology')
-rw-r--r--x11-terms/terminology/Manifest2
-rw-r--r--x11-terms/terminology/terminology-1.10.0.ebuild56
2 files changed, 58 insertions, 0 deletions
diff --git a/x11-terms/terminology/Manifest b/x11-terms/terminology/Manifest
index 9920558cd933..7344546814ec 100644
--- a/x11-terms/terminology/Manifest
+++ b/x11-terms/terminology/Manifest
@@ -1,3 +1,5 @@
+DIST terminology-1.10.0.tar.xz 4984496 BLAKE2B f8ca3e30686057a95d3d37993680e436c30df64fa058ebfdc5faeb2c4695b1e7277a542c4d92870d89e006db408b93b1cc99f1d2d5037023b1525662ab95192d SHA512 2afd253da27a49bf4d306bcc92fb14148c7f2df1116de8422a60be128be8483042ae61457805ce446d863b5671c6d1613d77efc811167a786f3968f68964dae1
DIST terminology-1.9.0.tar.xz 4971192 BLAKE2B 840da3f9c5432d795fc21418b24a351e6c3057566339c673c2de7c08ff16db9d65cbb431ac1151cb85f035a577b509339fbf6eed68197ac96d67dd59c6a67cb1 SHA512 03955899f320b9d018d9e8a4a195b298e35052e6b5fa7d6c804f1810edf9ef55cac02e8d8c7261e1b890e8a453fce6418dc53a37abe499067688d3e16fdff9f1
+EBUILD terminology-1.10.0.ebuild 1252 BLAKE2B 139c8f3f7c39bd1ed5140c9c46a7a2875c4d02900188b4802ebb3fb11c44e237c9b746f7382fd0a3d6b54da5e5c335ae1b305dbf7ea9ee48e86da692f4d602ce SHA512 f7ea6b62a1af250b0ddba884072d258dc109595632d23c21ad4aa7af9350c938606163bc11555d72830bf48dced8dc4e50e6c49ca28af641957c49617e424a8e
EBUILD terminology-1.9.0.ebuild 1233 BLAKE2B a844d74d704ecda740148ec5ea454734912013637837d6cdde9d567e8e969bdac13b4aa71ff9aeef32fa9a09fc45efb986bb67ef6d0c80486813538072415f3c SHA512 fcd04d587cf2ddb2554fcef1e05418c9b709148fbaadb7f1ef09d7748fff1ff79d18d0fc58300f866ad8201a2d4503760913afe6fada78174050486e1fa0df41
MISC metadata.xml 336 BLAKE2B 6f8e4a99a9941e3a9dba25832ae43998f1cc27e85c4535494f6762f99e915aa3be299cefdd9a8e9fcd1e5d934c87de826c64c72f1e74f4a49f57aa76de73595f SHA512 12190b1f38b235ba164b13cb7bac3f24fafc65a001c9cc5d7f24fbefed5ed5cb411a563ff57a54db722a3a79b9030d8eeaaaaafa4df79b0e2758393dc9332fa0
diff --git a/x11-terms/terminology/terminology-1.10.0.ebuild b/x11-terms/terminology/terminology-1.10.0.ebuild
new file mode 100644
index 000000000000..9ba5779041f8
--- /dev/null
+++ b/x11-terms/terminology/terminology-1.10.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit meson python-any-r1 xdg-utils
+
+DESCRIPTION="Feature rich terminal emulator using the Enlightenment Foundation Libraries"
+HOMEPAGE="https://www.enlightenment.org/about-terminology"
+SRC_URI="https://download.enlightenment.org/rel/apps/terminology/${P}.tar.xz https://downloads.terminolo.gy/${P}.tar.xz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="extras nls"
+
+RDEPEND="|| ( dev-libs/efl[gles2-only] dev-libs/efl[opengl] )
+ || ( dev-libs/efl[X] dev-libs/efl[wayland] )
+ app-arch/lz4
+ dev-libs/efl[eet,fontconfig]"
+DEPEND="${RDEPEND}"
+BDEPEND="${PYTHON_DEPS}
+ virtual/libintl
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ # Fix python shebangs for python-exec[-native-symlinks], #766081
+ local shebangs=($(grep -rl "#!/usr/bin/env python3" || die))
+ python_fix_shebang -q ${shebangs[*]}
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use nls)
+ $(meson_use extras tests)
+ )
+
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}