summaryrefslogtreecommitdiff
path: root/x11-terms/terminology
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-07 22:48:01 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-07 22:48:01 +0000
commitc3bc61051d7f12b4c682efa7a5460bbc8815649e (patch)
treeb6d19e96ba3c397fb8278eeb9b68170db92630ba /x11-terms/terminology
parent3517852e3b8a68d1e997770fc0650c5053bafc6c (diff)
gentoo resync : 07.01.2022
Diffstat (limited to 'x11-terms/terminology')
-rw-r--r--x11-terms/terminology/Manifest2
-rw-r--r--x11-terms/terminology/terminology-1.12.1-r1.ebuild47
2 files changed, 49 insertions, 0 deletions
diff --git a/x11-terms/terminology/Manifest b/x11-terms/terminology/Manifest
index 7859e32d0214..ed09acf2eb43 100644
--- a/x11-terms/terminology/Manifest
+++ b/x11-terms/terminology/Manifest
@@ -1,3 +1,5 @@
DIST terminology-1.11.0.tar.xz 4984128 BLAKE2B 059de50cd9e4c94f628e992f44909a1f2dcd79ce01c48cbde2f043f08a2e22c6ded1e7de61f84bd8b37961191501a4ec32ca027c32994a1d7b1929a2270c977e SHA512 9c26c383760a497cc9bbb36aa8bd154599a708cb6bbede26fc2f5c6d6459a51d566066c4d9b64198afaadd94463ce83bca4b392551fd4ff3e68d8a4383d6c403
+DIST terminology-1.12.1.tar.xz 2722144 BLAKE2B ce6eea2fd6efe8a4a6d654f8e7899336b3bb7a1d2f1728c2ac2f1b367972c8b222e665309e2b704dd1f3bb774784d218789bcd8134348893a265c0e50fa855d9 SHA512 036f1e516d5f9c44185fc417266022bb4a3c34839451b2bd7ab64c9610e71cd1690faee014cf8364ceac12261cb9b57501446a3e6e58ac13f98f11064498a43b
EBUILD terminology-1.11.0.ebuild 1250 BLAKE2B 206fdcb16cab6a35565306e500aa6981b33ab90c818cb7a92ce3f21acc111185a1c8c2690edfa4e205af97f6e8065150f00dd6ea618cbd338258f54c8ff27702 SHA512 f0e45dd106dd9894eb18690024e3528df8982be2b8f76e649ff2ed10ff54bad730d3a32820a8917720b9650834228151ef310d496c5b644d2f6fcb34c3eff414
+EBUILD terminology-1.12.1-r1.ebuild 1117 BLAKE2B 8af1bb591bcb3d28803447f5d444e4c4fea4b5f459fdccdc1a03cd717a8aa33a9ba9fa404a9709ca1ad1fe8e85814652c8373d6af7d26c484613aad3f087ab14 SHA512 6b730dbaac2992e3d85197708cf2580019e54594e525a271a8c0ee7c96cd985231852cf3f52f1eb2b851cf2341bc321bcdf087bc7b0c845266213a0dbe5b5de3
MISC metadata.xml 336 BLAKE2B 6f8e4a99a9941e3a9dba25832ae43998f1cc27e85c4535494f6762f99e915aa3be299cefdd9a8e9fcd1e5d934c87de826c64c72f1e74f4a49f57aa76de73595f SHA512 12190b1f38b235ba164b13cb7bac3f24fafc65a001c9cc5d7f24fbefed5ed5cb411a563ff57a54db722a3a79b9030d8eeaaaaafa4df79b0e2758393dc9332fa0
diff --git a/x11-terms/terminology/terminology-1.12.1-r1.ebuild b/x11-terms/terminology/terminology-1.12.1-r1.ebuild
new file mode 100644
index 000000000000..701ba06d6caf
--- /dev/null
+++ b/x11-terms/terminology/terminology-1.12.1-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit meson python-any-r1 xdg
+
+DESCRIPTION="Feature rich terminal emulator using the Enlightenment Foundation Libraries"
+HOMEPAGE="https://www.enlightenment.org/about-terminology"
+SRC_URI="https://download.enlightenment.org/rel/apps/terminology/${P}.tar.xz https://downloads.terminolo.gy/${P}.tar.xz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="extras nls"
+
+RDEPEND="|| ( dev-libs/efl[X] dev-libs/efl[wayland] )
+ app-arch/lz4
+ >=dev-libs/efl-1.26.1[eet,fontconfig]"
+DEPEND="${RDEPEND}"
+BDEPEND="${PYTHON_DEPS}
+ virtual/libintl
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ # Fix python shebangs for python-exec[-native-symlinks], #766081
+ local shebangs=($(grep -rl "#!/usr/bin/env python3" || die))
+ python_fix_shebang -q ${shebangs[*]}
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use nls)
+ $(meson_use extras tests)
+ )
+
+ meson_src_configure
+}