summaryrefslogtreecommitdiff
path: root/x11-terms/root-tail/root-tail-1.2-r4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /x11-terms/root-tail/root-tail-1.2-r4.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'x11-terms/root-tail/root-tail-1.2-r4.ebuild')
-rw-r--r--x11-terms/root-tail/root-tail-1.2-r4.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/x11-terms/root-tail/root-tail-1.2-r4.ebuild b/x11-terms/root-tail/root-tail-1.2-r4.ebuild
index 410af2e42979..ea4f261a0a94 100644
--- a/x11-terms/root-tail/root-tail-1.2-r4.ebuild
+++ b/x11-terms/root-tail/root-tail-1.2-r4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -16,10 +16,10 @@ IUSE="kde debug"
RDEPEND="x11-libs/libXext
x11-libs/libX11"
-DEPEND="x11-misc/imake
+DEPEND="${RDEPEND}"
+BDEPEND=">=x11-misc/imake-1.0.8-r1
app-text/rman
x11-base/xorg-proto
- x11-libs/libX11
x11-misc/gccmakedep"
src_prepare() {
@@ -28,15 +28,16 @@ src_prepare() {
}
src_configure() {
- xmkmf -a
+ CC="$(tc-getBUILD_CC)" LD="$(tc-getLD)" \
+ IMAKECPP="${IMAKECPP:-$(tc-getCPP)}" xmkmf -a || die
}
src_compile() {
sed -i 's:/usr/X11R6/bin:/usr/bin:' Makefile || die "sed Makefile failed"
use debug && append-flags -DDEBUG
emake \
- CC=$(tc-getCC) \
- CCOPTIONS="${CFLAGS}" \
+ CC="$(tc-getCC)" \
+ CDEBUGFLAGS="${CFLAGS}" \
EXTRA_LDOPTIONS="${LDFLAGS}"
}