summaryrefslogtreecommitdiff
path: root/x11-terms/kitty-terminfo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-22 17:28:08 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-22 17:28:08 +0100
commitd79ab35b7ac170babebe8bc151fe5d037c16285c (patch)
treec774a4913f32e952079ae36fc6afd2dad747837f /x11-terms/kitty-terminfo
parent992aa50a54a56c9e705ca4e85d809ec8989d74a2 (diff)
gentoo auto-resync : 22:09:2022 - 17:28:08
Diffstat (limited to 'x11-terms/kitty-terminfo')
-rw-r--r--x11-terms/kitty-terminfo/Manifest2
-rw-r--r--x11-terms/kitty-terminfo/kitty-terminfo-0.26.3.ebuild23
2 files changed, 25 insertions, 0 deletions
diff --git a/x11-terms/kitty-terminfo/Manifest b/x11-terms/kitty-terminfo/Manifest
index b56e71cc49bb..9a25bac3fccd 100644
--- a/x11-terms/kitty-terminfo/Manifest
+++ b/x11-terms/kitty-terminfo/Manifest
@@ -1,4 +1,6 @@
DIST kitty-0.26.2.tar.xz 4716932 BLAKE2B fbbd1bbeb42bfb5be1348ead4605d45f93a90e31e707444c901b9f4c20b42d470c1e3cec9e0f135f04ad49bb472824fb7445932403127e8cbc639b5dac6ee982 SHA512 4bfb3d9438bb018dc10503be610df4e6e8bb1f9459b5131f46fde6279ba5423e44dbbcb86a2dc2602ee208266edc78074f6496e99761cf43f7081ea9e88175f7
+DIST kitty-0.26.3.tar.xz 4730520 BLAKE2B a2d8cccc76eb295256ac420700e941ac9cb0e79c9717a93226cc30db63ab047dcd0be2e11b36b44c7c15daa0b77a451242d32f71024cee724869ba8937b93dd5 SHA512 77a518cd3ec4bb059907f16d01068914951cadbbcf803dcbfae13cc9ce144f65a886d7e986c7191019a0be9ccf902f086c72a24287458d083cbd3fd136d2c589
EBUILD kitty-terminfo-0.26.2.ebuild 618 BLAKE2B f28c7bc4aff671b8f2df8094f8abd881b9bfe0580fd84e302fea050235f5932c34636e407d87afb34ee1fe2e7006e1dc1a1902d9a914cfe4aa7372fb7d18d368 SHA512 971734b7d326df234fff57c14a17ce6da9e9f97dc86ea412b9521c76e0c06fceadffcb708db781d85d5529a6ec9c829dcd5f8210c36c06b73f6ce05b9be729b3
+EBUILD kitty-terminfo-0.26.3.ebuild 620 BLAKE2B 84d17d934610d200dd4d556462255c9f6ee5fa90553b81db4dc764a9bb4026d74b874f19ef92e3aeaaaf2856021870199518b66e633212896aa5b9d4f5255b8a SHA512 a9dca5ba4c276df302fb5df4507294bdac4609398ed441b242dba8459d2d58306c29a49373278f428c1d86a3e9e426f3605153252aebe9bfac5af00e088fac18
EBUILD kitty-terminfo-9999.ebuild 545 BLAKE2B 50bf783694580b016f3291640d6c4ab3e8ee335f78d13b75cb7ebe6628ddd2f244fab2e7c465a3964ed6b5e0ebbdb144c739a01ffa7239c8518503ea107a52f2 SHA512 267b8b4a526ee22159f7c1c0d9a089e183308e1e7f61d775834e4ed5d4f25be7aac8cc3db4afa3c3f1e933159f27abff25c31989dd6478c1727eec590bf0a3c8
MISC metadata.xml 610 BLAKE2B 29a121e206c4a21965f03cac1b01314dc32384eb617e9c188814f2c9a8896d10cb299aa4ef7fec74c5a74c966069355d291fe23d9f37b2cbb3d34ebb24850f81 SHA512 867c3bfc752f53287bea2f027a949bb433cd069f5480a5197986371db6dac4524577bf1503259a4fb4f6832ec7c860a5f2b4ac495a17c6a19fee5c62a70e6892
diff --git a/x11-terms/kitty-terminfo/kitty-terminfo-0.26.3.ebuild b/x11-terms/kitty-terminfo/kitty-terminfo-0.26.3.ebuild
new file mode 100644
index 000000000000..35ff98034a87
--- /dev/null
+++ b/x11-terms/kitty-terminfo/kitty-terminfo-0.26.3.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Terminfo for kitty, a GPU-based terminal emulator"
+HOMEPAGE="https://sw.kovidgoyal.net/kitty/"
+SRC_URI="https://github.com/kovidgoyal/kitty/releases/download/v${PV}/kitty-${PV}.tar.xz"
+S="${WORKDIR}/kitty-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+RESTRICT="test" # intended to be ran on the full kitty package
+
+BDEPEND="sys-libs/ncurses"
+
+src_compile() { :; }
+
+src_install() {
+ dodir /usr/share/terminfo
+ tic -xo "${ED}"/usr/share/terminfo terminfo/kitty.terminfo || die
+}