summaryrefslogtreecommitdiff
path: root/x11-terms/kitty-terminfo/kitty-terminfo-0.24.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-07 22:48:01 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-07 22:48:01 +0000
commitc3bc61051d7f12b4c682efa7a5460bbc8815649e (patch)
treeb6d19e96ba3c397fb8278eeb9b68170db92630ba /x11-terms/kitty-terminfo/kitty-terminfo-0.24.0.ebuild
parent3517852e3b8a68d1e997770fc0650c5053bafc6c (diff)
gentoo resync : 07.01.2022
Diffstat (limited to 'x11-terms/kitty-terminfo/kitty-terminfo-0.24.0.ebuild')
-rw-r--r--x11-terms/kitty-terminfo/kitty-terminfo-0.24.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/x11-terms/kitty-terminfo/kitty-terminfo-0.24.0.ebuild b/x11-terms/kitty-terminfo/kitty-terminfo-0.24.0.ebuild
new file mode 100644
index 000000000000..348b95a9b4a6
--- /dev/null
+++ b/x11-terms/kitty-terminfo/kitty-terminfo-0.24.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Terminfo for kitty, a GPU-based terminal emulator"
+HOMEPAGE="https://sw.kovidgoyal.net/kitty/"
+SRC_URI="https://github.com/kovidgoyal/kitty/releases/download/v${PV}/kitty-${PV}.tar.xz"
+S="${WORKDIR}/kitty-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test" # intended to be ran on the full kitty package
+
+BDEPEND="sys-libs/ncurses"
+
+src_compile() { :; }
+
+src_install() {
+ dodir /usr/share/terminfo
+ tic -xo "${ED}"/usr/share/terminfo terminfo/kitty.terminfo || die
+}