summaryrefslogtreecommitdiff
path: root/x11-terms/kitty-shell-integration
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-17 13:54:39 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-17 13:54:39 +0100
commitfe7238eca1d510cb096bf290978af72ba6607930 (patch)
tree564be9d3b7f3c9537d08b9b6a75fb119777c36f3 /x11-terms/kitty-shell-integration
parent403387a1bc2a2d98e75bf1474b21ae379b88aab2 (diff)
gentoo auto-resync : 17:10:2022 - 13:54:39
Diffstat (limited to 'x11-terms/kitty-shell-integration')
-rw-r--r--x11-terms/kitty-shell-integration/Manifest2
-rw-r--r--x11-terms/kitty-shell-integration/kitty-shell-integration-0.26.4.ebuild37
2 files changed, 39 insertions, 0 deletions
diff --git a/x11-terms/kitty-shell-integration/Manifest b/x11-terms/kitty-shell-integration/Manifest
index 7aaf3696628a..4faf34baae38 100644
--- a/x11-terms/kitty-shell-integration/Manifest
+++ b/x11-terms/kitty-shell-integration/Manifest
@@ -1,4 +1,6 @@
DIST kitty-0.26.3.tar.xz 4730520 BLAKE2B a2d8cccc76eb295256ac420700e941ac9cb0e79c9717a93226cc30db63ab047dcd0be2e11b36b44c7c15daa0b77a451242d32f71024cee724869ba8937b93dd5 SHA512 77a518cd3ec4bb059907f16d01068914951cadbbcf803dcbfae13cc9ce144f65a886d7e986c7191019a0be9ccf902f086c72a24287458d083cbd3fd136d2c589
+DIST kitty-0.26.4.tar.xz 4749148 BLAKE2B fe15d2bd3afda49fcdc911d0ada5824dffe7eac69cd22581b86f50b0d20330ef10bf567d4adfafe5e06d20f9d7a10c8acfcffb95a3d5c47c50327576d9600761 SHA512 4d3ef5ba2ca54d0f5cd84ece771297c19c05bd276fc235f92c76d469ad17e55b54de696dce38c9039ae9825c7609e03e937536261c4fb680e936865ee0e4441e
EBUILD kitty-shell-integration-0.26.3.ebuild 1483 BLAKE2B 8bb6bf5cbd3a11f5773f1783b5d6e8ed5bdac200a61e6df7326913081280f0e334b7c100cb09df05b6a3e99682fbb63117622671184b2cc2f12b87f975c345a0 SHA512 b032be5bdada3925e23bf44ad466b4aa1b51905715c6d5fef0781aeb634f1b728ad1429f75e4fcf8abffc6b88c975d73079037d32f909dfd91b38c8802095e04
+EBUILD kitty-shell-integration-0.26.4.ebuild 1485 BLAKE2B 21a75b84ba48ae28082f872464859710ada27876c1b5e0985d94f7431ac9ee34321eed9323e044bb41eb98a8a701b2a3be5c74869482f20d9c9ba25cc6ba9fa8 SHA512 67be032810055406c81963593c0b6dcede05bf5d7c8bc3178e758f1329bf88384ee25c614cd2fa16e50b210d95297dc33fdbd949a52a58108ffa3962cfee8a53
EBUILD kitty-shell-integration-9999.ebuild 1403 BLAKE2B 9f1e4aebc1103678d42ba5809c41848b2ace36e2ed0137bdb0f30048cb4372c61f80e509a8087a52b149fe25115ca8aaa511d4697459e1087bee65788055dd85 SHA512 d7674435c3d3d9cfd04d47889f9e0f1cb4e60a6dc3506529829b3782e958fc3cb18fe8b0a25463725128106d6ca8308a17ae961b184e13682a1b05852e22ce4e
MISC metadata.xml 610 BLAKE2B 29a121e206c4a21965f03cac1b01314dc32384eb617e9c188814f2c9a8896d10cb299aa4ef7fec74c5a74c966069355d291fe23d9f37b2cbb3d34ebb24850f81 SHA512 867c3bfc752f53287bea2f027a949bb433cd069f5480a5197986371db6dac4524577bf1503259a4fb4f6832ec7c860a5f2b4ac495a17c6a19fee5c62a70e6892
diff --git a/x11-terms/kitty-shell-integration/kitty-shell-integration-0.26.4.ebuild b/x11-terms/kitty-shell-integration/kitty-shell-integration-0.26.4.ebuild
new file mode 100644
index 000000000000..92b178c54f24
--- /dev/null
+++ b/x11-terms/kitty-shell-integration/kitty-shell-integration-0.26.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Shell integration scripts for kitty, a GPU-based terminal emulator"
+HOMEPAGE="https://sw.kovidgoyal.net/kitty/"
+SRC_URI="https://github.com/kovidgoyal/kitty/releases/download/v${PV}/kitty-${PV}.tar.xz"
+S="${WORKDIR}/kitty-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~riscv ~x86"
+RESTRICT="test" # intended to be ran on the full kitty package
+
+src_compile() { :; }
+
+src_install() {
+ # install the whole directory in the upstream suggested location
+ # for consistency (i.e. less variation between distros if someone
+ # ssh into Gentoo), then set symlinks to autoload where possible
+ # (these exit immediately if KITTY_SHELL_INTEGRATION is unset)
+ insinto /usr/share/kitty
+ doins -r shell-integration
+
+ dosym -r {/usr/share/kitty/shell-integration/bash,/etc/bash/bashrc.d}/kitty.bash
+
+ dosym -r /usr/share/{kitty/shell-integration/fish,fish}/vendor_completions.d/kitty.fish
+ dosym -r /usr/share/{kitty/shell-integration/fish,fish}/vendor_conf.d/kitty-shell-integration.fish
+
+ dosym -r /usr/share/{kitty/shell-integration/zsh/completions,zsh/site-functions}/_kitty
+ # zsh integration is handled automatically without needing to modify rc files,
+ # but may require user intervention depending on zsh invocation or if remote
+
+ # this is used internally by the ssh kitten and is not useful there
+ rm -r "${ED}"/usr/share/kitty/shell-integration/ssh || die
+}