summaryrefslogtreecommitdiff
path: root/x11-terms/kitty-shell-integration
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-29 10:46:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-29 10:46:12 +0100
commitd3fc35858ba4bc0c8038a8c536246b00fe648358 (patch)
tree416e79067bd12fc0b43e12f1b73ee15a62b8a5bf /x11-terms/kitty-shell-integration
parent2512faa12f58e69a2f3e27e13e10fd0aef3ab384 (diff)
gentoo auto-resync : 29:08:2022 - 10:46:12
Diffstat (limited to 'x11-terms/kitty-shell-integration')
-rw-r--r--x11-terms/kitty-shell-integration/Manifest2
-rw-r--r--x11-terms/kitty-shell-integration/kitty-shell-integration-0.26.0.ebuild37
2 files changed, 39 insertions, 0 deletions
diff --git a/x11-terms/kitty-shell-integration/Manifest b/x11-terms/kitty-shell-integration/Manifest
index eb1913486b48..985b3857a4cd 100644
--- a/x11-terms/kitty-shell-integration/Manifest
+++ b/x11-terms/kitty-shell-integration/Manifest
@@ -1,4 +1,6 @@
DIST kitty-0.25.2.tar.xz 4681940 BLAKE2B 9aa43711c833541f364100465dfd1c13251ed59d5777634a5f193cc0544743295a772de85c64b4657e2cbca3d88f77019b0fe26b25c8b0908c1cc108b480ecf6 SHA512 ac858b525abbdeb137989a7971c51651d46bffedde048ed572bbb4c31119a4e0f9f424edbdbfd14fe2e043b4a7c8a1a1f8ee6591906e40a655d9f783b21f31a6
+DIST kitty-0.26.0.tar.xz 4719488 BLAKE2B 02e06ed8dd6bfdca789efe53211a27855582b2baa845558efd454a9ee8d2d6a71749f8baaad6ac6ba3f5b0878b2786302a26be190dec544488c3918de70ab581 SHA512 e8e041cb8cbe8560e35126d9f717111e0094ef9dd260ade07017f36d8e8e18fd4198cf186198b78089b8a05baa98a512d273b24b7f3f0d4f9f6d06107eb76c58
EBUILD kitty-shell-integration-0.25.2.ebuild 1476 BLAKE2B d07578dfe48ab8aa3ff01b4ed91e0e9e1d357f00d0931d2a4beaa8659c843b130108ce925bb37fdb4679048e1d9bd90a64aaa95150eabb3e6c9b195e504a1bc3 SHA512 0f74797060755fdf9430efbbe5e7d56182b38dafd1d9c8bbf25d01e932e1bc95fb5e774064667b66f8beb8ab1e0772174746506bb9b156b88131dd23a14d82c4
+EBUILD kitty-shell-integration-0.26.0.ebuild 1478 BLAKE2B c9751a6a82bf10a629f06b6099dec2b6d08c0e4d961e6c8105ce7e975e849161bb09a8990a0ed971f96e4ea0787b87e64074d705e807fba6dbef3c3494ea495b SHA512 7f5f6d48619adeb300727cc9b30ef97403a2f6da00a45661cb8cec489ea9ccab02a48ba502d8099175342d832ec9ad98f82aff87bf5ef5d1df50ab7971d8fcea
EBUILD kitty-shell-integration-9999.ebuild 1403 BLAKE2B 9f1e4aebc1103678d42ba5809c41848b2ace36e2ed0137bdb0f30048cb4372c61f80e509a8087a52b149fe25115ca8aaa511d4697459e1087bee65788055dd85 SHA512 d7674435c3d3d9cfd04d47889f9e0f1cb4e60a6dc3506529829b3782e958fc3cb18fe8b0a25463725128106d6ca8308a17ae961b184e13682a1b05852e22ce4e
MISC metadata.xml 610 BLAKE2B 29a121e206c4a21965f03cac1b01314dc32384eb617e9c188814f2c9a8896d10cb299aa4ef7fec74c5a74c966069355d291fe23d9f37b2cbb3d34ebb24850f81 SHA512 867c3bfc752f53287bea2f027a949bb433cd069f5480a5197986371db6dac4524577bf1503259a4fb4f6832ec7c860a5f2b4ac495a17c6a19fee5c62a70e6892
diff --git a/x11-terms/kitty-shell-integration/kitty-shell-integration-0.26.0.ebuild b/x11-terms/kitty-shell-integration/kitty-shell-integration-0.26.0.ebuild
new file mode 100644
index 000000000000..4c3e987c411b
--- /dev/null
+++ b/x11-terms/kitty-shell-integration/kitty-shell-integration-0.26.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Shell integration scripts for kitty, a GPU-based terminal emulator"
+HOMEPAGE="https://sw.kovidgoyal.net/kitty/"
+SRC_URI="https://github.com/kovidgoyal/kitty/releases/download/v${PV}/kitty-${PV}.tar.xz"
+S="${WORKDIR}/kitty-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+RESTRICT="test" # intended to be ran on the full kitty package
+
+src_compile() { :; }
+
+src_install() {
+ # install the whole directory in the upstream suggested location
+ # for consistency (i.e. less variation between distros if someone
+ # ssh into Gentoo), then set symlinks to autoload where possible
+ # (these exit immediately if KITTY_SHELL_INTEGRATION is unset)
+ insinto /usr/share/kitty
+ doins -r shell-integration
+
+ dosym -r {/usr/share/kitty/shell-integration/bash,/etc/bash/bashrc.d}/kitty.bash
+
+ dosym -r /usr/share/{kitty/shell-integration/fish,fish}/vendor_completions.d/kitty.fish
+ dosym -r /usr/share/{kitty/shell-integration/fish,fish}/vendor_conf.d/kitty-shell-integration.fish
+
+ dosym -r /usr/share/{kitty/shell-integration/zsh/completions,zsh/site-functions}/_kitty
+ # zsh integration is handled automatically without needing to modify rc files,
+ # but may require user intervention depending on zsh invocation or if remote
+
+ # this is used internally by the ssh kitten and is not useful there
+ rm -r "${ED}"/usr/share/kitty/shell-integration/ssh || die
+}