summaryrefslogtreecommitdiff
path: root/x11-terms/kitty-shell-integration
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-18 11:05:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-18 11:05:42 +0100
commit1426dfeb15e4d49cb4238c6cf37455a6130cd83f (patch)
tree9f9734bcdc280108e52d753b3c57234371772c3c /x11-terms/kitty-shell-integration
parent836586553c510ee2dd91e2ecd7676fe432c1f1a4 (diff)
gentoo auto-resync : 18:09:2023 - 11:05:42
Diffstat (limited to 'x11-terms/kitty-shell-integration')
-rw-r--r--x11-terms/kitty-shell-integration/Manifest2
-rw-r--r--x11-terms/kitty-shell-integration/kitty-shell-integration-0.30.0.ebuild37
2 files changed, 39 insertions, 0 deletions
diff --git a/x11-terms/kitty-shell-integration/Manifest b/x11-terms/kitty-shell-integration/Manifest
index c520e21d2807..65d57d01ea7d 100644
--- a/x11-terms/kitty-shell-integration/Manifest
+++ b/x11-terms/kitty-shell-integration/Manifest
@@ -1,4 +1,6 @@
DIST kitty-0.29.2.tar.xz 7809388 BLAKE2B 6928d79a6cc0eaac4d92ce3babbeb0a42bf1dbc92b775386b521c8399352ba77ab9828f8cfd9f40c3e4f29ae98852b6f3cb9ee1f412474ba2ef655c18d2c294d SHA512 a34d8b5bc817dd9d27f1afa190856d916576f52458ede2253655b294358b6b89b1f103acb90d8d66a494b346420ddedc9fcf1a3399f561268ded82e7b1954b06
+DIST kitty-0.30.0.tar.xz 7842724 BLAKE2B a656fbb74a92a6b834fe8d06a89eaa1240044b132d64d7ad9eb429c71fd60e564ed963638bb9ba4e99d3e31c2ac594543e702b298a0b53aea1050e3b2e19ae9a SHA512 05438de8752057d7c419da41621b4d8fcfa6e7189530efc32c7c8a0bf2e6dae0332dd1b661206f9dea5bf374713e86ea5e69f640b0e73fe617f528bc963a8792
EBUILD kitty-shell-integration-0.29.2.ebuild 1495 BLAKE2B bc45a20de5feb70d9b28c1dd8213e6534c63a92a773977624b99519d3241fd6a88e9ef077bbcbd7085d017f13cfbe4493dfd0465ee7534939e3d57075d04ac32 SHA512 bfd89b4cc1ed6a4140e0c69167d8a60dabef6f9138f8aae5938971ef91510684a6535a5c1d526e11a896a446a54dd6c987ac0bbeaee184ba3884ecfad21bced1
+EBUILD kitty-shell-integration-0.30.0.ebuild 1497 BLAKE2B 6ea66e76709c69b93f53e4e18ef633cacb1f85da806c8da0c9b20f34acf3bca9b23b277af990d87af3790ebc1e7e28c8acec026d20513af0a9443904eeb8d4c4 SHA512 0469292c85c26e118594dffb54b5ba751defa7a7200ba9b0041d9ab6812b66edada608880a71c2082058dbd50278a4643fb896b80aab142b01d2234868b194a5
EBUILD kitty-shell-integration-9999.ebuild 1403 BLAKE2B 9f1e4aebc1103678d42ba5809c41848b2ace36e2ed0137bdb0f30048cb4372c61f80e509a8087a52b149fe25115ca8aaa511d4697459e1087bee65788055dd85 SHA512 d7674435c3d3d9cfd04d47889f9e0f1cb4e60a6dc3506529829b3782e958fc3cb18fe8b0a25463725128106d6ca8308a17ae961b184e13682a1b05852e22ce4e
MISC metadata.xml 610 BLAKE2B 29a121e206c4a21965f03cac1b01314dc32384eb617e9c188814f2c9a8896d10cb299aa4ef7fec74c5a74c966069355d291fe23d9f37b2cbb3d34ebb24850f81 SHA512 867c3bfc752f53287bea2f027a949bb433cd069f5480a5197986371db6dac4524577bf1503259a4fb4f6832ec7c860a5f2b4ac495a17c6a19fee5c62a70e6892
diff --git a/x11-terms/kitty-shell-integration/kitty-shell-integration-0.30.0.ebuild b/x11-terms/kitty-shell-integration/kitty-shell-integration-0.30.0.ebuild
new file mode 100644
index 000000000000..683e7101b6b5
--- /dev/null
+++ b/x11-terms/kitty-shell-integration/kitty-shell-integration-0.30.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Shell integration scripts for kitty, a GPU-based terminal emulator"
+HOMEPAGE="https://sw.kovidgoyal.net/kitty/"
+SRC_URI="https://github.com/kovidgoyal/kitty/releases/download/v${PV}/kitty-${PV}.tar.xz"
+S="${WORKDIR}/kitty-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+RESTRICT="test" # intended to be ran on the full kitty package
+
+src_compile() { :; }
+
+src_install() {
+ # install the whole directory in the upstream suggested location
+ # for consistency (i.e. less variation between distros if someone
+ # ssh into Gentoo), then set symlinks to autoload where possible
+ # (these exit immediately if KITTY_SHELL_INTEGRATION is unset)
+ insinto /usr/share/kitty
+ doins -r shell-integration
+
+ dosym -r {/usr/share/kitty/shell-integration/bash,/etc/bash/bashrc.d}/kitty.bash
+
+ dosym -r /usr/share/{kitty/shell-integration/fish,fish}/vendor_completions.d/kitty.fish
+ dosym -r /usr/share/{kitty/shell-integration/fish,fish}/vendor_conf.d/kitty-shell-integration.fish
+
+ dosym -r /usr/share/{kitty/shell-integration/zsh/completions,zsh/site-functions}/_kitty
+ # zsh integration is handled automatically without needing to modify rc files,
+ # but may require user intervention depending on zsh invocation or if remote
+
+ # this is used internally by the ssh kitten and is not useful there
+ rm -r "${ED}"/usr/share/kitty/shell-integration/ssh || die
+}