summaryrefslogtreecommitdiff
path: root/x11-terms/kitty-shell-integration
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-19 08:07:42 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-19 08:07:42 +0000
commit0184387f6a748c74c5d29cddf20289dc94f05ddc (patch)
tree254558423398a56afd082c6d0b4e60341ba38adb /x11-terms/kitty-shell-integration
parentf432b083b2efe1e2aa0a7497bf0ca78eeb483332 (diff)
gentoo auto-resync : 19:01:2024 - 08:07:41
Diffstat (limited to 'x11-terms/kitty-shell-integration')
-rw-r--r--x11-terms/kitty-shell-integration/Manifest2
-rw-r--r--x11-terms/kitty-shell-integration/kitty-shell-integration-0.32.0.ebuild37
2 files changed, 39 insertions, 0 deletions
diff --git a/x11-terms/kitty-shell-integration/Manifest b/x11-terms/kitty-shell-integration/Manifest
index 6be69b327eb4..96334f2b343a 100644
--- a/x11-terms/kitty-shell-integration/Manifest
+++ b/x11-terms/kitty-shell-integration/Manifest
@@ -1,4 +1,6 @@
DIST kitty-0.31.0.tar.xz 7929620 BLAKE2B 74ccd0e14803ee3991d895c8ec0099567b6a087110eda03d5b35a45d1e684916d63846f1bd1184b2f5fe7a88431983602899cfd6392c28de78d020b8c98c89b2 SHA512 3868431003f9f1a3907415124c1d8282b077985a9d104615d48f9d309f6fbf1a11119546674508649aa35f2b6e66aa5638024e8127f92ae7b043da367c7b3363
+DIST kitty-0.32.0.tar.xz 8122660 BLAKE2B 8f2fccb8f233612331b860e0b25aa5a028c2e4d39b5795132351c4a2dff51478b8e42fd3a15bec5f616b4cdb47ad0cc7f636d1961a7f9fad8ede91475e82c29e SHA512 d64f36c20d484724b0215a2ffc9044b83ddaa476926377e6c79226d7d6bd5deffda9964291a99c0df174640fb2fa7df0464435d2cef19304eab7b1d135cc1847
EBUILD kitty-shell-integration-0.31.0.ebuild 1495 BLAKE2B bc45a20de5feb70d9b28c1dd8213e6534c63a92a773977624b99519d3241fd6a88e9ef077bbcbd7085d017f13cfbe4493dfd0465ee7534939e3d57075d04ac32 SHA512 bfd89b4cc1ed6a4140e0c69167d8a60dabef6f9138f8aae5938971ef91510684a6535a5c1d526e11a896a446a54dd6c987ac0bbeaee184ba3884ecfad21bced1
+EBUILD kitty-shell-integration-0.32.0.ebuild 1497 BLAKE2B 945f2dc0f841bc3570f6d9c5a01a70c60f826fe8c1cf4ba402bf5478ca956e4578dbf356a98198eef51d90e403a98478feb20cddd91cb94ccbe3c2b51d39b2a4 SHA512 fa959b05abd969e137baccf58b0465cd2ce0b150abf2d377d54b9b86615cf93c4dd0691688fb62f59c619b14577a015b28897da435ee088ec26a41c97b9f2bfd
EBUILD kitty-shell-integration-9999.ebuild 1408 BLAKE2B f3310f49863e8dbd3c4e1ea27ac5c2ed7ae9f4840262a9fa155b24bc8545e99bcd7931f86bcec51a2c161a6e59e4bce24c26e7a028a96a6f7c9fbdcc0d02d791 SHA512 572a4946fb8511fc70c0fb461763c63dffe69c0985458e8234688796bba908bb7c84d24516556dd500bc9dd3c31d12a440c0a8dddc5300ea96ae2156c9a10a4e
MISC metadata.xml 610 BLAKE2B 29a121e206c4a21965f03cac1b01314dc32384eb617e9c188814f2c9a8896d10cb299aa4ef7fec74c5a74c966069355d291fe23d9f37b2cbb3d34ebb24850f81 SHA512 867c3bfc752f53287bea2f027a949bb433cd069f5480a5197986371db6dac4524577bf1503259a4fb4f6832ec7c860a5f2b4ac495a17c6a19fee5c62a70e6892
diff --git a/x11-terms/kitty-shell-integration/kitty-shell-integration-0.32.0.ebuild b/x11-terms/kitty-shell-integration/kitty-shell-integration-0.32.0.ebuild
new file mode 100644
index 000000000000..c3b309c79626
--- /dev/null
+++ b/x11-terms/kitty-shell-integration/kitty-shell-integration-0.32.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Shell integration scripts for kitty, a GPU-based terminal emulator"
+HOMEPAGE="https://sw.kovidgoyal.net/kitty/"
+SRC_URI="https://github.com/kovidgoyal/kitty/releases/download/v${PV}/kitty-${PV}.tar.xz"
+S="${WORKDIR}/kitty-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+RESTRICT="test" # intended to be ran on the full kitty package
+
+src_compile() { :; }
+
+src_install() {
+ # install the whole directory in the upstream suggested location
+ # for consistency (i.e. less variation between distros if someone
+ # ssh into Gentoo), then set symlinks to autoload where possible
+ # (these exit immediately if KITTY_SHELL_INTEGRATION is unset)
+ insinto /usr/share/kitty
+ doins -r shell-integration
+
+ dosym -r {/usr/share/kitty/shell-integration/bash,/etc/bash/bashrc.d}/kitty.bash
+
+ dosym -r /usr/share/{kitty/shell-integration/fish,fish}/vendor_completions.d/kitty.fish
+ dosym -r /usr/share/{kitty/shell-integration/fish,fish}/vendor_conf.d/kitty-shell-integration.fish
+
+ dosym -r /usr/share/{kitty/shell-integration/zsh/completions,zsh/site-functions}/_kitty
+ # zsh integration is handled automatically without needing to modify rc files,
+ # but may require user intervention depending on zsh invocation or if remote
+
+ # this is used internally by the ssh kitten and is not useful there
+ rm -r "${ED}"/usr/share/kitty/shell-integration/ssh || die
+}