summaryrefslogtreecommitdiff
path: root/x11-terms/guake
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
commit46eedbedafdb0040c37884982d4c775ce277fb7b (patch)
treedb33a91259730be84999e13a8d8168c799f50ac0 /x11-terms/guake
parente23a08d0c97a0cc415aaa165da840b056f93c997 (diff)
gentoo resync : 20.10.2021
Diffstat (limited to 'x11-terms/guake')
-rw-r--r--x11-terms/guake/Manifest3
-rw-r--r--x11-terms/guake/guake-3.8.0.ebuild85
-rw-r--r--x11-terms/guake/guake-9999.ebuild69
3 files changed, 87 insertions, 70 deletions
diff --git a/x11-terms/guake/Manifest b/x11-terms/guake/Manifest
index f61d48b4f05c..4edf8b58eed4 100644
--- a/x11-terms/guake/Manifest
+++ b/x11-terms/guake/Manifest
@@ -1,5 +1,6 @@
AUX guake-3.3.2-paths.patch 763 BLAKE2B f097157d3a6516bf5df888a8148cf2120695fc8dc6a80d14b6bc0326ab7a3a7fb4ad17adcd837766e8df442cd6d274eab9e1490c07f9969517785dd2a71641d4 SHA512 32015e084ba1e47c4cb5ece36548721f576e254ddcb29243db1609a403464a53a0ffb198f58cac84d54a2e22a432273687ced076d0ec7045865bfaf8536c1275
DIST guake-3.7.0.tar.gz 1215186 BLAKE2B ff60f83fce5fbdd3712e261bbb72247cdcb311b8208af75007183bced88fcc2d2ebe3c49b76e2264786246444e9d07a41f884de949112c249277717070d64c11 SHA512 578c42ed41049acd253e0c409a9ecb103c7f71679fc5efdd94c60461b952ac77c836e59439361e1cd70e5fe6785ab4c15e7bf73b9f4c7d23b47c77468fa05f62
+DIST guake-3.8.0.tar.gz 1125090 BLAKE2B 72ee6b5e93c3433fcc2863d2b0aa198326cc4889126454040ce870fdeaa0ba110723410355ae49b5e2e4876fcad3f9d849873adaddfcf1ecfa83dc1583db57eb SHA512 6e0bb6b4a0c92c163bd6151c65936a38d93624166af5a4e2b042f9ade7f28683c8e8fad802b23a07edd478e2dd3b99a559069c9935f1154585be936d1b7a96ed
EBUILD guake-3.7.0.ebuild 1767 BLAKE2B 3358dad3874118a2af413ba00a48fb072bf3cde0ec0d4d0a371ef0d7de2973ae4ba2f1d4d744821ad33201252a386191a59872a1d84cf3baa5ad2e2e27690f9c SHA512 38b8cfa20a37f06474978f067fd125aa863d92b1128af685540041d1ae49a6b4702878f5a248cebbe35b387bd8101ec5e23e49a57485f6d42936de80d2ba093b
-EBUILD guake-9999.ebuild 1538 BLAKE2B feb2481be734ddad1ca00b3fadc8424426d52b8e48f9eb03e5563daf79029c9105c8cf43f3848d07f9bd525ba2005aff2c22d2766a586f1ff34e0051a74bb4df SHA512 a84a18ddf1a4b908c4f439e89df8d067d0e8549f454059798ef7c0b5203ef4182060a48c1d19c2f8a5e242151c2414e916027b0df52a9e37e19c7b0573efe987
+EBUILD guake-3.8.0.ebuild 2123 BLAKE2B 8f7688df5ee33f68da0f5888e5e42540c7b5e14d7fe02c459078d9d6b083f26d22ae0745ce8d1b619c8d47a34c38a495dc46f3c1ec870370fb40d61ccb210cda SHA512 0e7ea5aec7364417070f528d1f0a5144dd115162a3c19b71a3dd780a011e77d703e3f945c905a5c901862a3265cbb65d946016d342b0d01c1f72ba2bd863c2af
MISC metadata.xml 532 BLAKE2B 382002b9523b4776d8fe378774a8408b04f8bfac0979bca539e811fe41adec06a0dbce18201191373eb558d9bfabaa9b887eb4134262265e94c837139cafc773 SHA512 5ee8ef619e1d9f04d6560f3c62ed8bd1fa05912a4a6c94e0440ed8208d8efa1b49517c9266fc211cafde37e1b9ea029c64ba529331910688eacb5899fe8507fb
diff --git a/x11-terms/guake/guake-3.8.0.ebuild b/x11-terms/guake/guake-3.8.0.ebuild
new file mode 100644
index 000000000000..c4f5e779132f
--- /dev/null
+++ b/x11-terms/guake/guake-3.8.0.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_SINGLE_IMPL=1
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1 gnome2-utils virtualx xdg-utils
+
+DESCRIPTION="Drop-down terminal for GNOME"
+HOMEPAGE="http://guake-project.org/"
+SRC_URI="https://github.com/Guake/guake/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="utempter"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+ dev-libs/keybinder:3[introspection]
+ x11-libs/libnotify[introspection]
+ x11-libs/libwnck:3[introspection]
+ x11-libs/vte:2.91[introspection]
+ utempter? ( sys-libs/libutempter )"
+BDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/pbr[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pyfakefs[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+ ')
+ dev-libs/glib:2
+ gnome-base/gsettings-desktop-schemas
+ sys-devel/gettext"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ emake PREFIX="${EPREFIX}/usr" prepare-install # paths.py.in -> paths.py
+
+ rm pyproject.toml || die # pytest fails if toml isn't installed
+
+ export PBR_VERSION=${PV} # needed if using github's tarball
+}
+
+python_test() {
+ # uses /usr/bin/bash if SHELL is not exported
+ SHELL=${SHELL} virtx distutils-r1_python_test
+}
+
+python_install() {
+ # done here so tests don't use the system's
+ sed -e "/^SCHEMA_DIR/s|=.*|= \"${EPREFIX}/usr/share/glib-2.0/schemas\"|" \
+ -e "/def get_default_data_dir/{n;s|=.*|= \"${EPREFIX}/usr/share/guake\"|}" \
+ -i "${BUILD_DIR}"/lib/guake/paths.py || die
+ rm -r "${BUILD_DIR}"/lib/guake/tests || die
+
+ distutils-r1_python_install
+}
+
+python_install_all() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install-{locale,schemas}
+
+ dodoc NEWS.rst README.rst
+
+ mv "${D}"/{,"${EPREFIX}"/usr/share/}metainfo || die
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+ xdg_desktop_database_update
+}
diff --git a/x11-terms/guake/guake-9999.ebuild b/x11-terms/guake/guake-9999.ebuild
deleted file mode 100644
index 0c37d44a1ac0..000000000000
--- a/x11-terms/guake/guake-9999.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..9} )
-DISTUTILS_SINGLE_IMPL=1
-
-inherit distutils-r1 gnome2-utils xdg-utils
-
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/Guake/guake.git"
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~x86"
-fi
-
-DESCRIPTION="Drop-down terminal for GNOME"
-HOMEPAGE="
- https://github.com/Guake/guake/
- https://pypi.org/project/guake/"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="utempter"
-
-RDEPEND="
- dev-libs/glib
- dev-libs/keybinder:3[introspection]
- $(python_gen_cond_dep '
- dev-python/dbus-python[${PYTHON_USEDEP}]
- dev-python/pbr[${PYTHON_USEDEP}]
- dev-python/pycairo[${PYTHON_USEDEP}]
- dev-python/pygobject:3[${PYTHON_USEDEP}]
- ')
- x11-libs/libnotify[introspection]
- x11-libs/libwnck:3[introspection]
- x11-libs/vte:2.91[introspection]
- utempter? ( sys-libs/libutempter )"
-DEPEND="${RDEPEND}"
-BDEPEND="
- gnome-base/gsettings-desktop-schemas
- sys-devel/gettext"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-3.3.2-paths.patch
-)
-
-python_compile_all() {
- emake prepare-install PREFIX=/usr
- emake generate-paths PREFIX=/usr DATA_DIR='$(datadir)/guake' DEV_SCHEMA_DIR='$(gsettingsschemadir)'
- default
-}
-
-python_install_all() {
- emake install-schemas install-locale PREFIX=/usr DESTDIR="${D}"
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- gnome2_schemas_update
- xdg_desktop_database_update
-}
-
-pkg_postrm() {
- gnome2_schemas_update
- xdg_desktop_database_update
-}