summaryrefslogtreecommitdiff
path: root/x11-terms/cool-retro-term/cool-retro-term-1.1.1-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
commit29aabba0ea759c6a2864ff5631735b67ee38e5e0 (patch)
treeab466b4dfa7abecb401b2f8039d08af4689306bb /x11-terms/cool-retro-term/cool-retro-term-1.1.1-r2.ebuild
parentd42200bec37eef2a7478d88988ff00addd0a9202 (diff)
gentoo resync : 05.02.2020
Diffstat (limited to 'x11-terms/cool-retro-term/cool-retro-term-1.1.1-r2.ebuild')
-rw-r--r--x11-terms/cool-retro-term/cool-retro-term-1.1.1-r2.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/x11-terms/cool-retro-term/cool-retro-term-1.1.1-r2.ebuild b/x11-terms/cool-retro-term/cool-retro-term-1.1.1-r2.ebuild
new file mode 100644
index 000000000000..1f9256427d7d
--- /dev/null
+++ b/x11-terms/cool-retro-term/cool-retro-term-1.1.1-r2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit qmake-utils xdg-utils
+
+QTW_PN=qmltermwidget
+QTW_PV=0.2.0
+QTW_P=${QTW_PN}-${QTW_PV}
+
+DESCRIPTION="terminal emulator which mimics the look and feel of the old cathode tube screens"
+HOMEPAGE="https://github.com/Swordfish90/cool-retro-term"
+SRC_URI="https://github.com/Swordfish90/cool-retro-term/archive/${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/Swordfish90/qmltermwidget/archive/${QTW_PV}.tar.gz -> ${QTW_P}.tar.gz"
+
+LICENSE="GPL-2 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-qt/qtdeclarative:5[localstorage]
+ dev-qt/qtgraphicaleffects:5
+ dev-qt/qtquickcontrols:5[widgets]
+ dev-qt/qtsql:5
+ dev-qt/qtwidgets:5
+"
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ rmdir qmltermwidget || die
+ mv "${WORKDIR}/${QTW_P}" qmltermwidget || die
+ pushd qmltermwidget || die
+ eapply "${FILESDIR}"/qmltermwidget-0.2.0-gcc-10.patch
+ popd || die
+}
+
+src_configure() {
+ eqmake5 PREFIX="${EPREFIX}/usr"
+}
+
+src_install() {
+ # default attempts to install directly to /usr
+ emake INSTALL_ROOT="${D}" install
+ doman packaging/debian/cool-retro-term.1
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}