summaryrefslogtreecommitdiff
path: root/x11-terms/aterm/aterm-1.0.1-r4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
commit38423c67c8a23f6a1bc42038193182e2da3116eb (patch)
tree04e2cf4bd43601b77daa79fe654e409187093c5e /x11-terms/aterm/aterm-1.0.1-r4.ebuild
parent623ee73d661e5ed8475cb264511f683407d87365 (diff)
gentoo resync : 25.04.2020
Diffstat (limited to 'x11-terms/aterm/aterm-1.0.1-r4.ebuild')
-rw-r--r--x11-terms/aterm/aterm-1.0.1-r4.ebuild90
1 files changed, 90 insertions, 0 deletions
diff --git a/x11-terms/aterm/aterm-1.0.1-r4.ebuild b/x11-terms/aterm/aterm-1.0.1-r4.ebuild
new file mode 100644
index 000000000000..8427c805ffef
--- /dev/null
+++ b/x11-terms/aterm/aterm-1.0.1-r4.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="rxvt compatible terminal emulator with transparency support"
+HOMEPAGE="http://aterm.sourceforge.net"
+SRC_URI="ftp://ftp.afterstep.org/apps/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64"
+IUSE="background cjk xgetdefault"
+
+RDEPEND="
+ virtual/jpeg:0
+ media-libs/libpng:0=
+ background? ( x11-wm/afterstep )
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libICE
+"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+ x11-libs/libXt
+"
+
+src_prepare() {
+ # Security bug #219746
+ eapply "${FILESDIR}/${P}-display-security-issue.patch"
+ eapply "${FILESDIR}"/${P}-deadkeys.patch
+ eapply "${FILESDIR}/${P}-dpy.patch"
+ eapply "${FILESDIR}/${P}-remove-streams.patch"
+
+ #fix pre-stripped files
+ sed -i -e "/INSTALL_PROGRAM/ s:-s::" autoconf/Make.common.in || die "sed Makefile failed"
+
+ default
+}
+
+src_configure() {
+ local myconf
+
+ use cjk && myconf="$myconf
+ --enable-kanji
+ --enable-thai
+ --enable-big5"
+
+ case "${CHOST}" in
+ *-darwin*) myconf="${myconf} --enable-wtmp" ;;
+ *-interix*) ;;
+ *) myconf="${myconf} --enable-utmp --enable-wtmp"
+ esac
+
+ econf \
+ $(use_enable xgetdefault) \
+ $(use_enable background background-image) \
+ --with-terminfo="${EPREFIX}"/usr/share/terminfo \
+ --enable-transparency \
+ --enable-fading \
+ --enable-background-image \
+ --enable-menubar \
+ --enable-graphics \
+ --with-x \
+ ${myconf}
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ fowners root:utmp /usr/bin/aterm
+ fperms g+s /usr/bin/aterm
+
+ doman doc/aterm.1
+ dodoc ChangeLog doc/FAQ doc/README.*
+ docinto menu
+ dodoc doc/menu/*
+ dohtml -r .
+}
+
+pkg_postinst() {
+ echo
+ elog "The transparent background will only work if you have the 'real'"
+ elog "root wallpaper set. Some tools that might help include: Esetroot"
+ elog "(x11-terms/eterm), wmsetbg (x11-wm/windowmaker), and/or"
+ elog "media-gfx/feh."
+ echo
+}