summaryrefslogtreecommitdiff
path: root/x11-plugins
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-25 11:40:32 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-25 11:40:32 +0000
commit4215622c05ed14d30fdad5a4d0feba6d94b0d046 (patch)
tree2e7c452f4b9f4b13bf11bf37ea05bdcf1bc7d73e /x11-plugins
parentd117dce29795dfc5a9824d31a128decaa37f73d2 (diff)
gentoo auto-resync : 25:02:2024 - 11:40:31
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/Manifest.gzbin26767 -> 26762 bytes
-rw-r--r--x11-plugins/guifications/Manifest3
-rw-r--r--x11-plugins/guifications/guifications-2.16-r1.ebuild35
-rw-r--r--x11-plugins/guifications/metadata.xml5
4 files changed, 41 insertions, 2 deletions
diff --git a/x11-plugins/Manifest.gz b/x11-plugins/Manifest.gz
index 2b196c97f603..aad087c4d4d2 100644
--- a/x11-plugins/Manifest.gz
+++ b/x11-plugins/Manifest.gz
Binary files differ
diff --git a/x11-plugins/guifications/Manifest b/x11-plugins/guifications/Manifest
index f7897dc60b24..6eec099227e8 100644
--- a/x11-plugins/guifications/Manifest
+++ b/x11-plugins/guifications/Manifest
@@ -1,3 +1,4 @@
DIST pidgin-guifications-2.16.tar.bz2 543136 BLAKE2B dd34108210914386dbd2780b4f2a23cb615a51e8cabe39e16867721815b017b8f897906e06eb7cef1cb96e60e70ce3c02ad20d8a1a906159848cfaf64eaa7b76 SHA512 fee1741a37df102ed3620caed9024c1a2ac5919c1a9c4182bdb19685a4d3412a1ff72e5e58ce65fdc2689f1d90432ea22c3912a9ecda80a95af96d57c86c9cf0
+EBUILD guifications-2.16-r1.ebuild 763 BLAKE2B a9e16b4e98da4c100c9e799ed8b14dbd78de7113baa4ffbf2c64b9afdc7c1ab1bbac21f4b2f6cc3d1498338727031d7b323680af3b113d6d1594cd862546ae6a SHA512 69859fe165c08cb2eaa8e0b6533456a2f06fd61c12dce15aa890df04a1ad1582bcc67da9dba8b7f9d9ed90447cde9b7244554adb4dd46453a4e9085b747a1717
EBUILD guifications-2.16.ebuild 638 BLAKE2B 9878940ef235663654fbb6a1eb02905a9c44874d33c018901d0766e2cd396c31c680685bd5709a568bf2d0ffe709a6af4d4406fa4e993e7dfc68cbe1d6cefd53 SHA512 a78ecc71bacf08cb9ede789d6492961293fc58e02b4484209bbb786a78b4287972f4a205a61d5481ea3f0b3a1c95d5484a102b106c9cb09adba8c3b158b5b616
-MISC metadata.xml 167 BLAKE2B 868e3b584722eaacf68273db062bb773d8c7e5d7ab2b81ca7e8397643bf7cc106c3a1033594401c99c54f667bb45d6b73f9048fc335580bbd44b4589ad26a832 SHA512 30caadd1496c3b9969136038239a1d8e01f236726b4022c2d7e19ca7575f25f735e556835e581afbf44fbd3e4104c40f2b5ef5fa70118d75c881fdf871962d0a
+MISC metadata.xml 253 BLAKE2B 48176bf4d3261fa1fa73f54f89eb55371dae1f30f8b6fce3ca78b404418583f11c35e1978342d406e1918f737bb8e971778a780d4195f4a1936f866a23cd8423 SHA512 26103b425624e485d98f014bc88d2574fad61a638f750ff21507690509c78529885f72d410975d4f3586b11192d86d8b6457a86330e39d64312c24ce58aea7c9
diff --git a/x11-plugins/guifications/guifications-2.16-r1.ebuild b/x11-plugins/guifications/guifications-2.16-r1.ebuild
new file mode 100644
index 000000000000..e54eb1cf8f87
--- /dev/null
+++ b/x11-plugins/guifications/guifications-2.16-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="pidgin-${PN}"
+MY_PV="${PV/_beta/beta}"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="Guifications is a graphical notification plugin for pidgin"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="http://downloads.guifications.org/plugins//Guifications2/${MY_P}.tar.bz2"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="debug nls"
+
+RDEPEND="net-im/pidgin[gtk]
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ $(use_enable debug ) \
+ $(use_enable nls)
+}
+
+src_install() {
+ default
+
+ find "${D}" -type f -name '*.la' -delete || die "la removal failed"
+}
diff --git a/x11-plugins/guifications/metadata.xml b/x11-plugins/guifications/metadata.xml
index 85e4ed814fa2..e8de1c56b30f 100644
--- a/x11-plugins/guifications/metadata.xml
+++ b/x11-plugins/guifications/metadata.xml
@@ -1,5 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<!-- maintainer-needed -->
+ <maintainer type="person">
+ <email>nativemad@gentoo.org</email>
+ <name>Andreas Schuerch</name>
+ </maintainer>
</pkgmetadata>