summaryrefslogtreecommitdiff
path: root/x11-plugins
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-24 12:57:16 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-24 12:57:16 +0000
commit1f23f671d001ca7a0073e504f5ae0184eb5d024d (patch)
tree6747e05170df64a1585f36519a780db2d90f2a11 /x11-plugins
parent98bd6c82c526d2c4239d3d194fa1a1a818784552 (diff)
gentoo auto-resync : 24:01:2023 - 12:57:16
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/Manifest.gzbin27376 -> 27361 bytes
-rw-r--r--x11-plugins/vicious/Manifest2
-rw-r--r--x11-plugins/vicious/vicious-2.6.0.ebuild64
3 files changed, 66 insertions, 0 deletions
diff --git a/x11-plugins/Manifest.gz b/x11-plugins/Manifest.gz
index 440b320e5df9..ffec1eff5aa5 100644
--- a/x11-plugins/Manifest.gz
+++ b/x11-plugins/Manifest.gz
Binary files differ
diff --git a/x11-plugins/vicious/Manifest b/x11-plugins/vicious/Manifest
index be47a2a44883..cf8fef7a1e63 100644
--- a/x11-plugins/vicious/Manifest
+++ b/x11-plugins/vicious/Manifest
@@ -1,3 +1,5 @@
DIST vicious-2.5.1.tar.gz 68635 BLAKE2B fa952f878140e76a44bde98ab928fe2a01a12f0e931a4f8ee366acba584661a0e42b150d4f69bfaaf7c58c68d57d2e261d8b586fb1abbd329d9f30fe90c2e21d SHA512 63de92a4e7d666d5737bfc0f50857c48f40818e5f1cf81ba672284db764c68d151f73afd6507b7392b38ae91cf1d18104284618430d15dd8837c56a0283571fe
+DIST vicious-2.6.0.tar.gz 69108 BLAKE2B de86326b8975511cf053e6707bdc133ad23c95cadd64190de326bfae2c710a2f97b7cbc102cf88f14e6ebfdeface2896862b52521ba5d83a47014bc7bd65d0d3 SHA512 d8107ab1bad80b115789d7dbda44568cee17546f76c03889028f61f8293d9c897eec1cb7f96b973a39f0c94889c13f13c6cbccb944390c80820a327691223af6
EBUILD vicious-2.5.1.ebuild 2295 BLAKE2B 844ae18c7434ef399bacda6250b759d59a33ba42bec250ae29443c452fd4031d3cb512b675e4dad70ff1c375d361fd965cdc97f59de3a47c9542b9bf59858ccf SHA512 d1344f1233e0bed64f6915702d10f4ba67b454fec688b07a9461bdc68ee9bea673483ef497386ece4d41079e99c0f167a6bb705959bfbf61df4c103806def02e
+EBUILD vicious-2.6.0.ebuild 2297 BLAKE2B 5d56f15dde7bf092131fa8a34bbc7261aaf7faf542b853809a78a4f04d73bca43042f015cbb205513230e0d360b0a97462956c7de13778d817866280b047bcaa SHA512 eb170904387b8f5e6f916d8872c393dd074975e90933409f9441591873762516a7f0c4bff1ac0e221da8648586056362722580a081795fcd6019ec1457df6477
MISC metadata.xml 492 BLAKE2B 21caf589f9a40c2b9203b2a45a4f0b60c6ce52e78a8fec7173c1a8467cb92a4891c28e412324f5652d1fd17b3fb07780b800bac643c3476e5b2d962124f86066 SHA512 5882c4db0ceea18943171338a23ffe8b31431a63d255cac0ef3544a3a267699969f9a735b5cb30d834f053c4bd574cb5aaa45c991c1b919c986683d991aacdba
diff --git a/x11-plugins/vicious/vicious-2.6.0.ebuild b/x11-plugins/vicious/vicious-2.6.0.ebuild
new file mode 100644
index 000000000000..8b67470f2103
--- /dev/null
+++ b/x11-plugins/vicious/vicious-2.6.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature
+
+DESCRIPTION="Modular widget library for x11-wm/awesome"
+HOMEPAGE="https://github.com/vicious-widgets/vicious"
+SRC_URI="https://github.com/${PN}-widgets/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~riscv ~x86"
+IUSE="contrib"
+
+RDEPEND="x11-wm/awesome"
+
+src_install() {
+ insinto /usr/share/awesome/lib/vicious
+ doins -r widgets spawn.lua helpers.lua init.lua
+
+ if use contrib; then
+ insinto /usr/share/awesome/lib/vicious/contrib
+ doins contrib/*.lua
+ fi
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ # Note that as of 2.5.1 this list may or may not be incomplete - it has been produced
+ # only by searching for occurrences of vicious.spawn (the recommended way of calling
+ # external helpers because it supports async) and popen (still used by many contrib widgets).
+ # Moreover, dependencies of all non-Linux widgets have been excluded on purpose.
+ optfeature_header "These widgets need some dependencies:"
+ optfeature "cmus" "media-sound/cmus"
+ optfeature "fs" "sys-apps/coreutils" # df
+ optfeature "gmail" "net-misc/curl"
+ optfeature "hddtemp" "net-misc/curl[telnet] app-admin/hddtemp"
+ optfeature "hwmontemp" "sys-apps/grep"
+ optfeature "mdir" "sys-apps/findutils"
+ optfeature "mpd" "net-misc/curl[telnet] media-sound/mpd"
+ optfeature "notmuch" "net-mail/notmuch"
+ optfeature "volume" "media-sound/alsa-utils" # amixer
+ optfeature "weather" "net-misc/curl"
+ optfeature "wifi" "net-wireless/wireless-tools"
+ optfeature "wifiiw" "net-wireless/iw"
+ if use contrib; then
+ optfeature "contrib/btc" "net-misc/curl"
+ optfeature "contrib/buildbot" "net-misc/curl"
+ optfeature "contrib/countfiles" "sys-apps/findutils"
+ optfeature "contrib/mpc" "media-sound/mpc"
+ optfeature "contrib/openweather" "net-misc/curl"
+ optfeature "contrib/netcfg" "sys-apps/coreutils" # ls
+ optfeature "contrib/nvinf" "x11-drivers/nvidia-drivers" # nvidia-settings
+ # ossvol needs 'ossmix' - not packaged?
+ optfeature "contrib/pulse" "media-sound/pulseaudio" # pacmd
+ optfeature "contrib/rss" "net-misc/curl"
+ optfeature "contrib/sensors" "sys-apps/lm-sensors"
+ optfeature "contrib/wpa" "net-wireless/wpa_supplicant" # wpa-cli
+ fi
+ elog
+}