summaryrefslogtreecommitdiff
path: root/x11-plugins
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-25 09:05:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-25 09:05:36 +0100
commit070db046876f2e8d5f83cb7b380ae857d06e493a (patch)
tree81c82d9b296b94b64dd8aea6ad369ea43f40bc14 /x11-plugins
parent4bc145ba9c79d57abcafc9b97c72bd5addd3e833 (diff)
gentoo auto-resync : 25:05:2023 - 09:05:36
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/Manifest.gzbin26904 -> 26899 bytes
-rw-r--r--x11-plugins/wmDownload/Manifest2
-rw-r--r--x11-plugins/wmDownload/files/wmDownload-strtouq-musl.patch24
-rw-r--r--x11-plugins/wmDownload/wmDownload-0.1.2a-r4.ebuild37
4 files changed, 63 insertions, 0 deletions
diff --git a/x11-plugins/Manifest.gz b/x11-plugins/Manifest.gz
index 5e1216901ad6..5bd709f52f9d 100644
--- a/x11-plugins/Manifest.gz
+++ b/x11-plugins/Manifest.gz
Binary files differ
diff --git a/x11-plugins/wmDownload/Manifest b/x11-plugins/wmDownload/Manifest
index f536e38907f6..62d4db1e502b 100644
--- a/x11-plugins/wmDownload/Manifest
+++ b/x11-plugins/wmDownload/Manifest
@@ -1,4 +1,6 @@
AUX wmDownload-0.1.2a-makefile.patch 801 BLAKE2B 6e54b6619150b239a418cc2f356690fc3f36e51f5ffda5c28b6b9d4af31caf741d1f27c6de3a032bdeb765477333022d4bd57aa01f511be08dd10b04074ee0c1 SHA512 e54e8ff7e5710cc2f888a6042c5e7886b71d5ab45b041c3e001bc5304abdaf0c2e125110ddfbf7d0c5116a47f86c24b7cf05e5e94ecdf2206f58e16f390b5683
+AUX wmDownload-strtouq-musl.patch 605 BLAKE2B 7e68c2703435aa08a534df371e177e50de991369aeb9282f48f26db279d49fcedcf65533bec53baa1ee802e86004f1773480993d18edb50bc1b69f3529452c28 SHA512 56c3a5bbcdc09f5c937ba73536d9b2b08bbc4fa144859c958874ac4ec3b2ba6748e35fb87ae9b34021eea9a103f15b6c9e5c4bacf81f3cf5e87339c5587d7a97
DIST wmDownload-0.1.2a.tar.gz 11449 BLAKE2B abbb01eec5dc9dc2932d4e7857b850ba64b564618e6643282b9659623444062d785bcde41ddfc0684d02cee6ca62df847a341ecdab8d48de9dc751d906563a0a SHA512 95bc3f7c9be344d88146fd0b2407afe43f5975bbf2158fc54c9d9200a7f09b53af3a8cae790b2e26f8e34792317a28524422e0d4f96e0e603e05af92d6354752
EBUILD wmDownload-0.1.2a-r3.ebuild 788 BLAKE2B eb04793763e54b942fdacaf3fe9c0b800f08892f0d84da7d9457404a90864069a776e53f304cc87ac5275b16b880f1e49ac176cc5a0920c4cdc936a3d9738764 SHA512 53af863e6069ca53a6b4f81359c9ba65d8c931b696648dbea0ecc3c7674f3762d3a54ff35dff30fc67994d210146becbceac6ab29cc01c7c76d97b6af2e7a31a
+EBUILD wmDownload-0.1.2a-r4.ebuild 826 BLAKE2B d23ecfe25618bf85ade240b99ac7e392d857ecb4b428ec8d6270446d0f66492ffa4a6544569aaff9cc06819f14c8c655be253ac97482c7ba728a724ac89c3ae1 SHA512 d6e99bbef5c66caa4b94144628bf6e2974d32077593c73e5b1ab20196170352f3cc82072fafa61dc103bd6454f5d0496106b894336ed8db13c7d87ab12b0255c
MISC metadata.xml 531 BLAKE2B 41fe5f8bb94f951402f7a12a4cebe3c6e1553b6e1d600a2b7165533debd73eceaa8fca4a91af500af3760d8ea22ce77e01921ed51f2a67e825a02560e63be052 SHA512 55e83c464bd88d1b8465f364fc58f6d5659a0800e23a18b43fd249492179d9edec6957928ebc4aa97cad226320133c446ce2b3a31ca0f4b8fa6b48d3ce6b98c7
diff --git a/x11-plugins/wmDownload/files/wmDownload-strtouq-musl.patch b/x11-plugins/wmDownload/files/wmDownload-strtouq-musl.patch
new file mode 100644
index 000000000000..3a9a5d00b206
--- /dev/null
+++ b/x11-plugins/wmDownload/files/wmDownload-strtouq-musl.patch
@@ -0,0 +1,24 @@
+https://bugs.gentoo.org/898922
+From: Brahmajit Das <brahmajit.xyz@gmail.com>
+Date: Sun, 14 May 2023 14:39:59 +0530
+Subject: [PATCH] Don't use strtouq while building on non-glibc system
+
+Bug: https://bugs.gentoo.org/898922
+Signed-off-by: Brahmajit Das <brahmajit.xyz@gmail.com>
+--- a/wmDownload.c
++++ b/wmDownload.c
+@@ -205,7 +205,11 @@ void checknetstats ()
+ {
+ p = (char *)strtok (NULL, tokens);
+
++#ifdef __GLIBC__
+ bytes = strtouq(p, NULL, 0);
++#else
++ bytes = strtoul(p, NULL, 0);
++#endif
+
+ kbytes = (bytes == 0)?0:bytes/base;
+ bytes = bytes%base;
+--
+2.40.1
+
diff --git a/x11-plugins/wmDownload/wmDownload-0.1.2a-r4.ebuild b/x11-plugins/wmDownload/wmDownload-0.1.2a-r4.ebuild
new file mode 100644
index 000000000000..a71cdc57295a
--- /dev/null
+++ b/x11-plugins/wmDownload/wmDownload-0.1.2a-r4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="dockapp that displays how much data you've received on each eth and ppp device"
+SRC_URI="mirror://sourceforge/wmdownload/${P}.tar.gz"
+HOMEPAGE="http://wmdownload.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/libdockapp-0.7:=
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-makefile.patch
+ "${FILESDIR}"/${PN}-strtouq-musl.patch
+)
+DOCS=( CHANGELOG CREDITS HINTS README TODO )
+
+src_prepare() {
+ sed -e 's#<dockapp.h>#<libdockapp/dockapp.h>#' -i *.c || die
+ default
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" LIBDIR="/usr/$(get_libdir)"
+}