summaryrefslogtreecommitdiff
path: root/x11-plugins/wmwifi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-10 18:05:22 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-10 18:05:22 +0000
commit17dcfeba22240edb3c54d96e319edf6c4bc008c3 (patch)
treebf7e044eef048853420208d083f77f7cd820e881 /x11-plugins/wmwifi
parentf95eeaf7db6ca1bfbb34c05fdad9ed9bb603b1c8 (diff)
gentoo auto-resync : 10:03:2023 - 18:05:22
Diffstat (limited to 'x11-plugins/wmwifi')
-rw-r--r--x11-plugins/wmwifi/Manifest2
-rw-r--r--x11-plugins/wmwifi/wmwifi-0.6-r1.ebuild9
2 files changed, 9 insertions, 2 deletions
diff --git a/x11-plugins/wmwifi/Manifest b/x11-plugins/wmwifi/Manifest
index 0e39503581dd..6cd7b9bc2fda 100644
--- a/x11-plugins/wmwifi/Manifest
+++ b/x11-plugins/wmwifi/Manifest
@@ -1,3 +1,3 @@
DIST wmwifi-0.6.tar.gz 150482 BLAKE2B 213f56897527b57ea2fd6123d9147c8d4547323104e940b632c2290fc6941478a9ee5d0aefbe5a06e2b20bd524b84eebd9d75bedc83054066975459b770fbc56 SHA512 ae0a66b68f991907b7e8434a872cc8b1fd9219d633260183a6917e1d34dd4ddc7be91dd71b6cb0ed20781ca4eaa6a0cfc2adcb7a838b734050264a5fae4cadd0
-EBUILD wmwifi-0.6-r1.ebuild 635 BLAKE2B 5b14b07c832a2927b4e645d1e2dacd9cc3995ce97be38cb910e6440ccf0dd6ad8bb543315a8af1c1423d139bef55281b7fc2e5e462beef2436c20885ef0644f5 SHA512 9dcfc3bd59c6dc3e33651319f78891de993260400a952d63e147522bbc78fafa7dd350695df09fcd34cbc9b0ef0b34fdcf5b2bbd32b8a251658ff5478448ab5e
+EBUILD wmwifi-0.6-r1.ebuild 692 BLAKE2B d72ec63c0dbd95bfef40d0ce4ab62711bf948fa3edb696a8b37b9d149e275bb05af3885093df87ac1edd61efaff1aac55e6b02cb5a233ae20f0420a62ad22981 SHA512 891ad96a58f1e0d056544f2c9a4b67dfc72f97de6483960e8de739090a8959b0856f9dcff7a98255bf75d35c2ca2342a1c6e1c07f271e9f056b3a2f3ca6b2ba7
MISC metadata.xml 250 BLAKE2B 3d69a837b82fe334630573d6bf123718a3eac254377bc2ca86a2268f210cbcef9922db631e91954bceacc28828b54ad567d0568a4df655545ac56a4a54151d76 SHA512 ee587c14474743ca118c5468d1cd04ce5e3533ea29550ae74a7d517f092c895fa18c7edc7e9ffe7757b62c214dda7abf5352ee838a6dbd7d1079d60d2762732f
diff --git a/x11-plugins/wmwifi/wmwifi-0.6-r1.ebuild b/x11-plugins/wmwifi/wmwifi-0.6-r1.ebuild
index a52c89a719bf..255ed5e11010 100644
--- a/x11-plugins/wmwifi/wmwifi-0.6-r1.ebuild
+++ b/x11-plugins/wmwifi/wmwifi-0.6-r1.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit autotools
+
DESCRIPTION="wireless network interface monitor dockapp"
HOMEPAGE="https://www.dockapps.net/wmwifi"
SRC_URI="https://www.dockapps.net/download/${P}.tar.gz"
@@ -19,6 +21,11 @@ RDEPEND="x11-libs/libX11
DEPEND="${RDEPEND}
x11-base/xorg-proto"
+src_prepare() {
+ default
+ eautoreconf
+}
+
src_compile() {
# by default it does not honour our CFLAGS
emake CFLAGS="${CFLAGS}" CPPFLAGS="${CFLAGS}"