summaryrefslogtreecommitdiff
path: root/x11-plugins/wmudmount/wmudmount-2.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-plugins/wmudmount/wmudmount-2.2-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-plugins/wmudmount/wmudmount-2.2-r1.ebuild')
-rw-r--r--x11-plugins/wmudmount/wmudmount-2.2-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-plugins/wmudmount/wmudmount-2.2-r1.ebuild b/x11-plugins/wmudmount/wmudmount-2.2-r1.ebuild
new file mode 100644
index 000000000000..10f32669f521
--- /dev/null
+++ b/x11-plugins/wmudmount/wmudmount-2.2-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils gnome2-utils xdg
+
+DESCRIPTION="A filesystem mounter that uses udisks to handle notification and mounting"
+HOMEPAGE="https://sourceforge.net/projects/wmudmount/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnome-keyring libnotify"
+
+RDEPEND="sys-fs/udisks:2
+ >=x11-libs/gtk+-3.8.0:3
+ gnome-keyring? ( gnome-base/libgnome-keyring )
+ libnotify? ( >=x11-libs/libnotify-0.7 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ || ( media-gfx/imagemagick[png] media-gfx/graphicsmagick[imagemagick,png] )"
+
+DOCS="ChangeLog"
+
+src_configure() {
+ econf \
+ $(use_with libnotify) \
+ $(use_with gnome-keyring)
+}
+
+pkg_preinst() { gnome2_icon_savelist; }
+pkg_postinst() { gnome2_icon_cache_update; }
+pkg_postrm() { gnome2_icon_cache_update; }