summaryrefslogtreecommitdiff
path: root/x11-plugins/wmtz
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-02 14:45:16 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-02 14:45:16 +0000
commita70f42c65202d88c203c40910fef8f96f333d1ee (patch)
treede550ee3deb79c550ae1aba7fcce118d5d4dbc31 /x11-plugins/wmtz
parent721254b86a09bdedd5eefd0de7899c90ea2ead1a (diff)
gentoo resync : 02.01.2018
Diffstat (limited to 'x11-plugins/wmtz')
-rw-r--r--x11-plugins/wmtz/Manifest2
-rw-r--r--x11-plugins/wmtz/files/wmtz-0.7-list.patch127
-rw-r--r--x11-plugins/wmtz/files/wmtz-0.7.patch48
3 files changed, 0 insertions, 177 deletions
diff --git a/x11-plugins/wmtz/Manifest b/x11-plugins/wmtz/Manifest
index c7452fdfebaa..8d0c467fa0fd 100644
--- a/x11-plugins/wmtz/Manifest
+++ b/x11-plugins/wmtz/Manifest
@@ -1,5 +1,3 @@
-AUX wmtz-0.7-list.patch 2918 BLAKE2B 393e76edcefa54d814229cc2d8d21556d7437580c1a226d454470175de6ad1e9a688555aabdc60aaa328d578b4d04b300e64ae431efe9d7680400118d52116d5 SHA512 2a6da4a9b676ea51bbcc400b3255f3c10240db13fd6da46921f6c91d5529ecf50120e195b815e58a1b0a8bad81a944e8da3cba261a69579f36165f35ad23f144
-AUX wmtz-0.7.patch 1305 BLAKE2B 13b09b49fda781a04e73a29d56dc87e1aec8a71a4ea643d49797fb15c2b6eecd390d02885c9fbdb17e5614285ddc7831f4d1c75b9fb58976aefe4aeb78c05bff SHA512 4e04a1a95d39ebe9982d4f26acf827fbbeb953f4dcc695c5b39dcb46423bd9d58336838a3d8a28af142b9a5391625a6965ece158b735514adce4438afa662194
DIST wmtz-0.7_p20150816.tar.gz 19310 BLAKE2B 7f3bc0b077a9a667211cc588f1fb7c3d1d246256724a6cf5a17f028d2d334d02f898a798aca6fae11910868d312844bbe8ac5bfd190229f3ae829e97e50e2247 SHA512 60c9b66423332b155ce262d30026a5091c0379eb3257f547af1203d331968e9f334a533ed03832476512893d06cea857db9c044b30115978904510f9725e8455
EBUILD wmtz-0.7_p20150816.ebuild 909 BLAKE2B 1779da6b58b351f016470ae11fe49c583be86456f19c26c0a2d46a4d8d43c0afc0984db1a002004522686cacff9d0819339b1d7bea81ac16a97b76bf256c1dc0 SHA512 ac4cab3641b4e772f945afb41694c88d9d8a7a28bf44b91e42af6997d2ed9ff49c4ef1c9aa8fcafb8607d474e70a54471ec4c6023e131a846c3fc2601b05feec
MISC metadata.xml 249 BLAKE2B ba223d81d4cf6b9ca1ba3a63e356bec0d9aa6f4cdf2ad3b29a6c97a6e5bad854154f8b9e6fc3d65d155c93daa706d03c84395b53951e3e326ffc19c8d0df0eb5 SHA512 1a1312bb0e9f74f1e3852218d8fd4817fbad3bc65633cecbe8735607bc33c1e05b414c2628ff3f6e24dfc4a3999de7191f6cdadd2161b03cf614d5b6f24fab8d
diff --git a/x11-plugins/wmtz/files/wmtz-0.7-list.patch b/x11-plugins/wmtz/files/wmtz-0.7-list.patch
deleted file mode 100644
index 1b1ac317669e..000000000000
--- a/x11-plugins/wmtz/files/wmtz-0.7-list.patch
+++ /dev/null
@@ -1,127 +0,0 @@
-diff -Naur wmgeneral.orig/list.c wmgeneral/list.c
---- wmgeneral.orig/list.c 2016-01-04 13:28:36.583339716 +0100
-+++ wmgeneral/list.c 2016-01-04 13:28:48.694343645 +0100
-@@ -38,7 +38,7 @@
-
- /* Return a cons cell produced from (head . tail)
-
--INLINE LinkedList*
-+LinkedList*
- list_cons(void* head, LinkedList* tail)
- {
- LinkedList* cell;
-@@ -51,7 +51,7 @@
-
- /* Return the length of a list, list_length(NULL) returns zero
-
--INLINE int
-+int
- list_length(LinkedList* list)
- {
- int i = 0;
-@@ -66,7 +66,7 @@
- /* Return the Nth element of LIST, where N count from zero. If N
- larger than the list length, NULL is returned
-
--INLINE void*
-+void*
- list_nth(int index, LinkedList* list)
- {
- while(index-- != 0)
-@@ -81,7 +81,7 @@
-
- /* Remove the element at the head by replacing it by its successor
-
--INLINE void
-+void
- list_remove_head(LinkedList** list)
- {
- if (!*list) return;
-@@ -101,7 +101,7 @@
-
- /* Remove the element with `car' set to ELEMENT
- /*
--INLINE void
-+void
- list_remove_elem(LinkedList** list, void* elem)
- {
- while (*list)
-@@ -112,7 +112,7 @@
- }
-
-
--INLINE LinkedList *
-+LinkedList *
- list_remove_elem(LinkedList* list, void* elem)
- {
- LinkedList *tmp;
-@@ -132,7 +132,7 @@
-
- /* Return element that has ELEM as car
-
--INLINE LinkedList*
-+LinkedList*
- list_find(LinkedList* list, void* elem)
- {
- while(list)
-@@ -146,7 +146,7 @@
-
- /* Free list (backwards recursive)
-
--INLINE void
-+void
- list_free(LinkedList* list)
- {
- if(list)
-@@ -158,7 +158,7 @@
-
- /* Map FUNCTION over all elements in LIST
-
--INLINE void
-+void
- list_mapcar(LinkedList* list, void(*function)(void*))
- {
- while(list)
-diff -Naur wmgeneral.orig/list.h wmgeneral/list.h
---- wmgeneral.orig/list.h 2016-01-04 13:28:36.583339716 +0100
-+++ wmgeneral/list.h 2016-01-04 13:28:39.471340654 +0100
-@@ -29,31 +29,25 @@
- #ifndef __LIST_H_
- #define __LIST_H_
-
--#if defined(__GNUC__) && !defined(__STRICT_ANSI__)
--# define INLINE inline
--#else
--# define INLINE
--#endif
--
- typedef struct LinkedList {
- void *head;
- struct LinkedList *tail;
- } LinkedList;
-
--INLINE LinkedList* list_cons(void* head, LinkedList* tail);
-+LinkedList* list_cons(void* head, LinkedList* tail);
-
--INLINE int list_length(LinkedList* list);
-+int list_length(LinkedList* list);
-
--INLINE void* list_nth(int index, LinkedList* list);
-+void* list_nth(int index, LinkedList* list);
-
--INLINE void list_remove_head(LinkedList** list);
-+void list_remove_head(LinkedList** list);
-
--INLINE LinkedList *list_remove_elem(LinkedList* list, void* elem);
-+LinkedList *list_remove_elem(LinkedList* list, void* elem);
-
--INLINE void list_mapcar(LinkedList* list, void(*function)(void*));
-+void list_mapcar(LinkedList* list, void(*function)(void*));
-
--INLINE LinkedList*list_find(LinkedList* list, void* elem);
-+LinkedList*list_find(LinkedList* list, void* elem);
-
--INLINE void list_free(LinkedList* list);
-+void list_free(LinkedList* list);
-
- #endif
diff --git a/x11-plugins/wmtz/files/wmtz-0.7.patch b/x11-plugins/wmtz/files/wmtz-0.7.patch
deleted file mode 100644
index adb5c68f1b6c..000000000000
--- a/x11-plugins/wmtz/files/wmtz-0.7.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-diff -ur wmtz-0.7.orig/wmtz/Makefile wmtz-0.7/wmtz/Makefile
---- wmtz-0.7.orig/wmtz/Makefile 2001-03-11 15:57:59.000000000 +0200
-+++ wmtz-0.7/wmtz/Makefile 2008-01-12 15:24:29.000000000 +0200
-@@ -1,5 +1,5 @@
- CC = gcc
--LIBDIR = -L/usr/X11R6/lib
-+LIBDIR = -L/usr/lib
- LIBS = -lXpm -lXext -lX11 -lm
- FLAGS = -O2
- DESTDIR = /usr/local
-@@ -10,7 +10,7 @@
-
-
- .c.o:
-- $(CC) -I/usr/X11R6/include $(FLAGS) -c -Wall $< -o $*.o
-+ $(CC) -I/usr/include $(FLAGS) -c -Wall $< -o $*.o
-
- wmtz: $(OBJS)
- $(CC) $(FLAGS) -o wmtz $^ -lXext $(LIBDIR) $(LIBS)
-diff -ur wmtz-0.7.orig/wmtz/wmtz.c wmtz-0.7/wmtz/wmtz.c
---- wmtz-0.7.orig/wmtz/wmtz.c 2001-04-16 22:26:34.000000000 +0300
-+++ wmtz-0.7/wmtz/wmtz.c 2008-01-12 15:17:37.000000000 +0200
-@@ -51,8 +51,7 @@
- #define STRSIZE 10
- #define LMST 1
- #define GMST 0
--#define ABOUT "xmessage -center -buttons \"Close\" \"WMTZ - Window Maker Time Zone dockapp v0.7
--http://www.geocities.com/jl1n/wmtz/wmtz.html\""
-+#define ABOUT "xmessage -center -buttons \"Close\" \"WMTZ - Window Maker Time Zone dockapp v0.7\nhttp://www.geocities.com/jl1n/wmtz/wmtz.html\""
-
-
- /*
-@@ -479,6 +478,7 @@
- but_stat = -1;
- break;
- default:
-+ break;
- }
- }
-
-@@ -529,6 +529,7 @@
- exit(0);
- break;
- default:
-+ break;
- }
- return;
- }