summaryrefslogtreecommitdiff
path: root/x11-plugins/wmtime
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
commite3872864be25f7421015bef2732fa57c0c9fb726 (patch)
tree9cb29a544215119b5c5538e37211b994ce1c87ae /x11-plugins/wmtime
parent480486b52ea64765faf696c88b2c6a26a5a454d4 (diff)
gentoo resync : 04.08.2018
Diffstat (limited to 'x11-plugins/wmtime')
-rw-r--r--x11-plugins/wmtime/Manifest1
-rw-r--r--x11-plugins/wmtime/wmtime-1.4-r1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/x11-plugins/wmtime/Manifest b/x11-plugins/wmtime/Manifest
index b219c3f36995..1cdb9ac40b3f 100644
--- a/x11-plugins/wmtime/Manifest
+++ b/x11-plugins/wmtime/Manifest
@@ -1,3 +1,4 @@
DIST wmtime-1.4.tar.gz 19200 BLAKE2B 453668828ee512979e840b66473c7acc52558965ad00d9ab750aba93d22447dcab13c424c2d5ad07baf3ef7c8e2d6c785c1ad5ccbe44d42aed867bdb7a10e679 SHA512 46e35ffe41aaa55a651fa2a4002ab83fd45f901dc12ce1e0ed981666b9b620aa11666920f595fc3a782c54cc036491e0c676fb760a38cd6f6b24e264723b87fb
+EBUILD wmtime-1.4-r1.ebuild 717 BLAKE2B d1870722e3da25e0b9eb7565bae39ba62cc4e7c268bf52b259ecf0476582ca2c0b92b65326574fc322614c673af69ae2ee066713f0da171f437bf05eb1f3f932 SHA512 6fa34dfa52a7c33fbdc3ac6f0dee478c4b91662a89fbea089f62119982c43f6707a054de912f6210c645aeda3b2d25c3e03924702cb33eda8eb7e6c50220032b
EBUILD wmtime-1.4.ebuild 709 BLAKE2B 2938503529e33fb7c5b691e8a68db142168fe3c336b1dc730ad2d9d44c0795460758a28250d0ec6f4297a54ab0b97aa8d8dea9b4ad43fe6fa4b9c43e983d75e8 SHA512 5af8a73d9269e9e497091dbd42b23654de873d291eb310ca71dc5a3719e25f9ebcb08155f4b5e6b2e0572778e3a11ceb5db4c3ac665082901de5680110a55ce1
MISC metadata.xml 249 BLAKE2B ba223d81d4cf6b9ca1ba3a63e356bec0d9aa6f4cdf2ad3b29a6c97a6e5bad854154f8b9e6fc3d65d155c93daa706d03c84395b53951e3e326ffc19c8d0df0eb5 SHA512 1a1312bb0e9f74f1e3852218d8fd4817fbad3bc65633cecbe8735607bc33c1e05b414c2628ff3f6e24dfc4a3999de7191f6cdadd2161b03cf614d5b6f24fab8d
diff --git a/x11-plugins/wmtime/wmtime-1.4-r1.ebuild b/x11-plugins/wmtime/wmtime-1.4-r1.ebuild
new file mode 100644
index 000000000000..4ea44b15579c
--- /dev/null
+++ b/x11-plugins/wmtime/wmtime-1.4-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="applet which displays the date and time in a dockable tile"
+HOMEPAGE="https://www.dockapps.net/wmtime"
+SRC_URI="https://dev.gentoo.org/~voyageur/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=x11-libs/libdockapp-0.7:=
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+DOCS=( BUGS CHANGES HINTS README TODO )
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install () {
+ emake DESTDIR="${D}" PREFIX=/usr install
+ einstalldocs
+}