summaryrefslogtreecommitdiff
path: root/x11-plugins/wmping
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-plugins/wmping
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-plugins/wmping')
-rw-r--r--x11-plugins/wmping/Manifest6
-rw-r--r--x11-plugins/wmping/files/wmping-0.2.1-format-security.patch38
-rw-r--r--x11-plugins/wmping/metadata.xml11
-rw-r--r--x11-plugins/wmping/wmping-0.2.1.ebuild42
4 files changed, 97 insertions, 0 deletions
diff --git a/x11-plugins/wmping/Manifest b/x11-plugins/wmping/Manifest
new file mode 100644
index 000000000000..bf999711b3c2
--- /dev/null
+++ b/x11-plugins/wmping/Manifest
@@ -0,0 +1,6 @@
+AUX wmping-0.2.1-format-security.patch 1195 SHA256 82bf8e5539c02d717fa602d9432eabd83608266c1088f9432edfd9801f061c65 SHA512 78aa196f01cbf121f8a90319835754a7d7f929bbf95cb82d42d7885aff829cd4487cc812182818b22fa1602a0757b8d3eae8660386dafeaef33993633bf94940 WHIRLPOOL a95e0fd06a59262c9a8e50f28af585bc698ff00171aae6964d07ac1105c0da0a2942459d25ad03ca9fb0cc2d9d9c7cced5b8e72c0a53fe47947034fa7c53c86d
+DIST wmping-0.2.1.tar.gz 100059 SHA256 8d10c77839f087add2c3b2f483585ede92f4c57a4a18262c74406591877a3c33 SHA512 c13a4906810d7513fe3e1e88a77846a5b0a299180f858f755a2fe602eaab802e77062d29e767e4d5c28e45bc6ce1431418cc71ee26c3c8fc5521280999bb9351 WHIRLPOOL f42b9a35c3b9d45116cbef6d3644310b05961e00fab96674acd13eb7193681223892dd10f586abf2ee829b29ca432095f1a7b8c92516813390df0194036b6997
+EBUILD wmping-0.2.1.ebuild 795 SHA256 7de5dfe5f479ff845da3fdf01884b7ca3dbb2697c0813869a13ff0727ef94b90 SHA512 cf7d72d9fd577a14e5c95e16d66f0c816708ce674748a05bcdaf2d3a88591895b1d7764a18aa1004faf7dd96a1578586c84e1143b621614024df741a94ad88d1 WHIRLPOOL 9be679ca0f259695c9992d7bc964a4485e104cba666869518a884a71343d53fdf6d1e17ded1eea7397959dbb8205dfd4f3c0e7b017a48582260db97170cff8db
+MISC ChangeLog 3041 SHA256 83d4f151ab9c639a9f014466e941d0d77dd536e1ced8dfc5a0687f66826d2653 SHA512 de60889291e317aa543a5d13a532d2ccd712f54c6a79a8ca66be2b6fc438acdd98e13e95dee4494013796b7ecd41905134d96e0dfc482772acc283ac00759253 WHIRLPOOL 15c69d0dfedf34e26b0fa8856799031c3881cb34aba1786354052d5d33a5623a2ed9ca643c0ade5bf96938c3632c3d11278ba3a8b3bb08a6d916a0b1905ad0a3
+MISC ChangeLog-2015 941 SHA256 fd6418b3a4fa6c8aea4d110b5307f218626525651ce9be229807b45362bd42b6 SHA512 c017952166355e3b4b669539c0de954e7ba2a0cb59b53fe79d8d72b10302b7556f5d4d99e9307bf41f4ed19bc7d632ad5f8c755bb4a62405ba864458c425bbe6 WHIRLPOOL 5825c50c505d42f90042e4a3db93a59363788263c4d237569fb31f69756fa9ae6229f901a91cf3ed7a35274f5947bfc270f12385bcc8a3a5c822f7c4273d94a0
+MISC metadata.xml 328 SHA256 a17c84c8e9ab704626272141c49ccae02790b8faf0a3eb8bcfcbde4a99add841 SHA512 72ccd52965da37da3846f3fb915addf58cebb1066f1a08c38e6b96ea734aa01502a153b716ab731d0d1f7df73a5d230f4674d96c8b1e464180a097a42bbd7b5b WHIRLPOOL e8c1d6a00d9861c0158f9890affde5d8e6f5c71f1644293faecc40ff172ae8b0c81217d5a913421f957a8b5e9e02434dabed720df8fd89ad38014765eca5ee2e
diff --git a/x11-plugins/wmping/files/wmping-0.2.1-format-security.patch b/x11-plugins/wmping/files/wmping-0.2.1-format-security.patch
new file mode 100644
index 000000000000..cc9976d04ad2
--- /dev/null
+++ b/x11-plugins/wmping/files/wmping-0.2.1-format-security.patch
@@ -0,0 +1,38 @@
+--- wmping.c.orig 2015-08-06 15:03:32.407526918 +0200
++++ wmping.c 2015-08-06 15:03:56.907978079 +0200
+@@ -237,7 +237,7 @@
+ if(strcmp(tokens[1],"="))
+ {
+ sprintf(str_err, "Not correct format of configuration file ( %s ): line %u", cfgfile, lineN);
+- fprintf(stderr, str_err);
++ fprintf(stderr, "%s", str_err);
+ exit(-1);
+ }
+
+@@ -288,7 +288,7 @@
+ else
+ {
+ sprintf(str_err, "Not correct format of configuration file ( %s ): line %u", cfgfile, lineN);
+- fprintf(stderr, str_err);
++ fprintf(stderr, "%s", str_err);
+ exit(-1);
+
+ }
+@@ -297,7 +297,7 @@
+ else
+ {
+ sprintf(str_err, "Error open configuration file ( %s ): %s", cfgfile, strerror(errno));
+- fprintf(stderr, str_err);
++ fprintf(stderr, "%s", str_err);
+ fprintf(stderr, "\n Create default configuration file\n");
+ createDefaultCfg(cfgfile);
+ }
+@@ -305,7 +305,7 @@
+ else
+ {
+ sprintf(str_err, "Error open configuration file ( %s ): %s", cfgfile, strerror(errno));
+- fprintf(stderr, str_err);
++ fprintf(stderr, "%s", str_err);
+ fprintf(stderr, "\n Create default configuration file\n");
+ createDefaultCfg(cfgfile);
+ }
diff --git a/x11-plugins/wmping/metadata.xml b/x11-plugins/wmping/metadata.xml
new file mode 100644
index 000000000000..a346b51ff273
--- /dev/null
+++ b/x11-plugins/wmping/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>voyageur@gentoo.org</email>
+ <name>Bernard Cafarelli</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">wmping</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-plugins/wmping/wmping-0.2.1.ebuild b/x11-plugins/wmping/wmping-0.2.1.ebuild
new file mode 100644
index 000000000000..4b44c98b1243
--- /dev/null
+++ b/x11-plugins/wmping/wmping-0.2.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="a simple host status monitoring dockapp"
+HOMEPAGE="https://sourceforge.net/projects/wmping"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+suid"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto
+ x11-proto/xproto
+ x11-libs/libICE
+ x11-libs/libXt"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-format-security.patch
+}
+
+src_install() {
+ if use suid; then
+ emake DESTDIR="${D}" install
+ else
+ dosbin ${PN}
+ fi
+
+ doman ${PN}.1
+ dodoc AUTHORS CHANGES README
+}
+
+pkg_postinst() {
+ use suid || ewarn "warning, ${PN} needs to be executed as root."
+}