summaryrefslogtreecommitdiff
path: root/x11-plugins/wmpinboard/wmpinboard-1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-plugins/wmpinboard/wmpinboard-1.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-plugins/wmpinboard/wmpinboard-1.0.ebuild')
-rw-r--r--x11-plugins/wmpinboard/wmpinboard-1.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/x11-plugins/wmpinboard/wmpinboard-1.0.ebuild b/x11-plugins/wmpinboard/wmpinboard-1.0.ebuild
new file mode 100644
index 000000000000..c61c4996c8b4
--- /dev/null
+++ b/x11-plugins/wmpinboard/wmpinboard-1.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit eutils
+
+IUSE=""
+DESCRIPTION="Window Maker dock applet resembling a miniature pinboard"
+SRC_URI="http://dockapps.windowmaker.org/download.php/id/131/${P}.tar.gz"
+HOMEPAGE="http://dockapps.windowmaker.org/file.php/id/93"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ x11-proto/xextproto"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 sparc alpha amd64 ppc"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/wmpinboard-1.0-segfault.patch
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+}