summaryrefslogtreecommitdiff
path: root/x11-plugins/wmcube
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-02 14:45:16 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-02 14:45:16 +0000
commita70f42c65202d88c203c40910fef8f96f333d1ee (patch)
treede550ee3deb79c550ae1aba7fcce118d5d4dbc31 /x11-plugins/wmcube
parent721254b86a09bdedd5eefd0de7899c90ea2ead1a (diff)
gentoo resync : 02.01.2018
Diffstat (limited to 'x11-plugins/wmcube')
-rw-r--r--x11-plugins/wmcube/Manifest1
-rw-r--r--x11-plugins/wmcube/files/wmcube-0.98-list.patch127
2 files changed, 0 insertions, 128 deletions
diff --git a/x11-plugins/wmcube/Manifest b/x11-plugins/wmcube/Manifest
index c29b2fb802a8..375098fc6be6 100644
--- a/x11-plugins/wmcube/Manifest
+++ b/x11-plugins/wmcube/Manifest
@@ -1,4 +1,3 @@
-AUX wmcube-0.98-list.patch 2918 BLAKE2B 393e76edcefa54d814229cc2d8d21556d7437580c1a226d454470175de6ad1e9a688555aabdc60aaa328d578b4d04b300e64ae431efe9d7680400118d52116d5 SHA512 2a6da4a9b676ea51bbcc400b3255f3c10240db13fd6da46921f6c91d5529ecf50120e195b815e58a1b0a8bad81a944e8da3cba261a69579f36165f35ad23f144
DIST wmcube-1.0.2.tar.gz 56908 BLAKE2B 4ce373b3822e9d515d611e577214a2c51a8e4fb62cc47cf9f64ad49441bd3c53ba09d301c898a37f6ffafecf984ae04cefce9890c593797719b29fb54425f6c7 SHA512 171700848a9d674ced3ee33468b967b2be706e72863f8356f0d8d72785c06a1c34b5be3597e5604bf74e97ee911ca05b68a28bfe67c1171a61c7084450d622de
EBUILD wmcube-1.0.2.ebuild 905 BLAKE2B 7cdf13f3021adac5cd2b71b813fe8c4522c6fe819c4e16bdb6f520e5cc4ad008cf3c8695cf9279c931d15302efa7a4ae0aae05dfda6c2b83db5402b30f19f020 SHA512 4a73a28b1d57ba605f83fe5c7b2a5362a0d98369b409ea689f0f501065ff9b7584d86b08553d2a7dee8230fa09421c47e274da05aeed762c734a7590623c8210
MISC metadata.xml 417 BLAKE2B 7d594431bb0c67d7275c73e53e6958ff415beaf1ec79b82bbf887b3ac16d17e13e8319f467c17bd376b04130959767be65e6112bd7032b853502b8d9dd07817e SHA512 370036b0e1a6a62c3251f22f687277a6ad684b02e423db1b2879fc08267db8c4b6de7e0e35de500b836dd1156d717bf3100e3de4027477473e30aeb1adf339ba
diff --git a/x11-plugins/wmcube/files/wmcube-0.98-list.patch b/x11-plugins/wmcube/files/wmcube-0.98-list.patch
deleted file mode 100644
index 1b1ac317669e..000000000000
--- a/x11-plugins/wmcube/files/wmcube-0.98-list.patch
+++ /dev/null
@@ -1,127 +0,0 @@
-diff -Naur wmgeneral.orig/list.c wmgeneral/list.c
---- wmgeneral.orig/list.c 2016-01-04 13:28:36.583339716 +0100
-+++ wmgeneral/list.c 2016-01-04 13:28:48.694343645 +0100
-@@ -38,7 +38,7 @@
-
- /* Return a cons cell produced from (head . tail)
-
--INLINE LinkedList*
-+LinkedList*
- list_cons(void* head, LinkedList* tail)
- {
- LinkedList* cell;
-@@ -51,7 +51,7 @@
-
- /* Return the length of a list, list_length(NULL) returns zero
-
--INLINE int
-+int
- list_length(LinkedList* list)
- {
- int i = 0;
-@@ -66,7 +66,7 @@
- /* Return the Nth element of LIST, where N count from zero. If N
- larger than the list length, NULL is returned
-
--INLINE void*
-+void*
- list_nth(int index, LinkedList* list)
- {
- while(index-- != 0)
-@@ -81,7 +81,7 @@
-
- /* Remove the element at the head by replacing it by its successor
-
--INLINE void
-+void
- list_remove_head(LinkedList** list)
- {
- if (!*list) return;
-@@ -101,7 +101,7 @@
-
- /* Remove the element with `car' set to ELEMENT
- /*
--INLINE void
-+void
- list_remove_elem(LinkedList** list, void* elem)
- {
- while (*list)
-@@ -112,7 +112,7 @@
- }
-
-
--INLINE LinkedList *
-+LinkedList *
- list_remove_elem(LinkedList* list, void* elem)
- {
- LinkedList *tmp;
-@@ -132,7 +132,7 @@
-
- /* Return element that has ELEM as car
-
--INLINE LinkedList*
-+LinkedList*
- list_find(LinkedList* list, void* elem)
- {
- while(list)
-@@ -146,7 +146,7 @@
-
- /* Free list (backwards recursive)
-
--INLINE void
-+void
- list_free(LinkedList* list)
- {
- if(list)
-@@ -158,7 +158,7 @@
-
- /* Map FUNCTION over all elements in LIST
-
--INLINE void
-+void
- list_mapcar(LinkedList* list, void(*function)(void*))
- {
- while(list)
-diff -Naur wmgeneral.orig/list.h wmgeneral/list.h
---- wmgeneral.orig/list.h 2016-01-04 13:28:36.583339716 +0100
-+++ wmgeneral/list.h 2016-01-04 13:28:39.471340654 +0100
-@@ -29,31 +29,25 @@
- #ifndef __LIST_H_
- #define __LIST_H_
-
--#if defined(__GNUC__) && !defined(__STRICT_ANSI__)
--# define INLINE inline
--#else
--# define INLINE
--#endif
--
- typedef struct LinkedList {
- void *head;
- struct LinkedList *tail;
- } LinkedList;
-
--INLINE LinkedList* list_cons(void* head, LinkedList* tail);
-+LinkedList* list_cons(void* head, LinkedList* tail);
-
--INLINE int list_length(LinkedList* list);
-+int list_length(LinkedList* list);
-
--INLINE void* list_nth(int index, LinkedList* list);
-+void* list_nth(int index, LinkedList* list);
-
--INLINE void list_remove_head(LinkedList** list);
-+void list_remove_head(LinkedList** list);
-
--INLINE LinkedList *list_remove_elem(LinkedList* list, void* elem);
-+LinkedList *list_remove_elem(LinkedList* list, void* elem);
-
--INLINE void list_mapcar(LinkedList* list, void(*function)(void*));
-+void list_mapcar(LinkedList* list, void(*function)(void*));
-
--INLINE LinkedList*list_find(LinkedList* list, void* elem);
-+LinkedList*list_find(LinkedList* list, void* elem);
-
--INLINE void list_free(LinkedList* list);
-+void list_free(LinkedList* list);
-
- #endif