summaryrefslogtreecommitdiff
path: root/x11-plugins/wmcube
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-plugins/wmcube
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-plugins/wmcube')
-rw-r--r--x11-plugins/wmcube/Manifest6
-rw-r--r--x11-plugins/wmcube/files/wmcube-0.98-list.patch127
-rw-r--r--x11-plugins/wmcube/metadata.xml13
-rw-r--r--x11-plugins/wmcube/wmcube-0.98.ebuild47
4 files changed, 193 insertions, 0 deletions
diff --git a/x11-plugins/wmcube/Manifest b/x11-plugins/wmcube/Manifest
new file mode 100644
index 000000000000..ca136d3f49a5
--- /dev/null
+++ b/x11-plugins/wmcube/Manifest
@@ -0,0 +1,6 @@
+AUX wmcube-0.98-list.patch 2918 SHA256 5e01887b3404df12e221fc43e1a4c1980fd66f44b6f189a7967ccc27bfbaf388 SHA512 2a6da4a9b676ea51bbcc400b3255f3c10240db13fd6da46921f6c91d5529ecf50120e195b815e58a1b0a8bad81a944e8da3cba261a69579f36165f35ad23f144 WHIRLPOOL 676703bedaff4c18d49e04ac31832ba3a370ad67e38008008af5849993592fcc693d1ae1b59d4e9adfb9e0c10ab9058fe012c0d8fe164cd9abe8d1048d915ec3
+DIST wmcube-0.98.tar.gz 38305 SHA256 5111d7bfacc7ffa26419dbc22542a0a0e1d33e5795882d1799b216abd73df24b SHA512 137e31b3de175bcbe593c420b79804a8904436923747e0db338258e87e08ed6dc4748c29910c68e01e072850fb0f0ca6d1979fee22d6e8edc76c500a5cd84230 WHIRLPOOL e86e330aa73fca437005acc87ae72262e6c1bf2dacfdcfe01b7711ed8315258bbfe6433982474ab394b7e76745de4cbdc87ec6eb2ddbd87bda9101616a43555d
+EBUILD wmcube-0.98.ebuild 908 SHA256 e3e614044319601a5a0496da168493e7747849f03f04b17fe2b420cfa9aa3340 SHA512 fa296d46439830013e48743c835504b83c00dde1a343c3d2b53ed47155119ad793c81affbf1f25c2e21eccd3b881e2962c39a3f7e0a5f02e28f629b2bf826cd2 WHIRLPOOL c6fbf7d26141fab8b7ee30b70bd100345c9daf58724787212abdc4fc3c148a094b9c2d748d2d5a297ee723c52c429de796f8f481c0f4f1430e3d5cab30077863
+MISC ChangeLog 3168 SHA256 dfac32d30897a366ecf373073bfcb13828d5784529e1cb0d39509295a96f3be0 SHA512 327222dd2e53958795fa9bf45109b9fb8e93deaa3c5ea47c7c7d68474b0dcc59fc82a4f04053a0f4283c99eef7c820a5c42e4e187b42c605b63fdef9ee277efc WHIRLPOOL 654026a72dc1ec7fe9c5867b0999a1926cffdc737b35ec36faa81f0ff653466904c9af4f90b28a758daa88379e1e80e25c4274b28d45de2ac8e0bf4747e97806
+MISC ChangeLog-2015 1349 SHA256 6c781bc092655d84b0da35b60573efcb60986f4459c0f9dbdbf96b865365e097 SHA512 c21096a9470261b80b6a91a1a6d3306e9bacae43185a8e88eadb4d59033589346de66ecccea41d9dbd89d8bddf2099b72e07b05f6b49e2c47c3cf69e8829a5e1 WHIRLPOOL 5abd336c4ff6a8493a6e8ff6364912948d022496439d24fdb576f5ebc236a03a4efe4c8061c2c5a75569936c8f1beabe187ef518b935a216b5020edfe30e46eb
+MISC metadata.xml 417 SHA256 63345488d6081e1de74e9f84729c8e6d0e59d0f7ab20c56cab974f71c45e6c7b SHA512 370036b0e1a6a62c3251f22f687277a6ad684b02e423db1b2879fc08267db8c4b6de7e0e35de500b836dd1156d717bf3100e3de4027477473e30aeb1adf339ba WHIRLPOOL 40312149a506decdcda5a2a56c3ffa4dab1bc1cec0bb5fa9271732e0ae00e75ca522662be1a05d9eb5aaeb4d264e158af94d26e9c6aaaf53fcd2e59a54a648ae
diff --git a/x11-plugins/wmcube/files/wmcube-0.98-list.patch b/x11-plugins/wmcube/files/wmcube-0.98-list.patch
new file mode 100644
index 000000000000..1b1ac317669e
--- /dev/null
+++ b/x11-plugins/wmcube/files/wmcube-0.98-list.patch
@@ -0,0 +1,127 @@
+diff -Naur wmgeneral.orig/list.c wmgeneral/list.c
+--- wmgeneral.orig/list.c 2016-01-04 13:28:36.583339716 +0100
++++ wmgeneral/list.c 2016-01-04 13:28:48.694343645 +0100
+@@ -38,7 +38,7 @@
+
+ /* Return a cons cell produced from (head . tail)
+
+-INLINE LinkedList*
++LinkedList*
+ list_cons(void* head, LinkedList* tail)
+ {
+ LinkedList* cell;
+@@ -51,7 +51,7 @@
+
+ /* Return the length of a list, list_length(NULL) returns zero
+
+-INLINE int
++int
+ list_length(LinkedList* list)
+ {
+ int i = 0;
+@@ -66,7 +66,7 @@
+ /* Return the Nth element of LIST, where N count from zero. If N
+ larger than the list length, NULL is returned
+
+-INLINE void*
++void*
+ list_nth(int index, LinkedList* list)
+ {
+ while(index-- != 0)
+@@ -81,7 +81,7 @@
+
+ /* Remove the element at the head by replacing it by its successor
+
+-INLINE void
++void
+ list_remove_head(LinkedList** list)
+ {
+ if (!*list) return;
+@@ -101,7 +101,7 @@
+
+ /* Remove the element with `car' set to ELEMENT
+ /*
+-INLINE void
++void
+ list_remove_elem(LinkedList** list, void* elem)
+ {
+ while (*list)
+@@ -112,7 +112,7 @@
+ }
+
+
+-INLINE LinkedList *
++LinkedList *
+ list_remove_elem(LinkedList* list, void* elem)
+ {
+ LinkedList *tmp;
+@@ -132,7 +132,7 @@
+
+ /* Return element that has ELEM as car
+
+-INLINE LinkedList*
++LinkedList*
+ list_find(LinkedList* list, void* elem)
+ {
+ while(list)
+@@ -146,7 +146,7 @@
+
+ /* Free list (backwards recursive)
+
+-INLINE void
++void
+ list_free(LinkedList* list)
+ {
+ if(list)
+@@ -158,7 +158,7 @@
+
+ /* Map FUNCTION over all elements in LIST
+
+-INLINE void
++void
+ list_mapcar(LinkedList* list, void(*function)(void*))
+ {
+ while(list)
+diff -Naur wmgeneral.orig/list.h wmgeneral/list.h
+--- wmgeneral.orig/list.h 2016-01-04 13:28:36.583339716 +0100
++++ wmgeneral/list.h 2016-01-04 13:28:39.471340654 +0100
+@@ -29,31 +29,25 @@
+ #ifndef __LIST_H_
+ #define __LIST_H_
+
+-#if defined(__GNUC__) && !defined(__STRICT_ANSI__)
+-# define INLINE inline
+-#else
+-# define INLINE
+-#endif
+-
+ typedef struct LinkedList {
+ void *head;
+ struct LinkedList *tail;
+ } LinkedList;
+
+-INLINE LinkedList* list_cons(void* head, LinkedList* tail);
++LinkedList* list_cons(void* head, LinkedList* tail);
+
+-INLINE int list_length(LinkedList* list);
++int list_length(LinkedList* list);
+
+-INLINE void* list_nth(int index, LinkedList* list);
++void* list_nth(int index, LinkedList* list);
+
+-INLINE void list_remove_head(LinkedList** list);
++void list_remove_head(LinkedList** list);
+
+-INLINE LinkedList *list_remove_elem(LinkedList* list, void* elem);
++LinkedList *list_remove_elem(LinkedList* list, void* elem);
+
+-INLINE void list_mapcar(LinkedList* list, void(*function)(void*));
++void list_mapcar(LinkedList* list, void(*function)(void*));
+
+-INLINE LinkedList*list_find(LinkedList* list, void* elem);
++LinkedList*list_find(LinkedList* list, void* elem);
+
+-INLINE void list_free(LinkedList* list);
++void list_free(LinkedList* list);
+
+ #endif
diff --git a/x11-plugins/wmcube/metadata.xml b/x11-plugins/wmcube/metadata.xml
new file mode 100644
index 000000000000..d018d6b527b5
--- /dev/null
+++ b/x11-plugins/wmcube/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>voyageur@gentoo.org</email>
+ <name>Bernard Cafarelli</name>
+</maintainer>
+
+<longdescription>
+wmCube is a dockapp that displays a realtime rotating 3D object and the current
+CPU load. You can design your own objects for it.
+</longdescription>
+</pkgmetadata>
diff --git a/x11-plugins/wmcube/wmcube-0.98.ebuild b/x11-plugins/wmcube/wmcube-0.98.ebuild
new file mode 100644
index 000000000000..e795d285b3fe
--- /dev/null
+++ b/x11-plugins/wmcube/wmcube-0.98.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=3
+inherit eutils
+
+DESCRIPTION="a dockapp cpu monitor with spinning 3d objects"
+HOMEPAGE="http://kling.mine.nu/kling/wmcube.htm"
+SRC_URI="http://kling.mine.nu/kling/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 amd64 ~mips ppc ppc64 ~sparc"
+
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto"
+
+S="${WORKDIR}/${P}/wmcube"
+
+src_prepare() {
+ #Honour Gentoo LDFLAGS, see bug #337893.
+ sed -e "s/-o wmcube/${LDFLAGS} -o wmcube/" -i Makefile
+
+ cd "${WORKDIR}"/${P} || die
+ epatch "${FILESDIR}"/${P}-list.patch
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" || die "parallel make failed"
+}
+
+src_install() {
+ dobin wmcube
+
+ cd ..
+ dodoc README CHANGES
+
+ SHARE=/usr/share/wmcube
+ dodir ${SHARE}
+ insinto ${SHARE}
+ doins 3dObjects/*
+}