summaryrefslogtreecommitdiff
path: root/x11-plugins/wmcoincoin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-19 23:10:29 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-19 23:10:29 +0100
commit318828e81fe6707ce5a64e6a59a76d4c0ca709f8 (patch)
treecc4b7818f7960cb193ad2bf7f7defe71adb3ee47 /x11-plugins/wmcoincoin
parent590c04803f88a968b4a750c0f420eb314e1fe968 (diff)
gentoo auto-resync : 19:09:2023 - 23:10:29
Diffstat (limited to 'x11-plugins/wmcoincoin')
-rw-r--r--x11-plugins/wmcoincoin/Manifest1
-rw-r--r--x11-plugins/wmcoincoin/wmcoincoin-2.6.3-r1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/x11-plugins/wmcoincoin/Manifest b/x11-plugins/wmcoincoin/Manifest
index 78c417ffa41d..da2dfc3070ef 100644
--- a/x11-plugins/wmcoincoin/Manifest
+++ b/x11-plugins/wmcoincoin/Manifest
@@ -1,3 +1,4 @@
DIST wmcoincoin-2.6.3.tar.gz 973973 BLAKE2B 4dcbb79ddb23c47fb891fde56137bb385ccf841eb54ce7a34cf060d4924d859a5a2ac40d504a26e763f1fe075796e09ec6a00a0080d214add2469db6b2f3a4d4 SHA512 daffd94387a03e780250877ae43e5431a7c0710862dd9fab04efc254e02e648215fa9c301bf1ed6d1a9ca5182a2a88d10ea4c385d92752d047492e6e9ad01d2d
+EBUILD wmcoincoin-2.6.3-r1.ebuild 714 BLAKE2B 36bb15e5a7d48cee47f8a93758ce0df87c53b50d236fef5198d56399f68fe06aab36c733843e91d2933aa81943c42f195072d34757f50f0d5e76300d905f8058 SHA512 ae6d6f08aa739b1afca5fcecbc9cad2236ecdedb407fbd0f87d7bd6daea8ef322096172515430348c48e6a14db855022ed953b7e7fa58e5abed3544d05b5b531
EBUILD wmcoincoin-2.6.3.ebuild 740 BLAKE2B 66e17f93da9cce72d15ec239df9dccb993594330a42afc2ba87b5d6b7774a948ad49e701c6b541e507c438fce4693486384ca1e7ff24c5a20e415cf1ce2a2723 SHA512 09a15f2d65a327472625f927413cd8d2d0521da57c824a39ed82e57fd3bb06f4390c283d8865cd340632096cc011bad69200b100317cb0281323c9ba44962318
MISC metadata.xml 643 BLAKE2B 78484fb1aea7668b0c8695944e6544cb4c543c82e4a2fbd546eeceaf8acc32056fe8c2ab195dd19ed30d6770178078d8fcc0dfd5851e6c577e8373c80c14728f SHA512 8d93441de80b4ed40b5c8856797b924f75c5d293d1dc913dbf7f7fe11fe025457767b031f64b7bf691ce54b3e13cde3358da574ebf0fb92312dad0a45baa4200
diff --git a/x11-plugins/wmcoincoin/wmcoincoin-2.6.3-r1.ebuild b/x11-plugins/wmcoincoin/wmcoincoin-2.6.3-r1.ebuild
new file mode 100644
index 000000000000..a0d96ed75a44
--- /dev/null
+++ b/x11-plugins/wmcoincoin/wmcoincoin-2.6.3-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Dockapp for browsing dacode news and board sites"
+HOMEPAGE="http://hules.free.fr/wmcoincoin/"
+SRC_URI="http://hules.free.fr/${PN}/download/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls xinerama"
+
+RDEPEND="media-libs/imlib2[X]
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXft
+ x11-libs/libXmu
+ x11-libs/libXpm
+ xinerama? ( x11-libs/libXinerama )"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+ x11-libs/libXt"
+BDEPEND="virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable xinerama)
+}