summaryrefslogtreecommitdiff
path: root/x11-plugins/wmblob
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-19 23:10:29 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-19 23:10:29 +0100
commit318828e81fe6707ce5a64e6a59a76d4c0ca709f8 (patch)
treecc4b7818f7960cb193ad2bf7f7defe71adb3ee47 /x11-plugins/wmblob
parent590c04803f88a968b4a750c0f420eb314e1fe968 (diff)
gentoo auto-resync : 19:09:2023 - 23:10:29
Diffstat (limited to 'x11-plugins/wmblob')
-rw-r--r--x11-plugins/wmblob/Manifest1
-rw-r--r--x11-plugins/wmblob/wmblob-1.0.4-r1.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/x11-plugins/wmblob/Manifest b/x11-plugins/wmblob/Manifest
index e0039913a80d..bb0a8a31fe14 100644
--- a/x11-plugins/wmblob/Manifest
+++ b/x11-plugins/wmblob/Manifest
@@ -1,3 +1,4 @@
DIST wmblob-1.0.4.tar.bz2 179284 BLAKE2B 79025a4d80c05bd8f9d1a962762680e24ae0eb09c8bf961833f4f4c59b086ecc8563ef71c28678c969da75f1f074c691c9fd6a6919358886e64f7fcb814611a3 SHA512 d325711e6c6c865a97386793a7c3f0e0833044001ccc336f2a4e9974799e5ff00936b0d90a0dc4a3280ba27a8d1f97239ba51d61e6e5b104e7cf82c8aeed5ec1
+EBUILD wmblob-1.0.4-r1.ebuild 727 BLAKE2B 6c05f1248806214792c6244d85a7a392c03e2eeedadb43750cca5c3dffb4b3f6d326eba70e2047070b72d980db3c830ab66356201d917dd7e9abbe135567c074 SHA512 a8e13085ddbaa2b3a6091affaaff51ecc31367131a9c67b917a10e24fdbb28500c188f555711a13a76e72fab0212971eccdaa73924ed4b1d688a0b59e928dca5
EBUILD wmblob-1.0.4.ebuild 731 BLAKE2B 49c635a6beb8cc353e79f93a2bfd53d4409df9641456ff3365bb10c4eea241d2750108b590120ab48d704eee7262294700e90e8117d4a0a206c5a23a0de251c8 SHA512 b0818713ca81d57ddd67f440f5ed9c9546fc21b13a5e36ded78caa78ce0024ea30145df217e7bdaebc981709baa892c8f04f11981f3515f192bc8b74632c3212
MISC metadata.xml 253 BLAKE2B 8557c513beef73e834b0a000c523a3241da961c6307b6e98ac857dad0888c4bbd028c98f8499f01086c24e8f2f57c64bc75db20154dab232adefc2510fccac03 SHA512 67dd372ef7b684101d9198c6199a6403f8750132d80aab4f4daa4b31ebaea3d82eb9a18e904734e2ac10c77b237d67210055949ff1c6d5aad4f75951a096884a
diff --git a/x11-plugins/wmblob/wmblob-1.0.4-r1.ebuild b/x11-plugins/wmblob/wmblob-1.0.4-r1.ebuild
new file mode 100644
index 000000000000..fb0d67e04abb
--- /dev/null
+++ b/x11-plugins/wmblob/wmblob-1.0.4-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Fancy but useless dockapp with moving blobs"
+HOMEPAGE="https://github.com/bbidulock/wmblob"
+SRC_URI="https://github.com/bbidulock/wmblob/releases/download/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND="x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/libXpm
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-libs/libXt"
+BDEPEND="virtual/pkgconfig"
+
+DOCS="AUTHORS ChangeLog NEWS README doc/how_it_works"
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e "s|-O2|${CFLAGS}|g" \
+ -e "s|\$x_libraries|/usr/$(get_libdir)|" \
+ configure.ac || die
+
+ eautoreconf
+}