summaryrefslogtreecommitdiff
path: root/x11-plugins/wmamixer
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-21 19:12:17 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-21 19:12:17 +0100
commit580d27c925587ae7c65ac3d2706b1c8ce42b0463 (patch)
treebe152335ae762fc8404bd696b02425db417ae5c9 /x11-plugins/wmamixer
parent47af801ff0ee4a4207b36e6917b1e496354940c0 (diff)
gentoo resync : 21.07.2018
Diffstat (limited to 'x11-plugins/wmamixer')
-rw-r--r--x11-plugins/wmamixer/Manifest2
-rw-r--r--x11-plugins/wmamixer/wmamixer-1.0.ebuild32
2 files changed, 34 insertions, 0 deletions
diff --git a/x11-plugins/wmamixer/Manifest b/x11-plugins/wmamixer/Manifest
index df4ea6709496..80860a3b2f2e 100644
--- a/x11-plugins/wmamixer/Manifest
+++ b/x11-plugins/wmamixer/Manifest
@@ -1,3 +1,5 @@
DIST wmamixer-0.2.tar.gz 93067 BLAKE2B 9e888b9b3214eee6c8e59da564e36e8f7c1e55df711ebeaaf73300b27b934840994177d003f2be14f40b5e30321c572e82888e030534ccc7cbe0ff12109231d4 SHA512 94f971ac59134f926b637c6c4ef80be1e082b9b81d2e744b921562140e610e958233645c0ee12310086f1aaa3bbb20622c6c92666dac51df3a963e725374583c
+DIST wmamixer-1.0.tar.gz 93181 BLAKE2B 16370da2c1f408b3b584a649e1317850963f2446997e1027cfa7b2cdfa1351807761d3981e2a2cc91ef42272df1146550b3943862d1cf03af5f96d83e6c2c42f SHA512 a5eac2ea3f63770f64f6d2c921aec0d38c54e953c7f5bf1d7ba14c510cc21927751d6939571eb3aede2c7bd0e44bfc84f8dd06ae1af0ef71f2bce8f1b6614708
EBUILD wmamixer-0.2.ebuild 689 BLAKE2B bfb4fe4651215b362cb80ff4cf73b1c292460f22e0092098fa02a2c6d390d349e054286980398cfd0b5c70b3c9fcfb315ae4f8c2f2dd7955331edb1ab480839a SHA512 a61081ce73b586568d6cf49141daa079be7e5590e19c3a218be1354c19291c156ff1f9685e8d3323c88edc02c2ff9795ec02c496e5678b8d67772ac9f68f9e9c
+EBUILD wmamixer-1.0.ebuild 690 BLAKE2B 59f091bdd8019d353f5f1e83b428cedd8c69f790fcf5200b0aa14027b093eadf2400266000582f50d9c8b20612b9c442456b3cf58c7d7f92134d559b72d08a1b SHA512 d88c7bcc14fe83d32019499e4f32f77422ccf22389482682a94803fd704f5f9f50238e00d7cc0b2fef645923f91d0adc86eb16dec0ce33fd29d3574449a99197
MISC metadata.xml 474 BLAKE2B b04cb3956e9f0b9043bf692a6d61024c8986ff04217f8bc9ce0fa15f7db50522798085eb5f4fe828dd9dd8c5baa11bf3ad658bc9cbd703b7e9cee3ab31320357 SHA512 2ef950ff6ffc4ec050aaa62f0da4589043a2b56df7f4e9c80bac8614e5817872dd08bacdb15b584f90a0b790812cbf3a6ebc343ffc65ffeb0cae081266891283
diff --git a/x11-plugins/wmamixer/wmamixer-1.0.ebuild b/x11-plugins/wmamixer/wmamixer-1.0.ebuild
new file mode 100644
index 000000000000..3e72430e43b8
--- /dev/null
+++ b/x11-plugins/wmamixer/wmamixer-1.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="ALSA mixer dockapp, fork of wmsmixer"
+HOMEPAGE="https://github.com/gryf/wmamixer"
+SRC_URI="https://github.com/gryf/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libXpm
+ x11-libs/libXext
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+DOCS=( README.rst )
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} -c -o wmamixer.o wmamixer.c
+ $(tc-getCC) ${LDFLAGS} -o wmamixer wmamixer.o -lm -lXpm -lXext -lX11 -lasound
+}
+
+src_install() {
+ dobin wmamixer
+ einstalldocs
+}