summaryrefslogtreecommitdiff
path: root/x11-plugins/wmacpimon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-19 23:10:29 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-19 23:10:29 +0100
commit318828e81fe6707ce5a64e6a59a76d4c0ca709f8 (patch)
treecc4b7818f7960cb193ad2bf7f7defe71adb3ee47 /x11-plugins/wmacpimon
parent590c04803f88a968b4a750c0f420eb314e1fe968 (diff)
gentoo auto-resync : 19:09:2023 - 23:10:29
Diffstat (limited to 'x11-plugins/wmacpimon')
-rw-r--r--x11-plugins/wmacpimon/Manifest1
-rw-r--r--x11-plugins/wmacpimon/wmacpimon-0.2.1-r1.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/x11-plugins/wmacpimon/Manifest b/x11-plugins/wmacpimon/Manifest
index 64dab4fa0728..7d02b1b8af18 100644
--- a/x11-plugins/wmacpimon/Manifest
+++ b/x11-plugins/wmacpimon/Manifest
@@ -2,5 +2,6 @@ AUX Makefile.patch 650 BLAKE2B 2dc6d65ff772b2a2594704acfcfac023183c1b5990075c9f7
AUX wmacpimon.c.patch 972 BLAKE2B 70e600339f3a43ca190ba67201dbf9dc6f0b2c0eca8171b333058624dbcfda0280999106215e959fec84a77e0bdc593b17173c515391fa1455b6573e61c4a8f6 SHA512 cb9080de40ae41804c0b4f8d1c105c7eed758cd12be71fda85afc0eeebb67965e619a6ed95b09bcaef99f0a6bebb51fbb7764080fbe511f1fbb483d43e581650
AUX wmacpimon.initscript 407 BLAKE2B f8a37c7f73febf9c1bc5403bf8f70ae95def8a2d411540ddda19d97bf07f4514ff13361a255dd52bf615e4243f3e9a32c38aa09d9b009068a5db01b259229c93 SHA512 cecadb137bc6acf2ef4c85afa75dd186c9217435c07384c8190a81e727509aa3715bf3b0e5c9851f0a54c6bb9d70c08339275aee30d110bd0cd3f37a9410f866
DIST wmacpimon-0.2.1.tar.gz 26498 BLAKE2B db1d308b24786a0db0fed5763ab5191f6ac2654c62d75996acaa93867cf7bc588da1f763b5483d64563b1e26b8d48063f143c28a61b61c4cbdb8de6c7ad58d1b SHA512 2b2d1da7608272969f0a2c98fae6398ebaa663a847acb79c795870cad85ca8d1317f5dfde6443634419c0c59b7457356bb8c195c1e7936f3cd8f3b251406084b
+EBUILD wmacpimon-0.2.1-r1.ebuild 1103 BLAKE2B a3dedf131b529a01ee4186fd320f3ea15bdab31a17f35db99ea9738a187ecafc0b48e08cd9e86cee0ce896fe4bbef0157c2ecd48bb875c95c024b738ae9ed5c8 SHA512 8deebf78ed87250278b22aaf29c2bbf041cec4cab62f64f77c905a6f2001c54d9948d40d855b77745769c1d96b74d77d468dea4a18b884791dc657339280841b
EBUILD wmacpimon-0.2.1.ebuild 1035 BLAKE2B ad88a1467418421200d4c4f2323dc9ee8fc92030f46b7e1ca81eaf5e900a4a914833388f8b809a1ea002a09429b8e85b909c10e89ad8c2a33c6018896c1e80ed SHA512 7fe519e4a8b2e553a9d8a22ab6272feeeee921c0f916dfd162cabac0708a0ab03274be09839c0f0e567fd1b716185e7fc27c48415859b3a7bdca02ea772e65ed
MISC metadata.xml 577 BLAKE2B 531192ebde4ffc4746d8985cdbe62c6722f0c3b43712db65061a86cc432a50c1b622a8919d2297ba22eebcd58145429a535a0481886d997ba315d7780a29a101 SHA512 de64d887542762a64b45e5056ea9042a98058177112cdefea54810872f3db1096d2aca17181e8efa4214814425b91c5cf9a0031876993f4fdc1ca1918f786214
diff --git a/x11-plugins/wmacpimon/wmacpimon-0.2.1-r1.ebuild b/x11-plugins/wmacpimon/wmacpimon-0.2.1-r1.ebuild
new file mode 100644
index 000000000000..878e89abe4e0
--- /dev/null
+++ b/x11-plugins/wmacpimon/wmacpimon-0.2.1-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="DockApp monitors the temperature and Speedstep features in ACPI-based systems"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+PATCHES=(
+ # patch wmacpimon.c file to set default path for
+ # wmacpimon.prc to /var/tmp/
+ "${FILESDIR}/wmacpimon.c.patch"
+
+ # fix LDFLAGS ordering. See bug #248618.
+ # fix LDFLAGS ordering again and other stuff. See bug #336091.
+ "${FILESDIR}/Makefile.patch"
+)
+
+src_compile() {
+ tc-export CC
+ default
+}
+
+src_install() {
+ dobin wmacpimond wmacpimon
+ dodoc AUTHORS ChangeLog README
+ newinitd "${FILESDIR}"/wmacpimon.initscript wmacpimon
+}
+
+pkg_postinst() {
+ elog "Remember to start the wmacpimond daemon"
+ elog "(by issuing the \"/etc/init.d/wmacpimon start\" command)"
+ elog "before you attempt to run wmacpimon..."
+}