summaryrefslogtreecommitdiff
path: root/x11-plugins/wmacpimon/wmacpimon-0.2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-plugins/wmacpimon/wmacpimon-0.2.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-plugins/wmacpimon/wmacpimon-0.2.1.ebuild')
-rw-r--r--x11-plugins/wmacpimon/wmacpimon-0.2.1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/x11-plugins/wmacpimon/wmacpimon-0.2.1.ebuild b/x11-plugins/wmacpimon/wmacpimon-0.2.1.ebuild
new file mode 100644
index 000000000000..30262c7d8128
--- /dev/null
+++ b/x11-plugins/wmacpimon/wmacpimon-0.2.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="DockApp monitors the temperature and Speedstep features in ACPI-based systems"
+HOMEPAGE="http://www.vrlteam.org/wmacpimon/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ x11-proto/xextproto"
+
+src_prepare() {
+ # patch wmacpimon.c file to set default path for
+ # wmacpimon.prc to /var/tmp/
+ epatch "${FILESDIR}"/wmacpimon.c.patch
+
+ # fix LDFLAGS ordering. See bug #248618.
+ # fix LDFLAGS ordering again and other stuff. See bug #336091.
+ epatch "${FILESDIR}"/Makefile.patch
+}
+
+src_install() {
+ dobin wmacpimond wmacpimon || die "dobin failed."
+ dodoc AUTHORS ChangeLog README
+ newinitd "${FILESDIR}"/wmacpimon.initscript wmacpimon
+}
+
+pkg_postinst() {
+ elog "Remember to start the wmacpimond daemon"
+ elog "(by issuing the \"/etc/init.d/wmacpimon start\" command)"
+ elog "before you attempt to run wmacpimon..."
+}