summaryrefslogtreecommitdiff
path: root/x11-plugins/wmSpaceWeather
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-21 19:12:17 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-21 19:12:17 +0100
commit580d27c925587ae7c65ac3d2706b1c8ce42b0463 (patch)
treebe152335ae762fc8404bd696b02425db417ae5c9 /x11-plugins/wmSpaceWeather
parent47af801ff0ee4a4207b36e6917b1e496354940c0 (diff)
gentoo resync : 21.07.2018
Diffstat (limited to 'x11-plugins/wmSpaceWeather')
-rw-r--r--x11-plugins/wmSpaceWeather/Manifest3
-rw-r--r--x11-plugins/wmSpaceWeather/wmSpaceWeather-1.04_p19-r1.ebuild60
-rw-r--r--x11-plugins/wmSpaceWeather/wmSpaceWeather-1.04_p19.ebuild2
3 files changed, 63 insertions, 2 deletions
diff --git a/x11-plugins/wmSpaceWeather/Manifest b/x11-plugins/wmSpaceWeather/Manifest
index a79de70a974d..dec3f7c77022 100644
--- a/x11-plugins/wmSpaceWeather/Manifest
+++ b/x11-plugins/wmSpaceWeather/Manifest
@@ -2,5 +2,6 @@ AUX wmSpaceWeather-1.04_p19-gentoo.patch 2034 BLAKE2B b81b73f9fb8c64c8ba9560f999
AUX wmSpaceWeather-1.04_p19-getkp.patch 1290 BLAKE2B dd350e57e2c0d40716ead4fb6bdc215f263bf5340c242550668ba252d78873a5ceab7cbf789209214daec41e33abea3a128b6cd5a5a83ee4e22b9de694ccecec SHA512 54f1ee8d2152bafc7895b2a626f27a4c5bf7b3702a2d14e2523952fcffb8e636f6f3ceb30d95b12b80470a58cb16dd50e04435ccae91e81c83097d41e2949b59
DIST wmspaceweather_1.04-19.diff.gz 9429 BLAKE2B c32b02d123783789962ef56f54b79b7afacc69573526cd5254b7083673a5ae0d70abaa82d84421c86d95139f9033a35de6511d131f73ff1360d43d1d0e320979 SHA512 f8228c15642b88b355f977a8ce73b474bf8874b4b64bce3f519e6ec6c5de1db7bbd1e5f40e57e367dc0a1dec47e5c32b87d4ce61e35043d71cee0005b06a5a78
DIST wmspaceweather_1.04.orig.tar.gz 36295 BLAKE2B 8f12a4ba7dc55d06ab1b3c86f387c0f4dc930d89b8ccf151096d736adb80deaf647e47bb4592f309042e2273936996b215cb2fffe83dbbe20bd10d94b1b7c109 SHA512 d422806d44a2929cfdb3e36c7075a4e02b64416db7c528d08411944f574dc34bb5e5ee48c55a3b9e796b15529857bcb480dc650ebdfe23cf1079ba09e2749154
-EBUILD wmSpaceWeather-1.04_p19.ebuild 1750 BLAKE2B de7b4ac5aba9b7e8a56ba7ad2ea61a5339155ed81d8b83755cb47292951bb044a01691015a2e258b4b6ca4600c28bd89eb1478b3a804745f5a723986fd377c54 SHA512 450dafa5f93c9fcc43db0b76d09f9d733d9995525a4f186bd71d5ba599da918a1eac2c22bcb077f85ad4834b8a6fa8ba4bdb1a55d2b4e6e42ded840ce9eddf31
+EBUILD wmSpaceWeather-1.04_p19-r1.ebuild 1621 BLAKE2B af863409907790a18fc0b807096d8fc2a38f3d5026d77bdc875a95cd7a0bc89333b0ed14e61828f448eb8a1af549ffa121f37b0b6b913e1259bfd8763dcc17aa SHA512 e1e27d138c061d792dda2cd58af43d52261157795046b5b7d2034764361ada3c7e0e862a5f6b7bef9ca9d492376d8f49c12646bcc6fe6090b65aae6728a85f6f
+EBUILD wmSpaceWeather-1.04_p19.ebuild 1744 BLAKE2B a50f25070cef9f86cde7af708cc5549f064f6d2bf0ca2c5889d9bde24ab847a238b767f819d3e813baeddc9d8315257fef85aa511aa33f06dbc868962c4b28f9 SHA512 a918147033cb30022ab49c7121531fc14c5dad791d79f156cd220f9ef573fd51e30a903a9465d28b1395d9366d2d5fb1c2bc4dd17339db4e53c20f32490442bd
MISC metadata.xml 349 BLAKE2B 1b79557d30af25f4419b0824e2f99a529447ad80c9c398d22b023eada927a3c840f8787aca77fff8f9073873f01a6be766595bd073cf8b11d335fea81f3e01ab SHA512 f39cf6f8c99788992a57ed0598fcd5d13b25fdf80dc5cf133091f5babae34e269b55e3464bec7b660e3ebb295edc4d46e76dda1978e4fde30e70620cefa21264
diff --git a/x11-plugins/wmSpaceWeather/wmSpaceWeather-1.04_p19-r1.ebuild b/x11-plugins/wmSpaceWeather/wmSpaceWeather-1.04_p19-r1.ebuild
new file mode 100644
index 000000000000..cb3cc31c6e87
--- /dev/null
+++ b/x11-plugins/wmSpaceWeather/wmSpaceWeather-1.04_p19-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils toolchain-funcs
+
+MY_PN="wmspaceweather"
+MY_PV_ORIG="${PV/_p*}"
+MY_PV_PATCH="${PV/_p/-}"
+MY_P_ORIG="${MY_PN}_${MY_PV_ORIG}.orig"
+MY_P_PATCH="${MY_PN}_${MY_PV_PATCH}.diff"
+
+DESCRIPTION="dockapp showing weather at geosynchronous orbit"
+HOMEPAGE="https://www.dockapps.net/wmspaceweather"
+SRC_URI="mirror://debian/pool/main/w/${MY_PN}/${MY_P_ORIG}.tar.gz
+ mirror://debian/pool/main/w/${MY_PN}/${MY_P_PATCH}.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+
+DOCS=( ../{BUGS,CHANGES,HINTS,README} )
+
+CDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${CDEPEND}
+ x11-base/xorg-proto"
+RDEPEND="${CDEPEND}
+ net-misc/curl
+ dev-lang/perl"
+
+S="${WORKDIR}/${MY_P_ORIG/_/-}/${PN}"
+
+src_unpack() {
+ unpack ${MY_P_ORIG}.tar.gz
+ epatch "${DISTDIR}"/${MY_P_PATCH}.gz
+
+ # need to apply patches from Debian first, do NOT change the order
+ cd "${S}" || die
+ mv ../debian/patches "${WORKDIR}"/patch || die
+ EPATCH_SUFFIX="dpatch" EPATCH_FORCE="yes" \
+ EPATCH_MULTI_MSG="Applying Debian patches ..." epatch
+ eapply "${FILESDIR}"/${P}-gentoo.patch
+ eapply "${FILESDIR}"/${P}-getkp.patch
+}
+
+src_compile() {
+ emake clean
+ emake CC="$(tc-getCC)" LIBDIR="/usr/$(get_libdir)"
+}
+
+pkg_postinst() {
+ elog "You need to emerge www-client/firefox or www-client/firefox-bin"
+ elog "to use the -url functionality - see man ${PN} for more info."
+ elog
+ elog "This version uses curl instead of wget. You may edit /usr/share/wmspaceweather/GetKp"
+ elog "if you don't like it."
+}
diff --git a/x11-plugins/wmSpaceWeather/wmSpaceWeather-1.04_p19.ebuild b/x11-plugins/wmSpaceWeather/wmSpaceWeather-1.04_p19.ebuild
index bb9f25ab7bc0..8a6964c62500 100644
--- a/x11-plugins/wmSpaceWeather/wmSpaceWeather-1.04_p19.ebuild
+++ b/x11-plugins/wmSpaceWeather/wmSpaceWeather-1.04_p19.ebuild
@@ -12,7 +12,7 @@ MY_P_ORIG="${MY_PN}_${MY_PV_ORIG}.orig"
MY_P_PATCH="${MY_PN}_${MY_PV_PATCH}.diff"
DESCRIPTION="dockapp showing weather at geosynchronous orbit"
-HOMEPAGE="http://packages.debian.org/sid/wmspaceweather"
+HOMEPAGE="https://www.dockapps.net/wmspaceweather"
SRC_URI="mirror://debian/pool/main/w/${MY_PN}/${MY_P_ORIG}.tar.gz
mirror://debian/pool/main/w/${MY_PN}/${MY_P_PATCH}.gz"