summaryrefslogtreecommitdiff
path: root/x11-plugins/pidgin-xmpp-receipts
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /x11-plugins/pidgin-xmpp-receipts
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'x11-plugins/pidgin-xmpp-receipts')
-rw-r--r--x11-plugins/pidgin-xmpp-receipts/Manifest2
-rw-r--r--x11-plugins/pidgin-xmpp-receipts/pidgin-xmpp-receipts-0.8.ebuild15
2 files changed, 8 insertions, 9 deletions
diff --git a/x11-plugins/pidgin-xmpp-receipts/Manifest b/x11-plugins/pidgin-xmpp-receipts/Manifest
index 377a93ec052a..cb73110fc546 100644
--- a/x11-plugins/pidgin-xmpp-receipts/Manifest
+++ b/x11-plugins/pidgin-xmpp-receipts/Manifest
@@ -1,3 +1,3 @@
DIST pidgin-xmpp-receipts-0.8.tar.gz 16021 BLAKE2B ba6eb7cb49ec75981e2c15f8aa471e6169ca4f9e6b03061248ff99669b7e31c838c466b1b476fed20bf3c1321954de13b053bbdd599f1ac4f58defacebabf383 SHA512 04113236d46066211d7e0f3c66f4bf1b6fb8a33ac675203f3cff15300eb97ffd3ee627e03fcc3ab3d1e9431fc107a9f7e9fca319f3debb773603d311b167b5a8
-EBUILD pidgin-xmpp-receipts-0.8.ebuild 886 BLAKE2B 0c3225f3ea6febf81693970007271c84a1ab8712f384aa5d125d000af7a6d43ca5b56c29ffadf0b757d8c6603ddacc47c67e4d4df9b200d0e6fe5470249bd652 SHA512 e263e4dd770d7b4605837d59bc8f909127ce1c1fdd3e5d123cb9ca0cfa277ab4ab0877c8b8f9e1b39cdb43373b89259b9fae5f5a896c86066c4819e06554b4c5
+EBUILD pidgin-xmpp-receipts-0.8.ebuild 875 BLAKE2B 8e50ac6124349edb98bbdc16d0657582cc2d730e71ed80bf944483b8bc8a74b9888e55d0eb2cd7b8efc12ccb16909bb6943414c3c07498ea38f636b2f6639f90 SHA512 90d22544e7347f16ccbc807690614348c30d331f6866a4d226d34bb572349e7a151e4cf39db5caeec79c7bd2d35410cc4939d5d1a517817e4a439bfd31746ed0
MISC metadata.xml 168 BLAKE2B 5f277cc66dbafa7e7985433f84b0f9a656a176a9b901862e2a8353ca2d4526797dded9696e835b9696c7f72324e94959cfb5a22de49a7e3e61604153886037ab SHA512 00eec08786156434460f5ed77b647579546cf1a86341a4f2c9c9c84326468c2c21dc5101c4277103b19266bb6f788823f4ddf3b9d044da26326d79bf2ac9a274
diff --git a/x11-plugins/pidgin-xmpp-receipts/pidgin-xmpp-receipts-0.8.ebuild b/x11-plugins/pidgin-xmpp-receipts/pidgin-xmpp-receipts-0.8.ebuild
index 601b7d04adf2..c62d3d1c907e 100644
--- a/x11-plugins/pidgin-xmpp-receipts/pidgin-xmpp-receipts-0.8.ebuild
+++ b/x11-plugins/pidgin-xmpp-receipts/pidgin-xmpp-receipts-0.8.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit vcs-snapshot toolchain-funcs
@@ -12,20 +12,19 @@ SRC_URI="https://github.com/noonien-d/pidgin-xmpp-receipts/archive/release_${PV}
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="amd64"
-IUSE=""
RDEPEND="net-im/pidgin[gtk]"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
src_compile() {
- GTK_PIDGIN_INCLUDES=$(pkg-config --cflags gtk+-2.0 pidgin)
+ GTK_PIDGIN_INCLUDES="$($(tc-getPKG_CONFIG) --cflags gtk+-2.0 pidgin)"
$(tc-getCC) ${LDFLAGS} -shared ${CFLAGS} -fpic ${GTK_PIDGIN_INCLUDES} -o ${PN/pidgin-/}.so ${PN/pidgin-/}.c || die
}
src_install() {
- PLUGIN_DIR_PIDGIN=$(pkg-config --variable=plugindir pidgin)
- dodir "${PLUGIN_DIR_PIDGIN}"
+ PLUGIN_DIR_PIDGIN=$($(tc-getPKG_CONFIG) --variable=plugindir pidgin)
+
insinto "${PLUGIN_DIR_PIDGIN}"
doins ${PN/pidgin-/}.so
}