summaryrefslogtreecommitdiff
path: root/x11-plugins/pidgin-sipe/pidgin-sipe-1.22.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-plugins/pidgin-sipe/pidgin-sipe-1.22.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-plugins/pidgin-sipe/pidgin-sipe-1.22.0.ebuild')
-rw-r--r--x11-plugins/pidgin-sipe/pidgin-sipe-1.22.0.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/x11-plugins/pidgin-sipe/pidgin-sipe-1.22.0.ebuild b/x11-plugins/pidgin-sipe/pidgin-sipe-1.22.0.ebuild
new file mode 100644
index 000000000000..8b7372dda468
--- /dev/null
+++ b/x11-plugins/pidgin-sipe/pidgin-sipe-1.22.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools eutils
+
+DESCRIPTION="Pidgin Plug-in SIPE (Sip Exchange Protocol)"
+HOMEPAGE="http://sipe.sourceforge.net/"
+SRC_URI="mirror://sourceforge/sipe/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="debug kerberos ocs2005-message-hack openssl telepathy voice"
+
+RDEPEND="
+ dev-libs/gmime:2.6
+ dev-libs/libxml2
+ openssl? ( dev-libs/openssl:= )
+ !openssl? ( dev-libs/nss )
+ kerberos? ( virtual/krb5 )
+ voice? (
+ >=dev-libs/glib-2.28.0
+ >=net-libs/libnice-0.1.0
+ media-libs/gstreamer:1.0
+ >=net-im/pidgin-2.8.0
+ net-libs/farstream:0.2
+ )
+ !voice? (
+ >=dev-libs/glib-2.12.0:2
+ net-im/pidgin
+ )
+ telepathy? (
+ >=sys-apps/dbus-1.1.0
+ >=dev-libs/dbus-glib-0.61
+ >=dev-libs/glib-2.28:2
+ >=net-libs/telepathy-glib-0.18.0
+ )
+"
+
+DEPEND="dev-util/intltool
+ virtual/pkgconfig
+ ${RDEPEND}
+"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-purple \
+ --disable-quality-check \
+ $(use_enable telepathy) \
+ $(use_enable debug) \
+ $(use_enable ocs2005-message-hack) \
+ $(use_with kerberos krb5) \
+ $(use_with voice vv) \
+ $(use_enable !openssl nss) \
+ $(use_enable openssl)
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dodoc AUTHORS ChangeLog NEWS TODO README
+}