summaryrefslogtreecommitdiff
path: root/x11-plugins/pidgin-privacy-please/pidgin-privacy-please-0.7.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-plugins/pidgin-privacy-please/pidgin-privacy-please-0.7.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-plugins/pidgin-privacy-please/pidgin-privacy-please-0.7.1.ebuild')
-rw-r--r--x11-plugins/pidgin-privacy-please/pidgin-privacy-please-0.7.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/x11-plugins/pidgin-privacy-please/pidgin-privacy-please-0.7.1.ebuild b/x11-plugins/pidgin-privacy-please/pidgin-privacy-please-0.7.1.ebuild
new file mode 100644
index 000000000000..9f968952cb3f
--- /dev/null
+++ b/x11-plugins/pidgin-privacy-please/pidgin-privacy-please-0.7.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=2
+
+inherit autotools
+
+DESCRIPTION="pidgin plugin to stop spammers from annoying you"
+HOMEPAGE="https://code.google.com/p/pidgin-privacy-please/"
+SRC_URI="https://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64"
+IUSE="linguas_de linguas_pl linguas_ru"
+
+RDEPEND="<net-im/pidgin-3[gtk]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ sys-devel/gettext"
+
+src_prepare() {
+ sed -e 's: -Wall -g3::' -i configure.ac || die
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" ALL_LINGUAS="${LANGS}" install || die
+ dodoc AUTHORS ChangeLog NEWS README || die
+}