summaryrefslogtreecommitdiff
path: root/x11-plugins/pidgin-libnotify/pidgin-libnotify-0.14-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-plugins/pidgin-libnotify/pidgin-libnotify-0.14-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-plugins/pidgin-libnotify/pidgin-libnotify-0.14-r1.ebuild')
-rw-r--r--x11-plugins/pidgin-libnotify/pidgin-libnotify-0.14-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/x11-plugins/pidgin-libnotify/pidgin-libnotify-0.14-r1.ebuild b/x11-plugins/pidgin-libnotify/pidgin-libnotify-0.14-r1.ebuild
new file mode 100644
index 000000000000..325a0607571e
--- /dev/null
+++ b/x11-plugins/pidgin-libnotify/pidgin-libnotify-0.14-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="pidgin-libnotify provides popups for pidgin via a libnotify interface"
+HOMEPAGE="http://gaim-libnotify.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gaim-libnotify/${P}.tar.gz
+ mirror://debian/pool/main/p/${PN}/${PN}_${PV}-4.debian.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="nls debug"
+
+RDEPEND=">=x11-libs/libnotify-0.3.2
+ net-im/pidgin[gtk]
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ EPATCH_FORCE=yes EPATCH_SUFFIX=diff epatch "${WORKDIR}"/debian/patches
+ epatch "${FILESDIR}"/${P}-libnotify-0.7.patch
+ sed -i -e '/CFLAGS/s:-g3::' configure || die
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ $(use_enable debug) \
+ $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ find "${D}" -name '*.la' -exec rm -f {} +
+ dodoc AUTHORS ChangeLog NEWS README TODO VERSION || die
+}