summaryrefslogtreecommitdiff
path: root/x11-plugins/pidgin-led-notification
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-plugins/pidgin-led-notification
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-plugins/pidgin-led-notification')
-rw-r--r--x11-plugins/pidgin-led-notification/Manifest6
-rw-r--r--x11-plugins/pidgin-led-notification/files/pidgin-led-notification-0.1-hardware.patch34
-rw-r--r--x11-plugins/pidgin-led-notification/metadata.xml8
-rw-r--r--x11-plugins/pidgin-led-notification/pidgin-led-notification-0.1.ebuild42
4 files changed, 90 insertions, 0 deletions
diff --git a/x11-plugins/pidgin-led-notification/Manifest b/x11-plugins/pidgin-led-notification/Manifest
new file mode 100644
index 000000000000..687e405a9a3e
--- /dev/null
+++ b/x11-plugins/pidgin-led-notification/Manifest
@@ -0,0 +1,6 @@
+AUX pidgin-led-notification-0.1-hardware.patch 1217 SHA256 84d3eaf36a26a08b730e2ea382711d704de21298278fcd42e7af3a4403339f62 SHA512 ce90c57c216f0811256a562820f346fc1ee900f5c08696daf4aae44410578ca3dd039101378594aeae258b38145003e7ec21dadce5c5a829a46b2f4b2e917868 WHIRLPOOL d5ee127ca7fcf79def6402a102133b0b3464999bc0e3d231947f528531db48005a4bd2c941172f3d5087b748454c0183c294f889a143be337ab9c35c563ea14c
+DIST led-notification-0.1.tar.bz2 8848 SHA256 aed13cd45e6bbb89574d9eafe477adc7ef3f0a1768cb1f3c5f573e08186e1a16 SHA512 40773a14c42e3c723d6cb693288378184b291df106810de99d7887c3ef8e938633498326419febb17d80e0aa4fb4e4cf7ced16ce5186f30df1ee84b38c0f6ed2 WHIRLPOOL 807f06a15655a1574d43664752880630c83c21d19f1ebba98bb1b091f75a021d123bfc7688de540ee214b81310ef64cdf26c7ea28a2c19a0ab0f7b38c5cccb4a
+EBUILD pidgin-led-notification-0.1.ebuild 966 SHA256 3242ec05f1c9e91c5248862530dfb12b7647e579710cbc4a0e8abf86ff01f753 SHA512 d424e3a74f21d973b0c417dede6397dd212341514e09a129743f6fb554c0f2b02be36986817c2e72d42ff5bb9eb73828f57cd14766a1591d98afa0d655d1da37 WHIRLPOOL db4b677fe61fe1fc741319d6cd022e23b150e5043e8078d3d9a239f47d1bb35c7c0e542de06e2c3ec05a5c28b2b33fb93facfa3bf4a33cc8105824b52d87a00f
+MISC ChangeLog 2840 SHA256 0c3aecd4a9be24aecd098127362ad394bd4d6d933f94aaa9f07d5cb3ec70d788 SHA512 969803d0bf25563761c4d8b2e0a46cc7554b70849450bc2d0ae30031df0e4d58d01424fffa081ac4c75b06b19f5301012b44399d7cfbfa2f0fd818e8a7154259 WHIRLPOOL 684983658935c993a1d5ba24ae592a0e9cb84a0324d3c837b53d53b76413e0b9db648769a4014ced9b33065f7a1981f26934385bef6849e34fb1af9b8bb85aaa
+MISC ChangeLog-2015 1136 SHA256 4525f2566352ff78c482a58748df83c8d90f4a7555700f95692fb3e5a2165cca SHA512 50a80dfc69e93799499a2e1f3b5ebdb33707003f1fe7edf6cf37b87a87461dde6a12cfea82d3d5b2bc61fd678c444a56498d90356eaee7c7d70b269c68dcab40 WHIRLPOOL ef6dc3eff13eeb0c1bd5b7e4f7a5dccadb1b6f0fea6c5dac30fb1824b7baf3b4a6c03f3552e3c608b1068bf23a0e39ef79a8dcff2f52d058b33c564d4c4f9b44
+MISC metadata.xml 237 SHA256 ffb571839c57797d282263369646d2bba2662601a45f7bb3251bb97f716554a6 SHA512 ae2360aa6b1b00c67e0acea4935c02b64585b9a15e126fec9d5d99637021c542c0a495e5116205f3da287def46fa5b19cb1a7f3042c12c5f7a78d66d92fcb03f WHIRLPOOL 60d6da846c983457e038ea5ba3c0bf48f939c9586610985a14cac9772fd1d45d781a643abc16482f232f3028e44fe99fe1a382deaebf6589602fc244a4460e3f
diff --git a/x11-plugins/pidgin-led-notification/files/pidgin-led-notification-0.1-hardware.patch b/x11-plugins/pidgin-led-notification/files/pidgin-led-notification-0.1-hardware.patch
new file mode 100644
index 000000000000..aaabada116db
--- /dev/null
+++ b/x11-plugins/pidgin-led-notification/files/pidgin-led-notification-0.1-hardware.patch
@@ -0,0 +1,34 @@
+--- led-notification-0.1/led-notification.c
++++ led-notification-0.1/led-notification.c
+@@ -54,9 +54,9 @@
+ }
+
+ if(state) {
+- fputs("1", file);
++ fputs(purple_prefs_get_string("/plugins/gtk/gtk-simom-lednot/led_on"), file);
+ } else {
+- fputs("0", file);
++ fputs(purple_prefs_get_string("/plugins/gtk/gtk-simom-lednot/led_off"), file);
+ }
+
+ fclose(file);
+@@ -155,6 +155,10 @@
+
+ ent=pidgin_prefs_labeled_entry(vbox2,"File to control led:",
+ "/plugins/gtk/gtk-simom-lednot/filename",sg);
++ ent=pidgin_prefs_labeled_entry(vbox2,"String to turn led on:",
++ "/plugins/gtk/gtk-simom-lednot/led_on",sg);
++ ent=pidgin_prefs_labeled_entry(vbox2,"String to turn led off:",
++ "/plugins/gtk/gtk-simom-lednot/led_off",sg);
+
+ gtk_widget_show_all(frame);
+ return frame;
+@@ -166,6 +170,8 @@
+ purple_prefs_add_string("/plugins/gtk/gtk-simom-lednot/chat", "nick");
+ purple_prefs_add_string("/plugins/gtk/gtk-simom-lednot/filename",
+ "/proc/acpi/asus/mled");
++ purple_prefs_add_string("/plugins/gtk/gtk-simom-lednot/led_on", "1");
++ purple_prefs_add_string("/plugins/gtk/gtk-simom-lednot/led_off", "0");
+ }
+
+ static gboolean plugin_load(PurplePlugin *plugin) {
diff --git a/x11-plugins/pidgin-led-notification/metadata.xml b/x11-plugins/pidgin-led-notification/metadata.xml
new file mode 100644
index 000000000000..a535b8852829
--- /dev/null
+++ b/x11-plugins/pidgin-led-notification/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+<email>xmw@gentoo.org</email>
+<name>Michael Weber</name>
+</maintainer>
+</pkgmetadata>
diff --git a/x11-plugins/pidgin-led-notification/pidgin-led-notification-0.1.ebuild b/x11-plugins/pidgin-led-notification/pidgin-led-notification-0.1.ebuild
new file mode 100644
index 000000000000..87efacac2590
--- /dev/null
+++ b/x11-plugins/pidgin-led-notification/pidgin-led-notification-0.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=3
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="Pidgin plugin to notify by writing user defined strings to (led control) files"
+HOMEPAGE="https://sites.google.com/site/simohmattila/led-notification"
+MY_PN=${PN/pidgin-/}
+MY_P=${MY_PN}-${PV}
+SRC_URI="https://sites.google.com/site/simohmattila/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+RDEPEND="net-im/pidgin[gtk]
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-hardware.patch
+}
+
+src_compile() {
+ $(tc-getCC) \
+ ${CFLAGS} -fpic $(pkg-config --cflags gtk+-2.0 pidgin) \
+ -shared ${MY_PN}.c -o ${MY_PN}.so \
+ ${LDFLAGS} $(pkg-config --libs gtk+-2.0 pidgin) || die
+}
+
+src_install() {
+ insinto /usr/$(get_libdir)/pidgin
+ insopts -m755
+ doins ${MY_PN}.so || die
+ dodoc README || die
+}