summaryrefslogtreecommitdiff
path: root/x11-plugins/pidgin-hotkeys
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-25 17:40:36 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-25 17:40:36 +0000
commit85809279ceef66e68b25eac8c3918bee6762f6cc (patch)
tree9ecee133212467e7b1402b70a11c5d6fb3ea817d /x11-plugins/pidgin-hotkeys
parent4215622c05ed14d30fdad5a4d0feba6d94b0d046 (diff)
gentoo auto-resync : 25:02:2024 - 17:40:36
Diffstat (limited to 'x11-plugins/pidgin-hotkeys')
-rw-r--r--x11-plugins/pidgin-hotkeys/Manifest3
-rw-r--r--x11-plugins/pidgin-hotkeys/metadata.xml5
-rw-r--r--x11-plugins/pidgin-hotkeys/pidgin-hotkeys-0.2.4-r1.ebuild23
3 files changed, 29 insertions, 2 deletions
diff --git a/x11-plugins/pidgin-hotkeys/Manifest b/x11-plugins/pidgin-hotkeys/Manifest
index 721bce1f15b1..85abd4bdf2a5 100644
--- a/x11-plugins/pidgin-hotkeys/Manifest
+++ b/x11-plugins/pidgin-hotkeys/Manifest
@@ -1,3 +1,4 @@
DIST pidgin-hotkeys-0.2.4.tar.gz 341912 BLAKE2B fe4b6d841010df2bfc17febbbc54d0dc10eb65f3c414b17728a92afb856232df1a7a9996631dc2564102346236cb5e7ae2fb3b10f67679dbaed11f3d83b03372 SHA512 99897a47f91c5ceacabdec13859526f6af6270e171b94b49183ad5cc5118b5e3f5377d02ffd0bdbdbaafdd6f23f400deb604a8fe686cd29103187276f20aca86
+EBUILD pidgin-hotkeys-0.2.4-r1.ebuild 530 BLAKE2B 15bf6f6ba7811b606e8a112d703a50740bd9ef3c787310d37ac402d950c467e43894a508b81841e44431843a194e212b84ad0df513e5b553706c14a96f24d4f8 SHA512 0045582765f808a4ce0cacc2d50293b2167eeb461d7aa2cb5653dda333aa028d85a005d1b660feb84a7b1849e83ba1fa266b74395fb5828d5c930714e2519bfb
EBUILD pidgin-hotkeys-0.2.4.ebuild 438 BLAKE2B 832f8aab1ea1ad969796248d747329c285a6caca31210a4556c50db0dbd803fafd0eb87d1dbbecd86a486edb0209e92cc36e0e0f7457514f9a595fe2c1528272 SHA512 c5d665dbf7f95d49a2fc5ce642c0e60fe39f994db4236d726ac270d3472429499afd31123051823506c7fda53bfa11ccf2b3974fe296af07f42dc7b62f1592c0
-MISC metadata.xml 252 BLAKE2B 86dade54a45b23e0cd67ab6fb9be652ccd57766fee39aa607805496edb24bfd1c6486b64996a1826b7b0fb06f522250f9670d247b9f0b8d81add2865fb2b483e SHA512 b879412bc05041ea5e658958e9a642ae3ab37d9221c7262c2eb73c2aa82053f4e53b15f41e37c4c237faeb7f2421d4d8156e0da4ec457201725f030816f9621c
+MISC metadata.xml 337 BLAKE2B f5e43305b08f037baf84fe1f3d9f2a7cb7f977a1aef4d032d181c0d416c14f97f8c0c9dc8dc38089b140e4ec47d4ff51030ae53be13039b53d28a4e494d5d744 SHA512 dd387828adee133ca46112944c9b506c97d0bdf5904c327821cc33aecd35a0b183e173f9e84ed39954e060404bd18c574f258a7fe3c402ea4a8b34d4f17be51a
diff --git a/x11-plugins/pidgin-hotkeys/metadata.xml b/x11-plugins/pidgin-hotkeys/metadata.xml
index 59c00cc967ef..44b8a99cfc0a 100644
--- a/x11-plugins/pidgin-hotkeys/metadata.xml
+++ b/x11-plugins/pidgin-hotkeys/metadata.xml
@@ -1,7 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person">
+ <email>nativemad@gentoo.org</email>
+ <name>Andreas Schuerch</name>
+ </maintainer>
<upstream>
<remote-id type="sourceforge">pidgin-hotkeys</remote-id>
</upstream>
diff --git a/x11-plugins/pidgin-hotkeys/pidgin-hotkeys-0.2.4-r1.ebuild b/x11-plugins/pidgin-hotkeys/pidgin-hotkeys-0.2.4-r1.ebuild
new file mode 100644
index 000000000000..bb859ee62736
--- /dev/null
+++ b/x11-plugins/pidgin-hotkeys/pidgin-hotkeys-0.2.4-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Pidgin plugin to define global hotkeys for various actions"
+HOMEPAGE="https://sourceforge.net/projects/pidgin-hotkeys/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~riscv ~x86"
+
+RDEPEND="net-im/pidgin[gtk]
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_install() {
+ default
+
+ find "${D}" -type f -name '*.la' -delete || die
+}