summaryrefslogtreecommitdiff
path: root/x11-plugins/lurch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /x11-plugins/lurch
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'x11-plugins/lurch')
-rw-r--r--x11-plugins/lurch/Manifest3
-rw-r--r--x11-plugins/lurch/lurch-0.6.8.ebuild67
-rw-r--r--x11-plugins/lurch/metadata.xml8
3 files changed, 78 insertions, 0 deletions
diff --git a/x11-plugins/lurch/Manifest b/x11-plugins/lurch/Manifest
new file mode 100644
index 000000000000..45fe8a9090f1
--- /dev/null
+++ b/x11-plugins/lurch/Manifest
@@ -0,0 +1,3 @@
+DIST lurch-0.6.8.tar.gz 398267 BLAKE2B 23211e82b80e26105f0d62510dc321abdd818eae21dd9f3e24f6ab01458748df64283acb99371a8ece34248f06e9e04edd35da30c771f45779474b3b43c3a53d SHA512 8b93523049d05a00f1d7286ec9d0d8d03c7ae46793ac72ea08c0d12cb5193324be4805fb6278d6c0f906d9c63db9d7ce6ca2a21442236df51e0ee0b48de6ef1d
+EBUILD lurch-0.6.8.ebuild 1718 BLAKE2B 5af54a0dc7bb979a814a93dde6b6b9afd05b3aa603599276db2983ecbd64fd129e8217b62cd1a2f8dea950def9da15242595f51f911eef9c3535dca67c26d1d2 SHA512 2fe714a97502f771a239937ba3af79610da1314ecd943f0ac1127afac2a143cf6b5cfe2181e4a01b8ef91979779a2b06ed46d0e1512396c2db8bf90d792b4d3b
+MISC metadata.xml 249 BLAKE2B a4931a30c3947b238913053d611639235b076475e864914e684020d86ee1b4aa6da94e4cef59c53a0e5ccd3b3d15d3a4ae293800b17bbb89e0af9cff79314a70 SHA512 b1cb770984baef468e3d17e343acff395e1993b14f90def7f8582b5e5d1a512bd3c7727e03f1deca47f7359a8f8cc9a8360130923388a5c06fabbfb9b05d5138
diff --git a/x11-plugins/lurch/lurch-0.6.8.ebuild b/x11-plugins/lurch/lurch-0.6.8.ebuild
new file mode 100644
index 000000000000..cb4e4a97bace
--- /dev/null
+++ b/x11-plugins/lurch/lurch-0.6.8.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+CMAKE_MAKEFILE_GENERATOR=emake # since top-level Makefile expects a child Makefile
+
+inherit toolchain-funcs cmake-utils
+
+DESCRIPTION="OMEMO encryption for libpurple (XEP-0384)"
+HOMEPAGE="https://github.com/gkdr/lurch"
+SRC_URI="https://github.com/gkdr/lurch/releases/download/v${PV}/lurch-${PV}-src.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# NOTE
+# - We cannot unbundle net-libs/libsignal-protocol-c
+# because upstream uses non-API/internal function
+# session_builder_process_pre_key_signal_message
+# - The build systems of axc (ex-libaxolotl)
+# at https://github.com/gkdr/axc and libomemo
+# at https://github.com/gkdr/libomemo build static
+# libraries only (*.a) so it is not clear when or
+# how to best unbundle them, either
+RDEPEND="
+ dev-db/sqlite
+ dev-libs/glib
+ dev-libs/libgcrypt:=
+ dev-libs/libxml2
+ dev-libs/mxml
+ net-im/pidgin:=
+ "
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ "
+
+CMAKE_USE_DIR="${S}"/lib/axc/lib/libsignal-protocol-c
+BUILD_DIR="${CMAKE_USE_DIR}"/build
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=OFF # top-level Makefile expects .a file
+ -DCMAKE_C_FLAGS=-fPIC
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+
+ local makeargs=(
+ CC="$(tc-getCC)"
+ LIBGCRYPT_CONFIG="$(tc-getPROG LIBGCRYPT_CONFIG libgcrypt-config)"
+ PKG_CONFIG="$(tc-getPKG_CONFIG)"
+ XML2_CONFIG="$(tc-getPROG XML2_CONFIG xml2-config)"
+
+ CMAKE=/bin/true # to stop Makefile from calling CMake, once more
+ )
+ emake "${makeargs[@]}"
+}
+
+src_install() {
+ default # use top-level Makefile, not cmake-utils_src_install
+}
diff --git a/x11-plugins/lurch/metadata.xml b/x11-plugins/lurch/metadata.xml
new file mode 100644
index 000000000000..ab886b7f0382
--- /dev/null
+++ b/x11-plugins/lurch/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM 'http://www.gentoo.org/dtd/metadata.dtd'>
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sping@gentoo.org</email>
+ <name>Sebastian Pipping</name>
+ </maintainer>
+</pkgmetadata>