summaryrefslogtreecommitdiff
path: root/x11-plugins/guifications
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-plugins/guifications
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-plugins/guifications')
-rw-r--r--x11-plugins/guifications/Manifest5
-rw-r--r--x11-plugins/guifications/guifications-2.16.ebuild36
-rw-r--r--x11-plugins/guifications/metadata.xml6
3 files changed, 47 insertions, 0 deletions
diff --git a/x11-plugins/guifications/Manifest b/x11-plugins/guifications/Manifest
new file mode 100644
index 000000000000..f270fdd369ee
--- /dev/null
+++ b/x11-plugins/guifications/Manifest
@@ -0,0 +1,5 @@
+DIST pidgin-guifications-2.16.tar.bz2 543136 SHA256 e007a75a904f6b24a608f566d84b6b41adfd91ed62daf4668a724cb25a721bd6 SHA512 fee1741a37df102ed3620caed9024c1a2ac5919c1a9c4182bdb19685a4d3412a1ff72e5e58ce65fdc2689f1d90432ea22c3912a9ecda80a95af96d57c86c9cf0 WHIRLPOOL 980512848fc97a05fe9a28fc34fdb9cddd33184fc62be896e03cc8a371e52a1b6563eec7db347cde398c94f7c86565f2e42ab0879233df02d91f96f9f23b1bde
+EBUILD guifications-2.16.ebuild 829 SHA256 e8b5ebf64a775dc67da86cc15faa972125e798443035290e0656d6fe1469bd7c SHA512 dad8f3dd623d0df6abe5977b5556640c6311a9416d92f21948a33cfb669ee8384e50e0fd4465896bb687b5da89a54d49ce8fd0e576f5de55565985bfed9202dc WHIRLPOOL 8925ddcb8fe806019eba2dd31deccf3f93b2fafc1c908ce0f378eaeec69a902ec6881266a04eab1955272a243aec4226af381fcf631ef286b27dc225e7194d83
+MISC ChangeLog 2472 SHA256 da251e47d55f0a23f76ad4a6ff3ebbd063e3e9b0bef898a6195ddd21eba35b3d SHA512 d77f95b16d06815270196887c8f1b60a2b9a9359080573a8fc2cd5fd4f176e9f04ecc8cff094b646b9a6fb3bbf15883a60e125a7ec61d5f808768feb5a6542dd WHIRLPOOL 5636d98d9d4296ecc8259a2cfeb422bd24a3afef8a3326cc6e7d65a5abe51e49d13a0d04cccdb39c4d8f07b55671fa78ec8ea8a37e081bb6eee3ed9aeb44e321
+MISC ChangeLog-2015 9575 SHA256 219ec394b22eda0df78f16c8f8439fda8208be33ac9dd3e82e34a77118eb912d SHA512 090d5c06edb6ee0f0171c3b3bffbc487404db0f827fde463919fbc5320cfb6d37d1bcea198bb99c0fbf4804ecfeb7081fc41f8a83f60c3f510ec383644a9d5bf WHIRLPOOL 1e9dc1a31dcfc1e132bb40b27a8c83c225b1d9bb8c3ed2352e4f239e1397fed7fe6c95679c90de902b14c82712f9e51cdc2205492a250ab0627b9354f092aeb0
+MISC metadata.xml 296 SHA256 2bc27de5ba31e3028135174470c7efbe3958922e02442232f969455c86278de8 SHA512 e0c54608b40170468a0ea5526bf15b1202a3f60a5911f6695f89caae84d152316a44c4c3cbc6e059f80f5a69c7757ba78ca582b571088b13a4b5dcc0f2ac4f9f WHIRLPOOL 49252543275df48065faf8546cb892af8cd24b983d50e529d292738d34578740923026dad3ae05ee166340f03f315788062fac27443bf70ba15dfe1ddfed1bd5
diff --git a/x11-plugins/guifications/guifications-2.16.ebuild b/x11-plugins/guifications/guifications-2.16.ebuild
new file mode 100644
index 000000000000..70ceda6a6a73
--- /dev/null
+++ b/x11-plugins/guifications/guifications-2.16.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="2"
+
+inherit eutils
+
+MY_PN=pidgin-${PN}
+MY_PV=${PV/_beta/beta}
+MY_P=${MY_PN}-${MY_PV}
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="Guifications is a graphical notification plugin for pidgin"
+HOMEPAGE="http://plugins.guifications.org/"
+SRC_URI="http://downloads.guifications.org/plugins//Guifications2/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 hppa ppc sparc x86"
+IUSE="debug nls"
+
+RDEPEND="net-im/pidgin[gtk]
+ x11-libs/gtk+:2"
+
+DEPEND="${DEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ $(use_enable debug ) \
+ $(use_enable nls) || die "econf failure"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "make install failure"
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO VERSION || die
+}
diff --git a/x11-plugins/guifications/metadata.xml b/x11-plugins/guifications/metadata.xml
new file mode 100644
index 000000000000..d8eed8d3c5a2
--- /dev/null
+++ b/x11-plugins/guifications/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<!-- maintainer-needed -->
+<longdescription>Guifications are graphical notification plugin for the open source instant message client gaim</longdescription>
+</pkgmetadata>