summaryrefslogtreecommitdiff
path: root/x11-plugins/gkrellsun/gkrellsun-1.0.0-r4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-plugins/gkrellsun/gkrellsun-1.0.0-r4.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-plugins/gkrellsun/gkrellsun-1.0.0-r4.ebuild')
-rw-r--r--x11-plugins/gkrellsun/gkrellsun-1.0.0-r4.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11-plugins/gkrellsun/gkrellsun-1.0.0-r4.ebuild b/x11-plugins/gkrellsun/gkrellsun-1.0.0-r4.ebuild
new file mode 100644
index 000000000000..40deb42b5728
--- /dev/null
+++ b/x11-plugins/gkrellsun/gkrellsun-1.0.0-r4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gkrellm-plugin
+
+DESCRIPTION="A GKrellM plugin that shows sunrise and sunset times"
+HOMEPAGE="http://gkrellsun.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gkrellsun/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="1"
+KEYWORDS="alpha amd64 hppa ia64 ppc sparc x86"
+IUSE="nls"
+
+COMMON_DEPEND="app-admin/gkrellm[X]
+ nls? ( sys-devel/gettext )"
+DEPEND+=" ${COMMON_DEPEND}"
+RDEPEND+=" ${COMMON_DEPEND}"
+
+PLUGIN_SO=src20/gkrellsun.so
+
+PATCHES=(
+ "${FILESDIR}/${P}-reenable.patch"
+ "${FILESDIR}/${P}-Respect-LDFLAGS.patch"
+)
+
+src_compile() {
+ use nls && myconf="$myconf enable_nls=1"
+ emake ${myconf}
+}