summaryrefslogtreecommitdiff
path: root/x11-plugins/gkrellstock/gkrellstock-0.5.1-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /x11-plugins/gkrellstock/gkrellstock-0.5.1-r2.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'x11-plugins/gkrellstock/gkrellstock-0.5.1-r2.ebuild')
-rw-r--r--x11-plugins/gkrellstock/gkrellstock-0.5.1-r2.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/x11-plugins/gkrellstock/gkrellstock-0.5.1-r2.ebuild b/x11-plugins/gkrellstock/gkrellstock-0.5.1-r2.ebuild
new file mode 100644
index 000000000000..6fcbaee5ee28
--- /dev/null
+++ b/x11-plugins/gkrellstock/gkrellstock-0.5.1-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic gkrellm-plugin toolchain-funcs
+
+DESCRIPTION="Get Stock quotes plugin for Gkrellm2"
+HOMEPAGE="http://gkrellstock.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gkrellstock/${P}.tar.gz"
+S="${WORKDIR}/${P/s/S}"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="
+ app-admin/gkrellm:2[X]
+ dev-libs/glib:2
+ x11-libs/gtk+:2
+ dev-perl/libwww-perl
+ dev-perl/Finance-Quote"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.5-ldflags.patch
+ "${FILESDIR}"/${PN}-0.5.1-r2-makefile-fixes.patch
+)
+
+src_configure() {
+ tc-export PKG_CONFIG
+ append-cppflags $($(tc-getPKG_CONFIG) --cflags gtk+-2.0)
+ append-flags -fPIC
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ gkrellm-plugin_src_install
+ dobin GetQuote2
+}