summaryrefslogtreecommitdiff
path: root/x11-plugins/gkrellstock/gkrellstock-0.5.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-04 18:55:01 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-04 18:55:01 +0000
commit423d21dcfee183cc4b04d29c1621615e8c30f834 (patch)
tree23bd6110b9a77b8d679b5ab60fb7663b8627f698 /x11-plugins/gkrellstock/gkrellstock-0.5.1-r1.ebuild
parent81e4fbcb846ed1cabdad699c0029b166dd7273b7 (diff)
gentoo resync : 04.01.2018
Diffstat (limited to 'x11-plugins/gkrellstock/gkrellstock-0.5.1-r1.ebuild')
-rw-r--r--x11-plugins/gkrellstock/gkrellstock-0.5.1-r1.ebuild20
1 files changed, 9 insertions, 11 deletions
diff --git a/x11-plugins/gkrellstock/gkrellstock-0.5.1-r1.ebuild b/x11-plugins/gkrellstock/gkrellstock-0.5.1-r1.ebuild
index adbd9c88ad4f..3f7aff6dea76 100644
--- a/x11-plugins/gkrellstock/gkrellstock-0.5.1-r1.ebuild
+++ b/x11-plugins/gkrellstock/gkrellstock-0.5.1-r1.ebuild
@@ -1,34 +1,32 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+
inherit flag-o-matic gkrellm-plugin toolchain-funcs
DESCRIPTION="Get Stock quotes plugin for Gkrellm2"
HOMEPAGE="http://gkrellstock.sourceforge.net/"
SRC_URI="mirror://sourceforge/gkrellstock/${P}.tar.gz"
-SLOT="2"
LICENSE="GPL-2"
+SLOT="2"
KEYWORDS="amd64 ~ppc x86"
IUSE=""
RDEPEND="
- app-admin/gkrellm[X]
+ app-admin/gkrellm:2[X]
dev-libs/glib:2
x11-libs/gtk+:2
dev-perl/libwww-perl
- dev-perl/Finance-Quote
-"
-DEPEND="${DEPEND}
- virtual/pkgconfig
-"
+ dev-perl/Finance-Quote"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
S="${WORKDIR}/${P/s/S}"
+PATCHES=( "${FILESDIR}"/${PN}-0.5-ldflags.patch )
-src_prepare() {
- default
- eapply "${FILESDIR}"/${PN}-0.5-ldflags.patch
+src_configure() {
append-cppflags $($(tc-getPKG_CONFIG) --cflags gtk+-2.0)
append-flags -fPIC
}