summaryrefslogtreecommitdiff
path: root/x11-plugins/gkrellm-leds/gkrellm-leds-0.8.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-plugins/gkrellm-leds/gkrellm-leds-0.8.2-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-plugins/gkrellm-leds/gkrellm-leds-0.8.2-r1.ebuild')
-rw-r--r--x11-plugins/gkrellm-leds/gkrellm-leds-0.8.2-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/x11-plugins/gkrellm-leds/gkrellm-leds-0.8.2-r1.ebuild b/x11-plugins/gkrellm-leds/gkrellm-leds-0.8.2-r1.ebuild
new file mode 100644
index 000000000000..e1cf0a439a5f
--- /dev/null
+++ b/x11-plugins/gkrellm-leds/gkrellm-leds-0.8.2-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gkrellm-plugin
+
+MY_P="${P/rellm-/}"
+
+DESCRIPTION="GKrellM2 plugin for monitoring keyboard LEDs"
+HOMEPAGE="http://heim.ifi.uio.no/~oyvinha/gkleds/"
+SRC_URI="http://heim.ifi.uio.no/~oyvinha/e107_files/downloads/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="alpha amd64 ~ppc ~sparc x86"
+IUSE=""
+
+COMMON_DEPEND="app-admin/gkrellm[X]"
+DEPEND+=" ${COMMON_DEPEND} x11-proto/inputproto"
+RDEPEND+=" ${COMMON_DEPEND} x11-libs/libXtst"
+
+S="${WORKDIR}/${MY_P}"
+
+PLUGIN_SO="src/.libs/gkleds.so"