summaryrefslogtreecommitdiff
path: root/x11-plugins/gkrellfire/gkrellfire-0.4.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-plugins/gkrellfire/gkrellfire-0.4.2-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-plugins/gkrellfire/gkrellfire-0.4.2-r1.ebuild')
-rw-r--r--x11-plugins/gkrellfire/gkrellfire-0.4.2-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/x11-plugins/gkrellfire/gkrellfire-0.4.2-r1.ebuild b/x11-plugins/gkrellfire/gkrellfire-0.4.2-r1.ebuild
new file mode 100644
index 000000000000..201cad761f91
--- /dev/null
+++ b/x11-plugins/gkrellfire/gkrellfire-0.4.2-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gkrellm-plugin toolchain-funcs
+
+DESCRIPTION="CPU load flames for GKrellM 2"
+HOMEPAGE="http://people.freenet.de/thomas-steinke"
+SRC_URI="ftp://ftp.freebsd.org/pub/FreeBSD/ports/distfiles/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="app-admin/gkrellm[X]"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/fix-CC-CFLAGS-LDFLAGS-handling.patch" )
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}