summaryrefslogtreecommitdiff
path: root/x11-plugins/enigmail
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-15 16:58:00 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-15 16:58:00 +0000
commit434d713861b70f6c6563d6ee50a8e64f14c970d9 (patch)
treeb72c523c72e764420f835ba9d63d43ffef687dcf /x11-plugins/enigmail
parentf78108598211053d41752a83e0345441bb9014ae (diff)
gentoo resync : 15.02.2018
Diffstat (limited to 'x11-plugins/enigmail')
-rw-r--r--x11-plugins/enigmail/Manifest4
-rw-r--r--x11-plugins/enigmail/enigmail-2.0_beta1.ebuild83
-rw-r--r--x11-plugins/enigmail/enigmail-9999.ebuild13
3 files changed, 95 insertions, 5 deletions
diff --git a/x11-plugins/enigmail/Manifest b/x11-plugins/enigmail/Manifest
index 3e29d49fefa0..2f51975b9880 100644
--- a/x11-plugins/enigmail/Manifest
+++ b/x11-plugins/enigmail/Manifest
@@ -1,4 +1,6 @@
DIST enigmail-1.9.9.tar.gz 1787556 BLAKE2B 729cf7e404b4cc5d964df476e627b476916cd6c834ce5f220a26738bc32eabbd9fd2c4c3cbaccef6e1d8c4b5b7313b54278a4170808f8b722443b338fda87b55 SHA512 39b37305362c88527d897ed95aa9d8457137d5f026359d19b838ab9df531c14099e157afdc8fefae78a6fa2ddded8dbfbeaf84eb91ac6cfbb05ae808731da2cb
+DIST enigmail-2.0-beta1.tar.gz 2116808 BLAKE2B a539e7bf97e12327ae2a7e9fafdc2ad4298f9dd602333aa6d414b4c6770b3279cc0c9e100cb3be6be86c49f17b4c76759676efc963fe04e8fe522a8aad345f47 SHA512 ddbf540c0d628c19c7ddbcd01686dcdec53385113367e9f3ef683e3ebc97e17cbdbe62e7623b7b1be41967f47cd430b4f2d2fba1d0a86773c836ffc6ceb8f548
EBUILD enigmail-1.9.9.ebuild 1922 BLAKE2B 91c9d28229704a6fc1b529a3b9948c3b4b32e097a2f9ec4d44e9e036ad2b7615314c1cf14120e536304cfb43c3ce0d71a6e327f92992c4f79b51ad484ffad6dd SHA512 b2e8dd3b86c1aaf37954c067bdaae67217f7446317817af837f9a2affd4c886d0e3d3b81b10f402105cd54a4534449a86ebe69673024367a34467fea400b6cba
-EBUILD enigmail-9999.ebuild 1915 BLAKE2B ccff9cc03869ccc02a313a3f96cdf25081424b295e03dca6f6a69449da99013708efc20fd5141e61cff2b68640d466a6141a60df51b29803c4ac11a47eebdcd6 SHA512 4b8c948bf8aef1eb2d2a422ee66d8ad0df4a0ef312ca7c16dbe12654b0bcc504e3882bbd258e5630a0e51977f14028b059940b47fb464bb7534daf47d6270374
+EBUILD enigmail-2.0_beta1.ebuild 2176 BLAKE2B 941c7f06bb44515c26c920ba15fe6c7babb041a01c84ac747c72c1bb3ec0e652a92a6277b16912724ef39250553ee7853f3d96883224b3ebb0552b2e38b56c76 SHA512 4fa175b4ad4412c7e3f18fcbb8d5dcb4cce5605dec07dd39e62e6ff1399d9f805d228ba9d0de083f66ac8802d0af8b2b5e6189e7baafc378cb418504fdfa6376
+EBUILD enigmail-9999.ebuild 2105 BLAKE2B 47053af959ddf2b745ad0aa620b8e1666905e5bb0ca60cb7fe8cfe02eb8160cbbc981940a78a0ddb0c01e1e7a557465f243eea15c44d6ff7e613f03695d58076 SHA512 4c7c4051d47d1692cd8eff3cd1d32027cbc6608257faf2fe437483df9676b70c320cb5546acd632142d8de0c612c6a6281d5eb6d151eeac494c7c1b359060a3e
MISC metadata.xml 250 BLAKE2B 9e6643b2a0b90fc083246090047db38d3b9a3b71db8542051307b7e87394135d3337e1ea54b83a0c7474661a0fd07d950385b44cbed6ee95f6e6ad718bd0b062 SHA512 ba5e7c1f6ee117471a3804bc54211e7f89c75e965a865f45f85015a0a28ec7d511ef9bbc196eef8245dc9259f54b04eb3563d83811a293bb946cf0977563892b
diff --git a/x11-plugins/enigmail/enigmail-2.0_beta1.ebuild b/x11-plugins/enigmail/enigmail-2.0_beta1.ebuild
new file mode 100644
index 000000000000..9e8d0cbb3958
--- /dev/null
+++ b/x11-plugins/enigmail/enigmail-2.0_beta1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-any-r1
+
+DESCRIPTION="Mozilla extension to provide GPG support in mail clients"
+HOMEPAGE="http://www.enigmail.net/"
+
+SLOT="0"
+LICENSE="MPL-2.0 GPL-3"
+IUSE=""
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.code.sf.net/p/enigmail/source"
+ S="${WORKDIR}/${P}"
+else
+ if [[ ${PV} = *_beta* ]] ; then
+ SRC_URI="http://www.enigmail.net/download/beta/${P/_/-}.tar.gz"
+ else
+ SRC_URI="http://www.enigmail.net/download/source/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+ fi
+ S="${WORKDIR}/${PN}"
+fi
+
+RDEPEND="|| (
+ ( >=app-crypt/gnupg-2.0
+ || (
+ app-crypt/pinentry[gtk(-)]
+ app-crypt/pinentry[qt4(-)]
+ app-crypt/pinentry[qt5(-)]
+ )
+ )
+ =app-crypt/gnupg-1.4*
+ )
+ !<mail-client/thunderbird-52.5.0
+ !<www-client/seamonkey-2.49.5.0_p0
+"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ app-arch/zip
+ dev-lang/perl
+ "
+
+src_compile() {
+ emake ipc public ui package lang stdlib
+ emake xpi
+
+}
+
+src_install() {
+ local emid=$(sed -n '/<em:id>/!d; s/.*\({.*}\).*/\1/; p; q' build/dist/install.rdf)
+ [[ -n ${emid} ]] || die "Could not scrape EM:ID from install.rdf"
+
+ mv build/enigmail*.xpi build/"${emid}.xpi" || die 'Could not rename XPI to match EM:ID'
+
+ # thunderbird
+ insinto "/usr/share/mozilla/extensions/{3550f703-e582-4d05-9a08-453d09bdfdc6}"
+ doins build/"${emid}.xpi"
+
+ # seamonkey
+ insinto "/usr/share/mozilla/extensions/{92650c4d-4b8e-4d2a-b7eb-24ecf4f6b63a}"
+ doins build/"${emid}.xpi"
+}
+
+pkg_postinst() {
+ local peimpl=$(eselect --brief --colour=no pinentry show)
+ case "${peimpl}" in
+ *gtk*|*qt*) ;;
+ *) ewarn "The pinentry front-end currently selected is not one supported by thunderbird."
+ ewarn "You may be prompted for your password in an inaccessible shell!!"
+ ewarn "Please use 'eselect pinentry' to select either the gtk or qt front-end"
+ ;;
+ esac
+ if [[ -n ${REPLACING_VERSIONS} ]]; then
+ elog
+ elog "Please restart thunderbird and/or seamonkey in order for them to use"
+ elog "the newly installed version of enigmail."
+ fi
+}
diff --git a/x11-plugins/enigmail/enigmail-9999.ebuild b/x11-plugins/enigmail/enigmail-9999.ebuild
index ec95bc9fb44a..66f465afa7c6 100644
--- a/x11-plugins/enigmail/enigmail-9999.ebuild
+++ b/x11-plugins/enigmail/enigmail-9999.ebuild
@@ -1,23 +1,28 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
PYTHON_COMPAT=( python2_7 )
-inherit git-r3 python-any-r1
+inherit python-any-r1
DESCRIPTION="Mozilla extension to provide GPG support in mail clients"
HOMEPAGE="http://www.enigmail.net/"
-KEYWORDS=""
SLOT="0"
LICENSE="MPL-2.0 GPL-3"
IUSE=""
if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
EGIT_REPO_URI="https://git.code.sf.net/p/enigmail/source"
S="${WORKDIR}/${P}"
else
- SRC_URI="http://www.enigmail.net/download/source/${P}.tar.gz"
+ if [[ ${PV} = *_beta* ]] ; then
+ SRC_URI="http://www.enigmail.net/download/beta/${P/_/-}.tar.gz"
+ else
+ SRC_URI="http://www.enigmail.net/download/source/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+ fi
S="${WORKDIR}/${PN}"
fi