summaryrefslogtreecommitdiff
path: root/x11-plugins/cputnik
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-30 08:49:38 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-30 08:49:38 +0100
commitb2be182d49eea46686b5cf2680d457df61e89dc4 (patch)
treec66442ced2011c5ca81c3114cc51041e314c6d33 /x11-plugins/cputnik
parente23cdda4dbb0c83b9e682ab5e916085a35203da5 (diff)
gentoo resync : 30.06.2018
Diffstat (limited to 'x11-plugins/cputnik')
-rw-r--r--x11-plugins/cputnik/Manifest3
-rw-r--r--x11-plugins/cputnik/cputnik-0.2.0-r1.ebuild34
-rw-r--r--x11-plugins/cputnik/files/cputnik-0.2.0-makefile.patch4
3 files changed, 38 insertions, 3 deletions
diff --git a/x11-plugins/cputnik/Manifest b/x11-plugins/cputnik/Manifest
index 45eb33dbbd04..96068d73a478 100644
--- a/x11-plugins/cputnik/Manifest
+++ b/x11-plugins/cputnik/Manifest
@@ -1,4 +1,5 @@
-AUX cputnik-0.2.0-makefile.patch 710 BLAKE2B b3b8e0f003fd3ef538b3e5efa49362323e7cc0751324e16b57c11b369b9969f31a796e0f734799fc4c6d738b47b356f333831d39e721423fa40e0c73a316ff83 SHA512 aad5f90f1e8717b539048ee8e0ba1260b7342c8a4f8e9b077b58e1c12b7f057c8f17bb17e94e3afd145dd4aeec746ccc94d339daef302b173f8a17baf565a9aa
+AUX cputnik-0.2.0-makefile.patch 709 BLAKE2B d40b5743f8bedf589d18e020374a38daf10563542c5e9f93514013880dceb16629c7ee83737ecdb6ff7dbde189697bebe6679b931e4cf5996245f2049a811f31 SHA512 4aff01e83540a7c08e777be8726b07fdb9d34798da957c85b9c27c87760854db335ed9f45b1dd250f63ae16c1e96c59615db79ca818f7233822103695458744d
DIST cputnik-0.2.0.tar.gz 17850 BLAKE2B 90824218a349d9b6cdf592cafe8dd29674f975a190a19a3dd6b941383d47f4fc492af339cbbb88240499363a1048b2564855d5a17caeaf53437fe34bf0d55ee1 SHA512 829d9d63f82a2d41c0160be575b3fb7840a5c295c6dd16702240a6aa104e557bff83936c46243e850edf918b41ddc22fd123dab7f5ffd6492302d60c374df55f
+EBUILD cputnik-0.2.0-r1.ebuild 639 BLAKE2B e14579a06a92c54d14521990de0e5f042057f06c26dbd0e0dc13fe975fa09bc8533abe2de66715a1278e51ae433271c1c8ed88547daa67b10f80a5de599c6b0a SHA512 cbdf01a2abc604c2a27856b7ff07006828733fedfbda5fab8fa71dbb564f2cf4d6438a65db911384f3a412fd7e441ebfc9e0aec916aa253de23dc919dffc7344
EBUILD cputnik-0.2.0.ebuild 733 BLAKE2B de4d82cd0be22b3bc3c3774e4e5adaaf3a396c49b81459cc1aca84607c04f30caa9b440dea0131a7edfa47df1b0bed96cc09050fc219a7f2d5b203da397c406c SHA512 4c2f93045d322ac64265c244ecc28595fa23373f94ddc6a8fdb014f3ab49afd2a8af5bccba0dd84bcae73798e85d5f72972320e2e3c680558553ac2563a7afb7
MISC metadata.xml 249 BLAKE2B ba223d81d4cf6b9ca1ba3a63e356bec0d9aa6f4cdf2ad3b29a6c97a6e5bad854154f8b9e6fc3d65d155c93daa706d03c84395b53951e3e326ffc19c8d0df0eb5 SHA512 1a1312bb0e9f74f1e3852218d8fd4817fbad3bc65633cecbe8735607bc33c1e05b414c2628ff3f6e24dfc4a3999de7191f6cdadd2161b03cf614d5b6f24fab8d
diff --git a/x11-plugins/cputnik/cputnik-0.2.0-r1.ebuild b/x11-plugins/cputnik/cputnik-0.2.0-r1.ebuild
new file mode 100644
index 000000000000..5c123773ab90
--- /dev/null
+++ b/x11-plugins/cputnik/cputnik-0.2.0-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="cputnik is a simple cpu monitor dockapp"
+HOMEPAGE="https://www.dockapps.net/cputnik"
+SRC_URI="https://www.dockapps.net/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+S=${WORKDIR}/${P}/src
+
+PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin cputnik
+ dodoc ../{AUTHORS,NEWS,README}
+}
diff --git a/x11-plugins/cputnik/files/cputnik-0.2.0-makefile.patch b/x11-plugins/cputnik/files/cputnik-0.2.0-makefile.patch
index 1eb1279b3bb3..b0c39ef2898b 100644
--- a/x11-plugins/cputnik/files/cputnik-0.2.0-makefile.patch
+++ b/x11-plugins/cputnik/files/cputnik-0.2.0-makefile.patch
@@ -1,5 +1,5 @@
---- Makefile.orig 2005-03-26 22:29:48.000000000 +0100
-+++ Makefile 2008-01-27 19:43:33.000000000 +0100
+--- a/Makefile 2005-03-26 22:29:48.000000000 +0100
++++ b/Makefile 2008-01-27 19:43:33.000000000 +0100
@@ -1,15 +1,15 @@
-CFLAGS = -Wall -Os