summaryrefslogtreecommitdiff
path: root/x11-plugins/asmon/asmon-0.71.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-plugins/asmon/asmon-0.71.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-plugins/asmon/asmon-0.71.ebuild')
-rw-r--r--x11-plugins/asmon/asmon-0.71.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/x11-plugins/asmon/asmon-0.71.ebuild b/x11-plugins/asmon/asmon-0.71.ebuild
new file mode 100644
index 000000000000..80bc8a5515bd
--- /dev/null
+++ b/x11-plugins/asmon/asmon-0.71.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit toolchain-funcs
+
+DESCRIPTION="WindowMaker/AfterStep system monitor dockapp"
+HOMEPAGE="http://rio.vg/asmon"
+SRC_URI="http://rio.vg/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ppc sparc x86"
+IUSE=""
+
+RDEPEND="x11-libs/libXext
+ x11-libs/libXpm
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto"
+
+S=${WORKDIR}/${P}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ sed -i -e "s:gcc:$(tc-getCC):g" "${S}"/Makefile
+}
+
+src_compile() {
+ emake clean || die "emake clean failed."
+ emake SOLARIS="${CFLAGS}" LIBDIR="${LDFLAGS}" \
+ || die "emake failed."
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc ../Changelog
+}