summaryrefslogtreecommitdiff
path: root/x11-misc/xwinwrap/xwinwrap-0_p4-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-misc/xwinwrap/xwinwrap-0_p4-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-misc/xwinwrap/xwinwrap-0_p4-r1.ebuild')
-rw-r--r--x11-misc/xwinwrap/xwinwrap-0_p4-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/x11-misc/xwinwrap/xwinwrap-0_p4-r1.ebuild b/x11-misc/xwinwrap/xwinwrap-0_p4-r1.ebuild
new file mode 100644
index 000000000000..2118202409f1
--- /dev/null
+++ b/x11-misc/xwinwrap/xwinwrap-0_p4-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="replace a desktop background with a movie or screensaver"
+HOMEPAGE="http://tech.shantanugoel.com/projects/linux/shantz-xwinwrap"
+SRC_URI="https://bazaar.launchpad.net/~shantanu-goel/xwinwrap/devel/tarball/4 -> ${P}.tar.gz"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ x11-libs/libXext
+ x11-libs/libXrender"
+
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${P}/${PN}/devel"
+
+src_unpack() {
+ default
+ mv * ./"${P}" || die
+}
+
+src_compile() {
+ local cmd="$(tc-getCC) -Wall ${CFLAGS} ${PN}.c -o ${PN} ${LDFLAGS} \
+ $(pkg-config --libs x11 xext xrender)"
+ ebegin $cmd
+ $cmd || die
+ eend $?
+}
+
+src_install() {
+ dobin "${PN}"
+}